Jump to content
KonstaT

[DEV][ROM][7.2.] LineageOS 13 (Android 6.0.1) for Huawei Y5

Recommended Posts

2 hours ago, Alonso98 said:

I just tested the patch. It still works and fixes the rotation and the camera, however it changes SELinux to disabled. The patch it's replacing the new kernel with the old one right?

Are you sure? I don't see how it's even remotely possible that it disables SELinux. :o That patch has a kernel I built for U23 specifically (it's dt image that actually ends up being different).

Old stock kernel is not compatible with these new builds anymore (wifi and fm won't work because they're not modules anymore). Need to build the kernel from source or drop support for U23.

2 hours ago, Seriel said:

Hey, I've got this installed (Just updated) and it's great but:

Does the Huawei Y560 support OTG? I can't find any information on the web. One OTG checker app says it does but another says it doesn't.
At first I thought it was because of CM, but after temporarily installing the stock ROM, it still won't work. (Back on CM now)

No, doesn't output power from the USB port I think. IIRC I also tested it with USB Y-cable and outside power source back in the day but still couldn't get any devices working.

Edited by KonstaT
  • Upvote 1

Share this post


Link to post
Share on other sites
2 hours ago, KonstaT said:

Are you sure? I don't see how it's even remotely possible that it disables SELinux. :o That patch has a kernel I built for U23 specifically (it's dt image that actually ends up being different).

Old stock kernel is not compatible with these new builds anymore (wifi and fm won't work because they're not modules anymore). Need to build the kernel from source or drop support for U23.

Yeah, look at these videos. It's pretty much what you already said (fm and wifi working before the patch but not after) but it shows that SELinux changed and then the bfq i/o scheduler was missing:

This is a fresh installation with the SELnux patch: https://www.dropbox.com/s/wqs7svp4odbk2wd/Screencast_2016-11-17-16-33-07.mp4?dl=0

And this is after installing the U23 patch: https://www.dropbox.com/s/dwaxz0bi5q78c9l/Screencast_2016-11-17-16-37-25.mp4?dl=0

 

If you need something else, I'll try to give as much information as possible

Share this post


Link to post
Share on other sites
8 hours ago, KonstaT said:

What procedure did you use to update? I'm just going to recommend everyone to install the SELinux permissive patch to avoid issues.

Contacts/Phone work just fine for me. Post logs next time, I don't do anything with screenshot.

After wiping.. Installed rom zip then selinux zip then gapps.zip.. 

Share this post


Link to post
Share on other sites
7 hours ago, Alonso98 said:

Yeah, look at these videos. It's pretty much what you already said (fm and wifi working before the patch but not after) but it shows that SELinux changed and then the bfq i/o scheduler was missing:

This is a fresh installation with the SELnux patch: https://www.dropbox.com/s/wqs7svp4odbk2wd/Screencast_2016-11-17-16-33-07.mp4?dl=0

And this is after installing the U23 patch: https://www.dropbox.com/s/dwaxz0bi5q78c9l/Screencast_2016-11-17-16-37-25.mp4?dl=0

 

If you need something else, I'll try to give as much information as possible

On 11/16/2016 at 6:42 PM, KonstaT said:

U23 patch needs an update as well but apparently there's not much point in making one. Someone test the CM12.1 patch first to see if it even works.

On 11/17/2016 at 8:31 AM, KonstaT said:

Yes, they released it last week after violating GPLv2 for 11 months. Please test the latest CM12.1 build and U23 patch there.

Err, I asked you to test the new CM12.1 build (cm-12.1-20161113-UNOFFICIAL-KonstaKANG-y560.zip) and the new CM12.1 U23 patch (cm-12.1-20161113-y560-u23.zip). U23 patches have always been specific to each build - you can't just some old file.
http://www.modaco.com/forums/topic/376808-devrom1311-cyanogenmod-121-android-511-for-huawei-y5/?do=findComment&comment=2279362

I need to build a CM13 kernel for U23 and make a new patch for this new CM13 build. No point in doing that if it doesn't even work in CM12.1 (in which case I'll have to drop support for U23 from now on).

Edited by KonstaT

Share this post


Link to post
Share on other sites

Tried flashing again BT still the same prblm after one reboot... Flashed 12.1 again.. Its fully fine..  Note: I set DPI to 180 in both zip n after restarting system ui I faced that prblm.. Is there any issue with dpi in cm13? BT alls r fine with cm12.1

Share this post


Link to post
Share on other sites
1 hour ago, Prince420 said:

Tried flashing again BT still the same prblm after one reboot... Flashed 12.1 again.. Its fully fine..  Note: I set DPI to 180 in both zip n after restarting system ui I faced that prblm.. Is there any issue with dpi in cm13? BT alls r fine with cm12.1

Like just said, I can't support installations with third party hacks/tweaks/etc.

There's an option to change dpi in 'Settings -> Display -> LCD density' so you're not even supposed to edit anything in the ROM anyway.

Edited by KonstaT

Share this post


Link to post
Share on other sites

It definitely does not work well xposed ..... try it in many ways .... old and new versions ...... may be installed and restart works fine ........... the problem is When a module is activated when restart it stays in the cyanogenmod logo ....... how can I deactivate the selinux ????

Edited by anmr2380

Share this post


Link to post
Share on other sites
2 hours ago, KonstaT said:

Like just said, I can't support installations with third party hacks/tweaks/etc.

There's an option to change dpi in 'Settings -> Display -> LCD density' so you're not even supposed to edit anything in the ROM anyway.

Yaa I changed that from settings>Display .. BT don't understanding y its creating such prblm

Share this post


Link to post
Share on other sites
13 hours ago, KonstaT said:

Err, I asked you to test the new CM12.1 build (cm-12.1-20161113-UNOFFICIAL-KonstaKANG-y560.zip) and the new CM12.1 U23 patch (cm-12.1-20161113-y560-u23.zip). U23 patches have always been specific to each build - you can't just some old file.
http://www.modaco.com/forums/topic/376808-devrom1311-cyanogenmod-121-android-511-for-huawei-y5/?do=findComment&comment=2279362

I need to build a CM13 kernel for U23 and make a new patch for this new CM13 build. No point in doing that if it doesn't even work in CM12.1 (in which case I'll have to drop support for U23 from now on).

My bad. I'm really sorry, I didn't read carefully. I just tested it from a fresh installation and SELinux was in enforcing mode. Camera, rotation and fm worked normally. I suppose that the patch still works

  • Upvote 1

Share this post


Link to post
Share on other sites
10 hours ago, Alonso98 said:

My bad. I'm really sorry, I didn't read carefully. I just tested it from a fresh installation and SELinux was in enforcing mode. Camera, rotation and fm worked normally. I suppose that the patch still works

That's good news. Thanks for testing.

Here's U23 for this CM13 build. Comes with SELinux set permissive.

cm-13.0-20161116-y560-u23.zip
https://www.androidfilehost.com/?fid=385035244224399513
md5:1551f6d28cc6911087a032efaa4b33a3

  • Upvote 1

Share this post


Link to post
Share on other sites
45 minutes ago, Prince420 said:

Konsta can u check the prblms?? Not understanding this thing..  Tried the cm13 today.. BT same prblms again.. 

What is there to check when you haven't posted the logs like I asked?!

Already went to 'Settings -> Display -> LCD density' and changed dpi to 180. Restarted SystemUI, rebooted device. Phone works, Contacts works - no problem whatsoever!

Here's solutions to your problem:
1) Don't use broken themes.
2) Don't set dpi to 180 if it's causing you problems.
3) Use some other ROM if the experience is so awful for you.

  • Upvote 1

Share this post


Link to post
Share on other sites
On 19/11/2016 at 1:01 AM, KonstaT said:

That's good news. Thanks for testing.

Here's U23 for this CM13 build. Comes with SELinux set permissive.

cm-13.0-20161116-y560-u23.zip
https://www.androidfilehost.com/?fid=385035244224399513
md5:1551f6d28cc6911087a032efaa4b33a3

Ok, I just tested CM 13 with the patch and things like camera, fm, rotation and wifi worked as expected, however for some odd reason my sim wasn't being detected. I double checked that the dual sim was activated, and indeed it was, so I was having problems with RIL. I'm not good understanding logcats but I found these lines:

11-20 16:40:51.378   426   426 E PerMgrLib: modem get service fail

11-20 16:40:51.378   426   426 E PerMgrLib: QCRIL failed to register for modem

However, from a video I posted you previously, I remember that RIL was working on the newest version of CM 13 but with old patch, so I tried installing the old patch, and then the new patch and it fixed it. I don't know what kind of problems could cause this, but right now is working OK

Share this post


Link to post
Share on other sites

Hi all,

thanks KonstaT for building this rom.

I flashed Y560 L01 with cm-13.0-20161116-UNOFFICIAL-KonstaKANG-y560.zip yesterday and tested it a bit.

The only flaw I found was somewhat jumpy scrolling. When moving webiste/app menu in vertical direction on finger release there is sometimes additional movment of the screen. Enabling forced 2D rendering in DevOpt does not make a difference.

Did anyone notice something similar?

best regards

Share this post


Link to post
Share on other sites

Hello to all .... I found the solution to my two problems .... the xposed and the link2sd app really very easy ............... for the xposed after so much try me I ran a modified version of xposed v87-sdk23-arm-test1 ............... and for the link2sd app it was just unmounting the partition in storage settings ......... ...... and problems solved .............

Share this post


Link to post
Share on other sites
On 11/20/2016 at 5:55 PM, odigPL said:

I wanted to move from cm12 to cm13 but after wiping and installations I do not have access to /sdcard

can i fix it somehow?

Logs? Like said, I don't do anything with screenshots or pictures.

Did you follow installation instructions in the third post of this thread? You are talking about internal sdcard (= /sdcard), right?

On 11/21/2016 at 4:24 AM, Alonso98 said:

Ok, I just tested CM 13 with the patch and things like camera, fm, rotation and wifi worked as expected, however for some odd reason my sim wasn't being detected. I double checked that the dual sim was activated, and indeed it was, so I was having problems with RIL. I'm not good understanding logcats but I found these lines:

11-20 16:40:51.378   426   426 E PerMgrLib: modem get service fail

11-20 16:40:51.378   426   426 E PerMgrLib: QCRIL failed to register for modem

However, from a video I posted you previously, I remember that RIL was working on the newest version of CM 13 but with old patch, so I tried installing the old patch, and then the new patch and it fixed it. I don't know what kind of problems could cause this, but right now is working OK

Or you could have just rebooted. Flashing old patch and then the new patch makes no difference whatsoever.

Edited by KonstaT

Share this post


Link to post
Share on other sites

I have this bug with the calls only happens when the superuser is enabled there are times when calling the screen stays black sometimes with the power button returns, same when they call and when the screen does not restart the cell uses the dual dual sim Of nightling of this forum how can I make a bug report if I reboot help please

Share this post


Link to post
Share on other sites
On 11/25/2016 at 1:00 AM, anmr2380 said:

I have this bug with the calls only happens when the superuser is enabled there are times when calling the screen stays black sometimes with the power button returns, same when they call and when the screen does not restart the cell uses the dual dual sim Of nightling of this forum how can I make a bug report if I reboot help please

1. Make clean installation following instructions in the third post of this thread (no Xposed Framework, no link2SD, etc!!!).

2. Reproduce your issue and record a logcat (e.g. 'adb logcat').

3. Write a report using full sentences and language that other people can understand as well. Attach the logcat you recorded to your issue report.

Share this post


Link to post
Share on other sites
On 23.11.2016 at 3:04 PM, KonstaT said:

Logs? Like said, I don't do anything with screenshots or pictures.

Sure. I put them as attachments

I did follow the instructions and yes i'm talking about internal sdcard

 

logcat2.txt

Share this post


Link to post
Share on other sites
3 hours ago, Prince420 said:

konsta any other rom u have for this device?? or any sgsn abt similar device etc??

Yes, CM12.1. Second question makes no sense whatsoever. Maybe try using full words next time...

Edited by KonstaT

Share this post


Link to post
Share on other sites

Yaa.. I know that.. Cos currently using cm12.1 ..  As i checked on net that porting rom is v easy if i have similar devices with the same processor etc.. Do u have idea about devices which are similar to this one?? 

Share this post


Link to post
Share on other sites
8 hours ago, Prince420 said:

Yaa.. I know that.. Cos currently using cm12.1 ..  As i checked on net that porting rom is v easy if i have similar devices with the same processor etc.. Do u have idea about devices which are similar to this one?? 

Yeah, it's super easy and that's why all the cool kids are doing it. :P

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.