Jump to content
KonstaT

[DEV][ROM][28.1.] CyanogenMod 12.1 (Android 5.1.1) for Chuwi Vi10 Plus, Hi10 Plus, Hi10 Pro, Hibook, Hibook Pro & Hi12

Recommended Posts

17 minutes ago, Javi1313 said:
Hello, I do not work the screen rotation on android, I have a chuwi hi12. Is there a solution for this? Thanks greetings

Have you installed the correct compatibility patch?

Share this post


Link to post
Share on other sites
53 minutes ago, Javi1313 said:

Sorry, the state looking for the forum and I do not get the right one. I have remixOs,

Everything works perfectly, the only problem is the rotation. Thanks

???

Which Hi12 compatibility patch did you install and have you tried with the other one? What stock firmware version was your device shipped with?

Share this post


Link to post
Share on other sites

I installed remix os 2.0 (Android 5.1.1) instead of the android that came on the tablet (5.0) from the official installer of intel (Phone flash tool). The installation has gone smoothly, everything works correctly in remixes, the only problem is the rotation. Thanks for your interest

Share this post


Link to post
Share on other sites
1 hour ago, Javi1313 said:

I installed remix os 2.0 (Android 5.1.1) instead of the android that came on the tablet (5.0) from the official installer of intel (Phone flash tool). The installation has gone smoothly, everything works correctly in remixes, the only problem is the rotation. Thanks for your interest

That's none of my problem then. I only provide support for my custom ROMs and you have posted on a completely wrong place.

You've installed a ROM that is not meant for your device! If you install e.g. this Remix OS with the right compatibility patch, I'm sure everything will work. http://konstakang.com/devices/chuwi_vi10plus/RemixOS/

Edited by KonstaT

Share this post


Link to post
Share on other sites
Updated with your rom remix os and the standard patch without serial number (my model is HQ64G45170104616) and the same rotation problem continues.
 What can it be? Thanks for your time

 

Share this post


Link to post
Share on other sites
47 minutes ago, Javi1313 said:
Updated with your rom remix os and the standard patch without serial number (my model is HQ64G45170104616) and the same rotation problem continues.
 What can it be? Thanks for your time

 

3 hours ago, KonstaT said:

???

Which Hi12 compatibility patch did you install and have you tried with the other one? What stock firmware version was your device shipped with?

 

 

Share this post


Link to post
Share on other sites

Hi, I am working on a new hi10 plus. The rom date from build.prop is 201705 (LQ64G42170903xxxx).

Everything rocks but the camera :( Looking at my backup of the firmware it  is the same hardware you have a patch for (GC2355 and gc2355b). The rear camera works with Open Camera and other apps (such as the bar code reader) but the front camera does not.

I merged the patch into the stock firmware and diff against the stock image just comparing system folders basically, there are some differences in configuration files and some xml files missing. I will try copying these over and see if they help. Is there anything else I could look for ? I'm not sure what to copy and what not to copy from the original firmware (are the aiqb files in atomisp copied from the original firmware or do you generate them).
Many thanks for the work on this and very grateful for any time you spend responding.

Edited by lowearthorbit
see next post. I fixed it.

Share this post


Link to post
Share on other sites

Fixed it! - both cameras work now.
I took a punt and copied these 2 xml files on to the device (remounted /system rw first).
    /system/etc/media_profiles_gc2355b.xml
    /system/etc/media_profiles_gc2355.xml

Looking at the insmod these seemed to be likely candidates :D
This post seemed to suggest that these files might be useful to the apps, lsmod showed that 
the modules were loaded. I hadn't got as far as looking for errors in logs.

I hope this helps someone :D

If you are reading this and going how?
Connect to your adb computer (there are plenty of guides on how to get adb running).
Pick the USB debug notification out of your notifications, it should take you to delevoper options where you can enable root for adb.
remount system rw ( adb root; adb shell; mount -o remount,rw /system; exit)
either :
grab the files from the system image (download the firmware for the hi 10 plus from chuwi forums).
or : grab your backup and unpack system backup, or like me use f7 on the keyboard with a kali linux boot stick, boot Kali in forensic mode, dd the android_system partition (back the whole thing up at the same time).
then :
get system.img and open it with 7zip (on 'linux 7z x system.img' in a folder)
in system/etc grab the files listed above

push them to the rom
adb push media_profiles_gc2355b.xml /system/etc
adb push media_profiles_gc2355.xml /system/etc

kill any camera apps and voila,
reboot the device and remove root priv from adb in the developer options


 

Share this post


Link to post
Share on other sites
14 hours ago, lowearthorbit said:

Fixed it! - both cameras work now.
I took a punt and copied these 2 xml files on to the device (remounted /system rw first).
    /system/etc/media_profiles_gc2355b.xml
    /system/etc/media_profiles_gc2355.xml

Looking at the insmod these seemed to be likely candidates :D
This post seemed to suggest that these files might be useful to the apps, lsmod showed that 
the modules were loaded. I hadn't got as far as looking for errors in logs.

I hope this helps someone :D

If you are reading this and going how?
Connect to your adb computer (there are plenty of guides on how to get adb running).
Pick the USB debug notification out of your notifications, it should take you to delevoper options where you can enable root for adb.
remount system rw ( adb root; adb shell; mount -o remount,rw /system; exit)
either :
grab the files from the system image (download the firmware for the hi 10 plus from chuwi forums).
or : grab your backup and unpack system backup, or like me use f7 on the keyboard with a kali linux boot stick, boot Kali in forensic mode, dd the android_system partition (back the whole thing up at the same time).
then :
get system.img and open it with 7zip (on 'linux 7z x system.img' in a folder)
in system/etc grab the files listed above

push them to the rom
adb push media_profiles_gc2355b.xml /system/etc
adb push media_profiles_gc2355.xml /system/etc

kill any camera apps and voila,
reboot the device and remove root priv from adb in the developer options

I've added CM12.1 and Remix OS compatibility patches for Hi10 Plus devices shipped with 20170504 firmware to my site.

Those two media_profiles_*.xml configs do absolutely nothing with CM12.1 (see https://github.com/CM-CHT/android_frameworks_av/commit/ec43dabccae4fc3d5dc482fd2b95c15eff102c0e).

Well done figuring out the rest. :)

  • Like 1

Share this post


Link to post
Share on other sites

I just got my new Chuwi Hi10 Plus, but with build version: 20171020

I don't see a disable dmverify or compatibility patch for this version. Is there any way to use this rom?

Share this post


Link to post
Share on other sites
On 12/22/2017 at 6:41 PM, PP23 said:

I just got my new Chuwi Hi10 Plus, but with build version: 20171020

I don't see a disable dmverify or compatibility patch for this version. Is there any way to use this rom?

Is that stock firmware available for downloads on Chuwi forum or did you make a backup in TWRP? I don't know if they've changed some hardware again or will it work with a previous compatibility patch. I'll add 20171020 patches/etc on my site once the stock firmware is available.

It seems there's nothing but spam in MoDaCo these days so this will be my last post on this forum. You know where to reach me. :)

Share this post


Link to post
Share on other sites
1 hour ago, KonstaT said:

It seems there's nothing but spam in MoDaCo these days so this will be my last post on this forum. You know where to reach me. :)

Does this mean the end of updates for Chuwi Vi10 Plus too? 

Share this post


Link to post
Share on other sites

Hi,

First of all, cheers to all of you. I'm new here.

This morning I received a Chuwi Hi10 pro with serial HQ64G42171XXXXX.

As Android presented problem of connectivity to App Store, I've tried to follow the tutorial.

Everything seemed to be fine during the process but right now android won't boot. I can use windows but android booting gets stucked.

I've used cm-12.1-20170128-chuwi_vi10plus-Hi10Pro-HQ64-20170720.zip (serial no HQ64G42170900000->).

The main problem is that I can't reinstall Android again.

Do you have any ideas?

Thanks in advance.

Share this post


Link to post
Share on other sites

Is it possible to somehow add USB-Ethernet adapter support under Android for my Chuwi Hi12 tablet?

Can it be a solution if I change the stock Android to the RemixOS or to the CyanogenMod 12.1?

Thanks for your help in advance!

Share this post


Link to post
Share on other sites

Hello @KonstaT the link of Gapps is not available to download, error goes out. Can you recover that download of the necessary Gapps to install the Rom?
Thank you.

Editor: Thursday the 8th and the download seems to work.

Edited by santi.sc

Share this post


Link to post
Share on other sites

Hi, I'm trying to install this, but the twrp seems to have trouble with my partitions: it can't find partitions to wipe, nor backup.

I used a file called "hi12-TWRP-recovery.img" as recovery image (booted, not flashed)

I have in the past flashed the stock rom with the modified gpt.bin in order to remove windows and use all the space for android.

 

Any hints?

Share this post


Link to post
Share on other sites

Hi ! Is there a way to make Magisk & SafetyPatch working on this one ? When I install them, it get stuck on a bootloop while optimizing apps.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.