Jump to content

MPx220 and BT ActiveSync


Guest dling1971
 Share

Recommended Posts

I am having difficulty setting up BT activesync........I have gone into options then pc settings and then advanced and the only choice is USB???? What gives? Any help would be greatly appreciated.

Link to comment
Share on other sites

True, but my BT ASync still doesn't work. I keep seeing that you have to go to Start -> Congfigurations -> BT Settings. I don't see that menu option on the Cingular Branded phone i have from BB.

Link to comment
Share on other sites

It's not. Try this, it's the only way mine worked...

1. delete the partnership made on computer and under bluetooth in settings menu on phone

2. set up bluetooth PC software to have a specific com port open for incoming.

3. open pc activesync and set same com port to allow connection.

4. THEN turn phone bluetooth on discoverable, and have PC search for device to establish partnership with and follow through the instructions

Mine only worked with activesync if I made a partnership AFTER I specified which COM port to use with PC bluetooth AND PC activesync.

Hope that helps!!!

Link to comment
Share on other sites

You also need to make sure Activesync is listening on the correct COM port on your PC. Your PC's Bluetooth driver assigned it a COM port beyond your existing ports, possibly COM6-9. If Activesync is only paying attention to COM1 or COM2, you won't be able to connect to it via Bluetooth and your device won't even see Activesync as a valid service offered by your PC.

Link to comment
Share on other sites

Welcome to the board Wes ^_^

Like I already said above, you need to set the PC to let a specific COM port accept incoming connections, and THEN allow Activesync to listen to the same COM port (look on the "connection settings" menu). It must be done in that order, and for the mpx220 it seems this needs to be done BEFORE the device is paired to the PC.

Link to comment
Share on other sites

My experience last night with an Anycom Bluetooth CF card on my XP SP2 machine using anycoms BT stack was fascinating.

I had already used IR successfully to AS my 220 with the PC, so I had an existing connection and my AS connection settings were set to "IR".

I used the Anycom "qucik phone connect" wizard to set up a BT DUN GPRS modem to the 220(which works great).

Following the advice here and elsewhere, I then set up AS connections to use COM5 (where my BT DUN was configured), and modified the smartphone AS advanced options to use Bluetooth. Finally, just going on a whim, I modified the Bluetooth device name on my phone from the default "anycom (computer name)" to just be "computer name" and made certain that said computer name matched that in the phone's AS settings.

Of course pressing Sync via bluetooth on the phone very quickly returned an error. That's where the interesting thing happened. I selected "Get Connected" on the desktop computer and let it search (mostly vainly) for the phone while I repeatedly pressed "sync via bluetooth" on the phone AS. On the fifth round of "get connected" and many many "sync via BT" presses I was rewarded with SUCCESS. The very interesting part is it used COM6 on the desktop, which according to anycom's interface is paired with "<none>" (DUN is paired at COM5).

After the initial struggle, it now syncs via BT with a single press of the phone's sync via BT option. And GPRS over BT still works too. woo-hoo!

The strategy above by gsr264 is probably simpler. Mine has the advantage of not requiring the AS device be deleted (which in my case always generates a few duplicate contacts).

Link to comment
Share on other sites

It's pretty much a crapshoot. I now believe that it's probably not a good idea to use whatever drivers and software came with your BT dongle/card. My office computer works fine and dandy with just the SP2 drivers, while my home PC is not very friendly with the bundled software/driver set.

Link to comment
Share on other sites

l agree. at least the sp2 drivers given a consistent interface.

by The way. I had to change my smartphone AS settings back to USB to get a USB sync working again.but after that, I did NET have to change then back to BT to use BT. very strange. it now does both. No setting changes required.

Link to comment
Share on other sites

mine still wont find it, heres exactly what i did.

- i turned off all my firewalls.

- i delete the partnership made on computer and under bluetooth in settings menu on phone

- i uninstalled and reinstalled both the bluetooth device and activesync then - set up bluetooth PC software to have a specific com port open for incoming (com7 is what it chose)

- open pc activesync and set same com port to allow connection (com 7)

- THEN turn phone bluetooth on discoverable, and have PC Search for device to establish partnership

- the pc finds the phone, has me enter a passkey, then connects

- the phone responds, asks for the passkey, then confirms the pc name, then connects

- the phone says it is connected when i go to show bluetooth devices > properties, but the only service that is listed is dial up networking (on COM 6?)

- it will not sync using active sync.

i can go back and use active sync with IR no problems.

can anyone help solve this problem?

Link to comment
Share on other sites

You DO want to pair up your PC and phone to use DUN on a COM port before you try BT AS (DUN is a superset of SPP).

After pairing and setting up a DUN COM port, you might try to select File->Get Connected on the desktop and let it seach everywhere at once. At the SAME TIME try repeatedly selecting Connect via Bluetooth on the phone.

If it doesn't work the first time, turn off BT on your phone to break the connection, wait a half minute, turn BT back on, then again select Get Connected on the desktop and Connect via Bluetooth on the phone.

A big pain, but once you get a successful pairing, it will be easy from then on.

(And why is it so hard we might wonder? I suspect Cingular attempted -- and luckily failed -- to prevent AS over BT by removing the SPP profile and the Setup BT connection menu from AS. But we commoners will never know).

Link to comment
Share on other sites

I use AS over BT using the Serial port profile, not DUN and it works, although if the laptop BT has been off a while it takes some fancy footwork to get it all connected again. Basically, starting from scratch:

1. I established the pairing from phone to laptop (and that seems to matter because if I start the pairing from the laptop the serial port does not get created)

2. select COM8 for AS port

3. sync the phone via USB cable to set up AS partnership

4. go to AS PC settings on phone and enable bt sync

5. on phone just go to activesync and "connect via bluetooth"

6. go to AS PC settings on phone and change back to USB

I've reset my phone several times now and that procedure works every time. The glitch is that AS on the laptop will set itself back to COM3 now and then so it takes a little fiddling with it from time to time.

Link to comment
Share on other sites

should i not install the software that came with my belkin adaptor and just use the XP provided methods? should i install both, in a different forum it said that i need to go into the devic manager and switch the drivers for the adaptor to the specific one given on the disk and not use any windows drivers, true? this is driving me mad.

Link to comment
Share on other sites

Definately don't try with both drivers at once! :-)

I'm using the vendor provided drivers because XP doesn't support my old BT card. I've heard that the other reason to use the vendor drivers (widcomm in particular) is because XP doesn't support the headset protocol; but that's only valid if you intend to use your BT headset with your PC (no phone at all).

Honestly I don't think it matters which drivers you use. Just keep trying and rechecking your settings (I took a half hour before it *hit* for me).

Link to comment
Share on other sites

  • 1 month later...

Been reading this and other forums trying to get Activesync to work over BT and would like to know from anyone how you open up connection settings in Activesync when there is no partnership. I have the latest download, but since there is no partnership it goes to automatically set up a connection and just spins it's wheels.to

The PC is set to COM8, the MPX 220 has a connection with the PC because I can do file transfers.

Pleas help, as I am about to have a coniption!

Thanks,

Link to comment
Share on other sites

have you created an ActiveSync partnership using the supplied USB cable? before you can setup a BT connection, you have to first connect using the USB cable. from there you should be able to use the partnership (you created with the cable) to configure BT connections. if you've created a partnership, then go to File-->Mobile Device and select the partnership; then File--> Connection settings to set up the BT com port.

Link to comment
Share on other sites

did you goto File-->Connection Settings and ensure that you've selected the com port that your Bluetooth device is using? you may have to remove then reestablish existing MPx220 bluetooth-pairing (on your PC and on the MPx220). once you've reestablished the pairing (between the MPx220 and your PC), make sure ActiveSync is using the correct com port, then try connecting to ActiveSync via aBluetooth connection... my suggestion is based on what i had to do to get mine to work. you might check out this site for more tips...

Link to comment
Share on other sites

I swear I am going to pull my hair out! This should not be the F*%*ing tough.

Anyway, trying to set this up on a machine that already has an established AS partnership via USB as suggested by cortez. When I check the BT software and check which COM port it is looking at it has changed to COM 6. Of course when I open Activesync File-->connection setting it does not list a COM Port 6 for me to choose from!

If anyone has any more suggestions I would love to hear them before I jump off the wireless bridge.

Using Widdcom BT software BTW.

Link to comment
Share on other sites

Have the active sync working on my laptop. Had to remove the driver and software that came with my laptop. Use the windows xp driver. The only problem is, I can only connect with the bluetooth once. If I reboot the pc, I have to reconnect the bluetooth all over again. I have the same problem with the bluetooth moto car kit. Can connect once, mabe twice.

It turns the bluetooth off on the mpx. The home screen shows the bluetooth active, but when you go to the settings it is turned off. Looks like a big bug in the bluetooth. If moto would have used ther bluetooth instead of Microsofts maybe it would have worked. When I coneccted with another moto phone to the car kit everything works fine. Hope moto comes out with a fix soon!!

Link to comment
Share on other sites

  • 2 months later...

You saved the day!! I have spent way way way too long trying to get Bluetooth ActiveSync to work and this was the fix! Thank you so much!!

It's not. Try this, it's the only way mine worked...

1. delete the partnership made on computer and under bluetooth in settings menu on phone

2. set up bluetooth PC software to have a specific com port open for incoming.

3. open pc activesync and set same com port to allow connection.

4. THEN turn phone bluetooth on discoverable, and have PC search for device to establish partnership with and follow through the instructions

Mine only worked with activesync if I made a partnership AFTER I specified which COM port to use with PC bluetooth AND PC activesync.

Hope that helps!!!

<{POST_SNAPBACK}>

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.