Jump to content

I did it! TomTom Mobile 5 with ANY BT GPS !


Guest hueznar
 Share

Recommended Posts

Well, at least I get my MPx220 working with TomTom Mobile 5 and any BlueTooth GPS. I tested ir with 4 different GPS and all of them are working fine. I can't believe it.

I'm writing all steps to follow.

needed to modify the registry, the Bluetooth Devices, and a bit more.

Let my order the steps.

Regards,

Link to comment
Share on other sites

  • 2 weeks later...
Well, at least I get my MPx220 working with TomTom Mobile 5 and any BlueTooth GPS. I tested ir with 4 different GPS and all of them are working fine. I can't believe it.

I'm writing all steps to follow.

needed to modify the registry, the Bluetooth Devices, and a bit more.

Let my order the steps.

Regards,

<{POST_SNAPBACK}>

Fine. I need to configure mine cause I'm having some problems. When I quit from TomTom mobile 5 my settings are not saved. And I have to setup the seriel port for GPS each time I open TomTom. Was your problems like these?

Please post step-bystep what you have made. Thanks

Link to comment
Share on other sites

Well, at least I get my MPx220 working with TomTom Mobile 5 and any BlueTooth GPS. I tested ir with 4 different GPS and all of them are working fine. I can't believe it.

I'm writing all steps to follow.

needed to modify the registry, the Bluetooth Devices, and a bit more.

Let my order the steps.

Regards,

<{POST_SNAPBACK}>

Fine. I need to configure mine cause I'm having some problems. When I quit from TomTom mobile 5 my settings are not saved. And I have to setup the seriel port for GPS each time I open TomTom. Was your problems like these?

Please post step-bystep what you have made. Thanks

Link to comment
Share on other sites

I got TomTom Mobile 5 working with an Adapt Bluetooth GPS and activesync works through bluetooth!

If it hasn't worked for you yet then try this:

use a registery editor and go to

HKEY_LOCAL_MACHINE\SOFTWARE\TomTom\GPS Engine\
Change the device name to the default GPS name (when you pair the gps)
Device = BT GPS
also
Enabled = 1

now pair the gps and pc and don't activate com6. (I didn't atleast)

Connect to activesync with bluetooth.

Now start TomTom... and go to the GPS Device... and then wait till it finds the device.

You should then be able to Use tomtom and use activesync.

But if you start tomtom first you will have to close tomtom before you can use activesync through bluetooth.

I am using rom 3.46 so I don't know if it works for other roms. But I guess activesync uses a default com and the gps will find a free com to use.

Link to comment
Share on other sites

use a registery editor and go to

HKEY_CURRENT_USER\ControlPanel\Bluetooth\
Change the active com from 0 to 1 or 2 depending on how many active connections are needed.
IsBthVCOMActive = 2
VComsetup = 0
IsBthVCOMSetup = 0

Link to comment
Share on other sites

I got TomTom Mobile 5 working with an Adapt Bluetooth GPS and activesync works through bluetooth!

If it hasn't worked for you yet then try this:

use a registery editor and go to

HKEY_LOCAL_MACHINE\SOFTWARE\TomTom\GPS Engine\
Change the device name to the default GPS name (when you pair the gps)
Device = BT GPS
also
Enabled = 1

now pair the gps and pc and don't activate com6. (I didn't atleast)

Connect to activesync with bluetooth.

Now start TomTom... and go to the GPS Device... and then wait till it finds the device.

You should then be able to Use tomtom and use activesync.

But if you start tomtom first you will have to close tomtom before you can use activesync through bluetooth.

I am using rom 3.46 so I don't know if it works for other roms. But I guess activesync uses a default com and the gps will find a free com to use.

<{POST_SNAPBACK}>

i can't find:

HKEY_LOCAL_MACHINE\SOFTWARE\TomTom\GPS Engine

tomtom is not in SOFTWARE.

strange?

Link to comment
Share on other sites

i can't find:

HKEY_LOCAL_MACHINE\SOFTWARE\TomTom\GPS Engine

tomtom is not in SOFTWARE.

strange?

<{POST_SNAPBACK}>

I have it in my registry... maybe got it after I started Tom Tom 5 it adds things to the reg.?

Link to comment
Share on other sites

I have it in my registry... maybe got it after I started Tom Tom 5 it adds things to the reg.?

<{POST_SNAPBACK}>

Maybe,i don't know.

Before i had installed the 3.46 rom,it worked fine with a adapt bt gps(1.43 rom).

now it doesn't work.

What kind of comprt. must i make a incoming or a outgoing?

Link to comment
Share on other sites

Hmm ckk i followed ur instructions. Problem is my c500 says its connected with the BT GPS, but TomTom5 still says no GPS device !

use a registery editor and go to

HKEY_CURRENT_USER\ControlPanel\Bluetooth\
Change the active com from 0 to 1 or 2 depending on how many active connections are needed.
IsBthVCOMActive = 2
VComsetup = 0
IsBthVCOMSetup = 0

<{POST_SNAPBACK}>

this i dont see..

hell i spend all day trying to get Tomtom5 seeing the BT GPS, i just dont get it to work :)

Link to comment
Share on other sites

Hi, i have the same problem. When i used the 1.28 version of firmware my Tomtom worked fine. Now after upgrade to 3.46 tomtom could not recognize the GPS reciver... :)

But i'm sure that this is a registry problem..but i have not any idea :D :D

Link to comment
Share on other sites

Hi, i have the same problem. When i used the 1.28 version of firmware my Tomtom worked fine. Now after upgrade to 3.46 tomtom could not recognize the GPS reciver... :)

But i'm sure that this is a registry problem..but i have not any idea :D :D

<{POST_SNAPBACK}>

i had the same problem,but after i flashed the Cingular-1.43 the problem was gone.No mediaplayer 10 but who cares.

Link to comment
Share on other sites

Yeah i see.

But i think that the problem is in some registry key... because if i perform a restore of my personal data from my 1.28 ITA rom to 3.46 asian rom (using Sprite Backup) my GPS works fine!!

So the problem isn't the version of Rom used

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...
Ok, now my mpx220 with 3.46 firmware works with tom tom 5!!!

<{POST_SNAPBACK}>

Netmaster,

If it doesn't contain any personal info could you please send me a copy of your sprite backup? TomTom 5 was working fine on my mpx220 before I updated to 1.47, but it now seems to be having major problems with Bluetooth and it's COM ports.

Cheers,

Paul.

Link to comment
Share on other sites

I have the same problem on my Qtek 8080 with TomTom Mobile 5.

I register my Fortuna BT GPS Receiver, I start TomTom and it works fine until I quit.

But next time I start TomTom, it say "no gps device" so I have to re-register my GPS Receiver.... and so on every time. ;)

I tried all combinations of serial ports :|

With old TomTom Mobile all worked fine, it's very annoying! :?:

Anybody could help me, please? :)

Edited by AlexMessoMalex
Link to comment
Share on other sites

I have the same problem on my Qtek 8080 with TomTom Mobile 5.

I register my Fortuna BT GPS Receiver, I start TomTom and it works fine until I quit.

But next time I start TomTom, it say "no gps device" so I have to re-register my GPS Receiver.... and so on every time. ;)

I tried all combinations of serial ports :|

With old TomTom Mobile all worked fine, it's very annoying! :?:

Anybody could help me, please? :)

<{POST_SNAPBACK}>

Well the actual setup for me changed depending on what phone ROM I was running. You could try the following steps as it worked for me:

Exit TomTom

Delete all GPS pairings in the bluetooth settings

Now go to configurations and enable com port 7 (I think that is the outgoing one, but not sure). You will probably get a message to now pair a device that is COM7 compatible or something.

It will probably then start the bluetooth settings options, so pair your GPS receiver and do NOT change the name from the default one.

Start TomTom and fingers crossed it will find your receiver - my version of TomTom allows me to select a third party receiver in the preferences.

Link to comment
Share on other sites

Exit TomTom

Delete all GPS pairings in the bluetooth settings

Now go to configurations and enable com port 7 (I think that is the outgoing one, but not sure).  You will probably get a message to now pair a device that is COM7 compatible or something.

It will probably then start the bluetooth settings options, so pair your GPS receiver and do NOT change the name from the default one.

Until now, all perfect !

The problem is there :

Start TomTom and fingers crossed it will find your receiver - my version of TomTom allows me to select a third party receiver in the preferences.

I start TomTom and I go into preferences - show GPS status - configure - other bluetooth gps - select I read : "Please pair your Bluetooth GPS and your PDA/Smartphone. For details, consult the documentation for your GPS receiver and your PDA/Smartphone", but I paired my Fortuna BT GPS, I see it on Bluetooth settings :)

I don't understand why TomTom developers programmed this strange function that sometime deletes GPS pairing, it's completely stupid :x

I'm trying since two days ago :cry:

Edited by AlexMessoMalex
Link to comment
Share on other sites

May be I found a solution :

- I entered in BTSerialPortSetup and enabled COM7 outbound port (COM6 was already enabled)

- I paired my GPS device and renamed it in "BT GPS" instead of "TomTom Wireless GPS" (my device is made by Fortuna and it's default name is "Clip-On BT GPS")

- I run TomTom, I entered in settings and selected "other GPS receivers" so it thought for several seconds and finally it recognized my device.

Now my pairing is not deleted :)

It seems running correctly, when I start TomTom I have to wait for 5 or 6 seconds before it detect my device; by seeing BT led on my GPS it seems TomTom detect everytime all GPS it can recognize by polling algorithm.

The only one thing I don't understand is everytime I exit TomTom I find bluetooth disabled but it's a very small problem for me; may be it's an automatic TomTom function to improve battery performances.

Thank you for your support anyway !!!

I'm happy 8)

Link to comment
Share on other sites

This may be somewhat OT, but can TTMobile 5 recognize maps from TT5 for PPC? Is there anyway to "trick" it into doing this? I'm in the U.S., and would like to use this if possible. Thanks!

Link to comment
Share on other sites

:arrow: TomTom Mobile 5 works with MPx220 and BT GPS Nemerix ChipSet but hangs :??:

Since April 2005 I am a happy user of the Motorola MPx220 and purchased a BT GPS device with a Nemerix ChipSet, 16 channels. With this, I am running TomTom Mobile 5 with the Benelux Plus card (571) and runs very wel... :(

But nevertheless, sometimes TomTom hangs suddenly (not often, but once a week or so) and the screen does not respond anymore and stops navigating. I am still able to quit/minimize (don't exactly know what I do) the program but after this it is very hard to startup again (after some soft resets and try's it works again)... :?:

What I also experienced after the hanging is that in my Benelux folder there are sometimes several additional maps and files with weird characters that cannot be deleted. I have to plug-in my miniSD card in the reader to delete these folders. With these folders in the Benelux folder, TomTom is not able to recognize the Benelux map... :cry:

I use the modified .exe file and use *.ov2 files to detect the speed-camera's. Maybe it has to do something with this.... or maybe that my miniSD card is FAT32 formatted... should it be FAT?? Has anyone also experienced these problems and/or does anyone know a solution? Thanks in advance... ;) :)

Edited by Troxelke
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.