Jump to content

Garbled / Problem Voice Reception C500 4.2.1.2


Guest bob.chandler
 Share

Recommended Posts

Guest bob.chandler

Recently received third replacment C500;

Rom Update 4.2.1.2

when calling it sounds garbled to anyone receiving the call - like using a voice changer. On instant call back - problem solved but with lots of echo instead!

Called Orange - suggested hard reset (softkeys and power on - press '0') - problem not solved.

Orange are aware - refuse point blank to replace phone again - have to live with it - bloody useless!!

Can anyone help - suggest another fix??

Thanks.

Link to comment
Share on other sites

i have exactley the same problem with my c500 had it replaced twice now by orange in the last 2 months every phone same problem ad different rom versions on all of them been told i can change it again but will cost me another £15 not going to pay to change it when orange know there is a problem with them waiting for M5000 to come out.

And it does not matter if i'm phoning a landline or a mobile.

Edited by gcarte
Link to comment
Share on other sites

Guest bob.chandler

It happens in all locations no matter what phone you are calling - landline or mobile. Am seriously considering leaving Orange over this. Heaven help anyone who uses a C500 as a business phone with this problem.

Orange now flatly refuse to replace phones with this problem!

So much for customer service.

Link to comment
Share on other sites

Guest cuk0724

This is a problem know to Orange. I have had this problem for the last two months (16 new phones).

They have just released a new version ROM 4-2-1-4 this I have been told will fix the problem. I am just downloading it so I will see.

Link to comment
Share on other sites

Guest cuk0724
This is a problem know to Orange. I have had this problem for the last two months (16 new phones).

They have just released a new version ROM 4-2-1-4 this I have been told will fix the problem. I am just downloading it so I will see.

<{POST_SNAPBACK}>

I have been using this new ROM for the last 3 days, and I have not had the sound issue, so it looks like Orange have fixed it!!!!

Link to comment
Share on other sites

Guest cuk0724
That's 4 updates in two months! Who said Orange never release rom updates  ;)

<{POST_SNAPBACK}>

That's only because each update has fixed a problem with the last one!!!!!

Link to comment
Share on other sites

Guest bob.chandler

Well, after all that Orange were very good and contacted me to replace my phone. So I'm now on my 5th C500!!!

Only problem is that the really annoying echo still remains in all calls I make. My Mum even hung up on me yesterday she was so annoyed!!

Can't wait for the C600 - which I sure will have as many bugs!

Link to comment
Share on other sites

Well, after all that Orange were very good and contacted me to replace my phone. So I'm now on my 5th C500!!!

Only problem is that the really annoying echo still remains in all calls I make. My Mum even hung up on me yesterday she was so annoyed!!

Can't wait for the C600 - which I sure will have as many bugs!

<{POST_SNAPBACK}>

Hi All,

I know this is a long shot but are you using a Leather case on your Phone? Some phones can have problems with some Cases or phones. If you are try removing the case and then try calling someone again and see if the Echo has gone.

I HTH

Regards

Michael Burdis

Edited by M1DUL
Link to comment
Share on other sites

Guest motorolampx200

Hi guys,

I think i have the same problem, people think i'm sick or that darth vader is calling them?!

I looked my rom version 4.21.1088 (build 15045.2.6.0)

Radio version: 1337.0.42_0.03.28

Maybe a stupid question but I just had my c500 replaced and I read on the orange site that this rom has wmplayer 10, but my rom also has that player so the only difference will be that people will actually hear me normally?

4.2.1.4 is a newer version?

And is there a newer radio version?

Tnx.

Edited by motorolampx200
Link to comment
Share on other sites

Guest cuk0724
Hi guys,

I think i have the same problem, people think i'm sick or that darth vader is calling them?!

I looked my rom version 4.21.1088 (build 15045.2.6.0)

Radio version: 1337.0.42_0.03.28

Maybe a stupid question but I just had my c500 replaced and I read on the orange site that this rom has wmplayer 10, but my rom also has that player so the only difference will be that people will actually hear me normally?

4.2.1.4 is a newer version?

And is there a newer radio version?

Tnx.

<{POST_SNAPBACK}>

The build and radio ver are the same as I have with the 4.2.1.4 ROM. You need to check what your "ROM update version Manufacturer version is" under Setting About.

The last two ROM versions have had WMP10, and also the sound bug!!!

Link to comment
Share on other sites

Guest motorolampx200

Don't exactly know what you mean but I found this:

Rom update versions:

Operator : 4.2.3.3

Manufacturer: 2.5.3.56

Microsoft: 4.21.15045.0

Language : 2.5.3.56

Windows 2003 second edition

Link to comment
Share on other sites

  • 2 weeks later...

I have had this problem recently and found that it is always only the first call made or received after comming out of the c500s Flight Mode.

If you power up the Phone in normal reception mode the calls are always OK

If you start the phone in flight Mode or go into and then out of Flight Mode - the first call has the problem - ie your transmitting voice is garbled the other end. all subsequent calls are OK.

Very strange NO one alse has reported this !

I wonder if it is fixed in the very latest ROM ?

I have Operator ROM version 4.2.1.1 phone bought from Orange just over 3 months ago

(I think this ROM version was around for a while)

This may well explain why hardly anyone else has heard of the problem and only this post - because I guess very few use flight mode.

Please - Can anyone else confirm this happens on their c500 ?

Recently received third replacment C500;

Rom Update 4.2.1.2

when calling it sounds garbled to anyone receiving the call - like using a voice changer. On instant call back - problem solved but with lots of echo instead!

Called Orange - suggested hard reset (softkeys and power on - press '0') - problem not solved.

Orange are aware - refuse point blank to replace phone again - have to live with it - bloody useless!!

Can anyone help - suggest another fix??

Thanks.

<{POST_SNAPBACK}>

Link to comment
Share on other sites

I have Operator ROM version 4.2.1.1 phone bought from Orange just over 3 months ago

<{POST_SNAPBACK}>

lft480

Try updating to the C500 to ROM 4.2.1.4 as stated previously in this thread and see if the clears the problem or not ?

Here is how to find the update ;)

Goto http://www.orange.co.uk

Click 'get help using you phone' under Help and Support

Click 'choose another phone' and select Monthly, Orange SPV C500.

Click 'download latest doftware update'

Click 'how do I download latest software update'

Link to comment
Share on other sites

thank you for responding with this confirmation.

However, I am interested to know just how you know that this is the only change ?

Why is it that neither Orange or HTC (who I assume are the ones who fix and rebuild the ROM release) clearly list the bugs the release fixes and any enhancements included in it ?

clearly from other posts - orange have just been telling people to send back phones and then resend them out not fixed - when someone clearly knoew of the ROM Flight mode/garbled sound bug long ago.

In short - is there some secret source of such info available from HTC themselves or a more techy Orange page ?

Many thanks for this confirmation

I am a little hesitaant to put this latest ROm on right away - incase there are some other new problems with it (I'll just wait a little)

It is good to know how to work around the bug though (ie ensure one comes out of flight Mode before turning the phone off so that when I turn it on again I am sure all calls will be clear (or just make a dummy call myself after flight mode)

Also -is there an uptodate list of any outstanding known bugs - I can only find one that is way out of date ?

thanks again to all for their contribs to this thread - v.helpful

The new ROM Version 4.2.1.4 does fix this problem. This is the only change in this version. It has been happening since the 4.2.x.x ROM. 4.1.1.4 was OK.

<{POST_SNAPBACK}>

Link to comment
Share on other sites

Guest cuk0724
thank you for responding with this confirmation.

However, I am interested to know just how you know that this is the only change ?

Why is it that neither Orange or HTC (who I assume are the ones who fix and rebuild the ROM release) clearly list the bugs the release fixes and any enhancements included in it ?

clearly from other posts - orange have just been telling people to send back phones and then resend them out not fixed - when someone clearly knoew of the ROM Flight mode/garbled sound bug long ago.

In short - is there some secret source of such info available from HTC themselves or a more techy Orange page ?

Many thanks for this confirmation

I am a little hesitaant to put this latest ROm on right away - incase there are some other new problems with it (I'll just wait a little)

It is good to know how to work around the bug though (ie ensure one comes out of flight Mode before turning the phone off so that when I turn it on again I am sure all calls will be clear (or just make a dummy call myself after flight mode)

Also -is there an uptodate list of any outstanding known bugs - I can only find one that is way out of date ?

thanks again to all for their contribs to this thread - v.helpful

<{POST_SNAPBACK}>

I have been having this problem since the ver 4.2.x.x ROM came out. The phone I have is a company phone, and I had 16 replacements for the speach problem. In the end I found out that the problem happened when you take it out of flight mode or change to a second line. The first call after this always has problems with the speach.

Once I cound get the phone to do it, I showed our companys Orange Rep. This was then escelated to Orange Tec Team and HTC then found the bug and changed the software. I had been testing the new ROM version before it was released. I was told by our Orange Rep that this was the only change in the version.

Link to comment
Share on other sites

Ok - thanks for the info

Atleast it does show that Orange and HTC do respond to precise clear defects - when they can be clearly demonstrated.

I have been having this problem since the ver 4.2.x.x ROM came out. The phone I have is a company phone, and I had 16 replacements for the speach problem. In the end I found out that the problem happened when you take it out of flight mode or change to a second line. The first call after this always has problems with the speach.

Once I cound get the phone to do it, I showed our companys Orange Rep. This was then escelated to Orange Tec Team and HTC then found the bug and changed the software. I had been testing the new ROM version before it was released. I was told by our Orange Rep that this was the only change in the version.

<{POST_SNAPBACK}>

Link to comment
Share on other sites

  • 6 months later...
Guest spvdk

Anyone got the latest info on this?

I am trying to fix this problem on my gf's C500, but no newer ROM seems to be working. I have tried 4.2.1.5 and 4.2.5.2, as well as SP3 2.1.331, and still the problem persists.

Btw this problem happens several times each day, regardless of flightmode settings.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.