Jump to content

Problems connecting to a router with wireless


Guest farmgorgon
 Share

Recommended Posts

Guest farmgorgon

I have an 02 exec, but can't connect to my linksys router (which I use for my wirelss laptop connection) to get online.

the exec shows the linksys connection as available, but when I select connect, it just thinks a bit and changes back to available.

In the `configure wireless network` section the network and other tab are grayed out as SSID and the 822.1 (or whatever it is called) is disabled on the router. It is set to `connect to work` in the general tab as the manual states (not `internet`).

I haven't touched any other settings. Do I need to set up the connection manually somehow with the VPN or network card settings. I've read the manual but am none the wiser.

thanks v much

FG

(NB I had this exact same unresolved problem with a M2000 a few months ago before I lost my bottle and returned the unit within 14 days.....)

Link to comment
Share on other sites

Guest chucky.egg

The first problem sounds like you have some sort of security (WEP perhaps) that is stopping the connection.

I set my router to only allow connections from specified MAC addresses, which means you dont need to enter a WEP key but your router can still only be used by devices you nominate.

I would have thought you should connect to the Internet, not Work, but I dont use VPN so that might be why.

Link to comment
Share on other sites

Guest farmgorgon
The first problem sounds like you have some sort of security (WEP perhaps) that is stopping the connection.

I set my router to only allow connections from specified MAC addresses, which means you dont need to enter a WEP key but your router can still only be used by devices you nominate.

I would have thought you should connect to the Internet, not Work, but I dont use VPN so that might be why.

<{POST_SNAPBACK}>

I've disabled all my security settings, and allow connections from anyone, so its not a WEP or MAC address problem.

Any other thoughts? I've heard mention on these boards of some sort of ip address clash but there isn't any mention of my IP address on the pda. In the WLAN settings page, the `status` is permanently `scanning network` as there's no signal link and so IP and BSSID are both greyed out.......

Link to comment
Share on other sites

Guest farmgorgon
Try looking here:

http://www.modaco.com/Wifi_Trouble_With_Mda_Pro-t229829.html

HTH

<{POST_SNAPBACK}>

Confuscious,

thanks VERY much for the reply. Am going to go through that thread in detail tonight when am next to laptop and device. First I'll try and connect with WEP enabled, then try and connect mannually. How do I do this? The manual has no information about a great number of settings on my Exec. I see that I can get various info from running ipconfig on the laptop. Do I have to set up a new connection on the exec manually? From memory there are a great many settings and I don't know how to do this.

thanks for holding my hand.....

FG

(ps will also forward thread to linksys tech support who have been less than helpful....)

Link to comment
Share on other sites

Guest farmgorgon
I have a similar problem.  Is your Universal able to connect the instant after rebooting the router?  Have you tried that?

<{POST_SNAPBACK}>

jmcglynn

thanks, but this makes no difference. (But I sometimes do have to do this to get a connection with my laptop, as BT broadband tell me that apparently linksys routers sometimes lose their internet connection but think they are still connected. You have to reboot and go into their diagnostic settings to check this!)

Link to comment
Share on other sites

Similar situation here - Linksys router + XDA Exec. I had a bit of a mare setting them up to talk to each other (in my case due to not Reading The Manual - the Universal is B only and I'd set the Linksys some time previously to G only). It would see the SSID (the broadcast of which I hadn't turned off) but sit forever at "connecting" until I set the router to B+G. Then it was just a question (for me) of entering the WEP key correctly.

One other thing to try - if you've just unplugged the Universal from a USB connection, try soft-resetting it. I suspect that if for some reason it can't get an IP address straight away ot "gives up", and I've noticed that sometimes it won't pick up a WLAN IP address after unpluuging from USB.

Link to comment
Share on other sites

Guest terryd

Can I join in here.

I have been having the problem of connecting on wifi with a number of WM5 devices.

We have a couple of Vigor routers (Draytek) and I don't have a problem "connecting" to the wireless (with or without wep), my problem is that the device cannot get an IP address.

If I turn on dhcp on the router, then no problem. If I leave the handling of dhcp to the windows 2003 servers, then no IP address.

The only exception to this is a Vigor 2800 with me setting the VPN over wifi setting on. That gives me the necessary IP.

Does this help anyone with identifying their problem?

Is there a way to fix the IP on a particular network connection?

Terry

Link to comment
Share on other sites

Guest Danlance
If I turn on dhcp on the router, then no problem. If I leave the handling of dhcp to the windows 2003 servers, then no IP address.

<{POST_SNAPBACK}>

I Have an orange SPV M5000.

I use it on WIFI at work (Draytek router, Windows 2003 DHCP Server) and at home (Draytek router, Windows 2000 DHCP Server) - and as long as I'm in range, I have no problems obtaining an IP address.

The SPV does seem to need a much stronger signal than my (Centrino) Laptop - unless I turn the power settings right up on the SPV (which really hammers battery usage)

Another thing to try if you are using a Unviersal - Check that the router is configured to use 802.11b (or b + g) and not 802.11g only - I have had similar problems on my laptop trying to access a router which had been configured to use 802.11g only - the network could be seen - but the device could not connect (which is hardly surprising really!)

If the problem really is one with DHCP (which would surprise me tbh unless the router is doing something strange), and you are using a separate DHCP server, then it may be worth configuring the DHCP server to reserve an IP address for the MAC address of your device (Turn on wireless LAN on device and go to Settings> Connections > Wireless LAN, and you should see the MAC address of the device in the 5th box down)

If the router is handling DHCP, then it should also be possible to reserve an IP address on the router (it certainly is on a Draytek) - but this depends on the router.

Again depending on your router, there may be a way of monitoring wireless network connection attempts (e.g. station list status screen, or through logging) which may give you info as to why the connection is not made / maintained.

I'd echo chucky.egg's comments about security settings - if it were not for the fact you say these have all been disabled, I'd say it was most likely that access had been restricted by MAC address (I'd say probably not WEP, as if this was the case, WM should prompt you to enter the WEP key). It may be worth giving the router another reboot - some routers are not brilliant at applying changes to security settings on the fly...

HTH

Edited by Danlance
Link to comment
Share on other sites

i had this problem initially with my Imate SP5m - and i have a linksys router

let me say linksys are not good at all in general - they are terrible. you dont wanna know my story.

I found the new ROM for my device made wifi connection easier but that was just a feature.

the way I had it connect initially was to

disable all security

ENABLE SSID broadcast for a few minutes

make sure the channel of the router is the same as the channel "hearing" on the mobile device

it then should connect

then enable your security one by one.

the key point is the channel range, they must match together. As well as this make sure that your router has enough DHCP allowable connections

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.