Jump to content

SMT5600 apparently dead, hopefully just acting

Guest mastman

Recommended Posts

Guest mastman

Caveat - This is my son's phone, and only the recent observations are my own. I can't be sure he didn't do something to munge it up. In any case . . .

I bought an unlocked SMT5600 on eBay about 6 weeks ago. It worked great for about 3 weeks, then went on the fritz. It started by only booting to the red-green-blue OS screen. Removing the battery did nothing to reset it. It was still doing this when I retrieved it from my son. When I finally had time to look at it four days later, it booted once or twice to that screen, but then stopped doing even that. I have since done research online and not seen a similar situation. Other observations - there is no change if I swap out the battery for one that I know is charged. After replacing the battery, when I insert the charge cord (wall plug, not USB to PC) the power light flashes red briefly, then goes black and never comes on again.

Of course the eBay seller is telling me I'm SOL at this point. Before the problems began, I actually bought three more of these phones from the same seller and none has had any problems. My son is not into modding or installing programs, and tells me he has done neither. I think this is likely the case, but it is conceivable he or a friend might have tried something. So I am looking for assistance/direction in what to try next. Although I don't think I have the correct torx to disassemble it right now, I am willing to get the right tools and give that a go to avoid a $150 paperweight.

Thanks, mastman

Link to comment
Share on other sites

Guest mini_man

Well the multicoloured screen only occurs if you turn the phone on while holding the camera button in so it might be tthat its stuck in and it would explain why thats happening.

Odd that it wont turn on? Even stranger that the light flashes. You might want to try a hard reset?

Hold the two softkeys down and then press the power button in for about a second so that light flashes on and then release it while still holding onto the softkeys and then follow the instructions on screen.

Good Luck


Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.