Jump to content

My update gets stuck at %92

Guest Rhasielle

Recommended Posts

Guest Rhasielle


I used to have 3.46 firmware on my mpx220.

then I had to give it for technical repairs and got it back after they changed the mainboard.

Since the firmware was different, I decided I should reinstall the firmware I was using and restore my backup file.

But the thing is I can't install any firmware on it.

I've tried 3.46, 3.51, 1.28, 1.49, 1.43 but no luck.

What I've noticed is European ones get stuck at 91% and Asian ones get stuck at 92%.

I've also tried upgrading on another computer (laptop).

Since the upgrade failed in the middle of file transfer, I can't even turn my phone on.

It gives me some kind of an error message like "Download incompletely"

I'm planning to try it with another data cable.

I've also checked the Surreal networks forums and noticed one other person had the same problem too.

But there was no answer, no solution for it.

Did it happen to anybody else? Do you have any idea what should be the problem?

Thanks for your time and attention

Link to comment
Share on other sites

Guest geoffrey118

I think it's more a problem with regards to the software rather than the hardware! Try re-downloading the offline updater and re-download the firmware from other sites! Maybe it will help!

Hopefully this will solve your problem!

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.