Jump to content

Universal - useless as a phone


Guest flippy
 Share

Recommended Posts

Guest flippy

Before I smash this thing against a pillar, I'm after some help.

I got my Universal via T-Mobile (MDA Pro) at launch, and have been impressed with it, as a PDA. It's always been utterly useless as a phone, though.

Right from the start, the green hard 'answer' button has chosen at random whether to answer or hang up, not quite the functionality I've been after.

Occasionally, I can only hear properly from the screen side of the device; when closed, I can't hear anything (which is weird, cos I assumed it was the same speaker).

Most recently, and most annoying, is that whenever I have to go through a 'press 1 to continue' type phone system, which usually involves a healthy amount of 'on hold' time, the microphone just doesn't work, so my 30 minute wait results in me listening to someone going "Hello? Hello?", then hanging up. I've checked the screen, and I'm not somehow invoking mute every time.

I haven't updated the system version since I got it - mainly through fear of how good ActuiveSync is, and will be trying this as a last ditch effort to maintain a usable phone, unless anyone has any other ideas...

Thanks in advance.

Link to comment
Share on other sites

Guest Paul (MVP)

I would strongly suggest putting the latest ROM on for it and seeing how you go... as it does add a number of improvements to overall reliability.

Having said that, the symptoms you are experiencing aren't regular Universal complaints AFAIK...

P

Link to comment
Share on other sites

Guest flippy

OK - having spoken to other people, and having just tried my SIM in someone else's phone, it appears that there's some kind of bizarre dead spot RIGHT IN THE MIDDLE OF COVENT GARDEN, whereby you can hear people, but they can't hear you, which affects all networks. I guess I've just been calling a lot of menu-based services recently!

My point re: the green button stands though! :)

Link to comment
Share on other sites

Guest jimbouk

You should also try switching it to 2g to see if it works better. There are places where the 3g coverage is there (so the phone has a signal) but its so weak that it cannot actually carry voice or data.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.