Jump to content

A word of warning re: GPS settings


Guest PaulOBrien
 Share

Recommended Posts

A word of warning - DON'T fiddle with the 'External GPS' settings.

It's pretty easy to get it to the state where you have to hard reset to get it working again!

P

Link to comment
Share on other sites

A word of warning - DON'T fiddle with the 'External GPS' settings.

It's pretty easy to get it to the state where you have to hard reset to get it working again!

P

Too late ;) ... *sigh*..... when you say "hard reset," do you mean turning the device completely off and then back on again or erasing everything and reloading a backup on to the device.

Is there anyway to get back to what it was originally so I dont have to "hard reset" it?

Thanks,

John J:)

Link to comment
Share on other sites

Unfortunately, a full factory reset seems to be the only solution!

P

for those that like to tinker - heed the warning! i just changed the settings once. ONCE. and the gps system got hosed. after playing for a while to try and fix it, i did the hard reset and it now works. oh well, playing was fun, but glad GPS now works. Take care.

Link to comment
Share on other sites

  • 4 weeks later...

How do you know if you hosed it and need to do a hard reset?

I was having trouble getting a fix so i went into the external gps settings. i didn't really change anything, but i'm still having problems.

Link to comment
Share on other sites

I know that some devices hide the External GPS option and there was a registry change you could do to re-enable it.

Is it possible that you can therefore hide the External GPS option on the Kaiser by reversing this change? If it serves no purpose having the icon/option there, and by just opening it you hose your GPS settings, wouldn't it be wise to put it in your Kaiser tweaks cab?

Link to comment
Share on other sites

A word of warning - DON'T fiddle with the 'External GPS' settings.

It's pretty easy to get it to the state where you have to hard reset to get it working again!

P

Looks like I've managed to break mine ;)( Never messed with the external GPS thing either. I instaled google navigator which didn't seem to work so I uninstalled it and since then GPS hasn't worked with anything :(( Can't believe a hard reset is the only way out of this!! :D(

Below is a useful GPS test program which people might find useful (from XDA Developers).

Go to this page and see the link for external mirror 1. use it to download GPS TEST:

http://handheld.softpedia.com/progDo...oad-34335.html

When you have installed it, run it and it will auto scan the ports to find the GPS receiver. Make note of the port number - that's the one you'll need for your other applications. Make sure you have a clear view of the sky when running it and give it PLENTY time to achieve a first time fix.

By the way if you have ever used the "External GPS" on the Kaiser then you may have altered asome settings that can stop GPS working. Unfortunately only a hard reset will cure this. BUT, try the above first. If GPS test can get satellites then so will other applications.

This little application GPS Test is also useful to run before things like Google Maps that some folks have problems with.

Link to comment
Share on other sites

I'm going to look into this more - i've found an easy way to tell if it's broken or not. Not found an easy fix yet tho ;)

P

I'm in the same boat. I did a hard reset...gpstest showed four satelittes then stopped working. It would be awesome if someone came up with a cab to reset the 'external gps' settings.

Link to comment
Share on other sites

I think a hard reset is only required if you actually change something in the External GPS program. I accidentally started External GPS but did not change anything. I couldn't get a fix using Windows Live Search so installed the GPS Info program mentioned in another thread and left that going for about an hour. When I came back it was reporting location info, and trying Windows Live again gave me my current GPS position within a few seconds. Not sure whether this would work if I had changed anything in External GPS, but at least there is a way to recover if you just start it up accidentally.

Edited by StephenR
Link to comment
Share on other sites

  • 2 weeks later...

Hi guys,

I have a strange problem... I've installed tomtom 6 ver' 6.032 (UK Tmobile Vario 3) and it installed fine. But, I get 'no gps device' message constantly. The thing is, google maps works fine with the gps tracking every time perfectly.

I just installed the gps test app but that just keeps scanning through the ports???

I do remember changing the external gps settings when I first got the phone but as Google maps is working with the gps I'm not sure wether I need a hard reset or not...

Any help is much appreciated.

Silver.

Link to comment
Share on other sites

If Google Maps is working then no.

Do you have TomTom set up to use COM4?

P

Wow, fast reply Paul.

No, I am using 'Internal gps' setting in TomTom... I have tried the the NMEA GPS receiver option but that didn't work either?

Also I thought people couldn't install this version of tomtom on UK Kaiser?

Thanks for any help Paul...

Link to comment
Share on other sites

Internal or NMEA GPS (set to COM4) should work fine, in fact I use TomTom on my device no problem.

When you go into settings -> gps status, can you see anything happening? I guess mine takes a few seconds to pick up the GPS after I start the application.

P

Link to comment
Share on other sites

I installed TomTom 6 Navigator (6.010) on this phone and can use it without any issue.

I'm using "Other NMEA GPS receiver", GPS baud rate set to 4800 and set to COM4 and it connected to GPS OK.

Link to comment
Share on other sites

Internal or NMEA GPS (set to COM4) should work fine, in fact I use TomTom on my device no problem.

When you go into settings -> gps status, can you see anything happening? I guess mine takes a few seconds to pick up the GPS after I start the application.

P

Hi Paul,

the gps status in tomtom just says 'No GPS device' and I have no option to change the port only the GPS baud rate on the NMEA gps device.

the gps test just keeps cycling through the ports too, it cant find anything...

Link to comment
Share on other sites

Oddness... the latest TT version from the TomTom site?

http://www.tomtom.com/support/index.php?FID=6736&Lid=1

P

hmmm, thanks P. I just installed the update. this version does not have 'internal gps' option however ? strange. Even though the tomtom site says this is for the vario III. still not working ;)

do you think that the fact that the 'gps test' app cannot find anything is significant?

Link to comment
Share on other sites

Have you tried shutting down all the other GPS apps before running TTN? Start/Settings/System/Memory/Running Programs. Shut down PIE, GoogleMaps and any other GPS app, in case one of those is hogging the GPS Port and not letting TTN get to see it. It ought to work automatically, but sometimes doesn't ;)

Link to comment
Share on other sites

Have you tried shutting down all the other GPS apps before running TTN? Start/Settings/System/Memory/Running Programs. Shut down PIE, GoogleMaps and any other GPS app, in case one of those is hogging the GPS Port and not letting TTN get to see it. It ought to work automatically, but sometimes doesn't ;)

thanks mate, tried that. noting seems to work.

BTW Paul, that 'new' version i updated to of TTN is actually 6.030. I was on the 6.032 so it has downgraded ? weird...

i hear some people are talking about port 4 for the gps but I don't have the option for this anywhere? how are peeps doing this?

Link to comment
Share on other sites

just for anyone else having same issue... found this on the xda site.

"Hm.. installed 6.030 my maps work fine, but when I choose "Other NMEA" and choose baud rate 4800, it doesn't prompt me for Com4. When I get into the program, it just sits there "No GPS Device". Any ideas?

Googlemaps seems to work fine locating a GPS signal though."

reply: NVM, finally got it to work. Changed the ExternalGPS setting to Com4. Then when I got into TomTom it asked me which Com Port I wanted to use. Works awesome now."

I have now done this and it is working fine :(

so much for NOT TOUCHING THE EXTERNAL GPS SETTINGS ;)

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.