Jump to content

Wi-fi via WPA (EAP-TLS authentication)


Guest dom
 Share

Recommended Posts

Has anyone tried using Wi-fi to connect to an access point using RADIUS with certificates? I've been trying since I got the phone, but am getting some pretty strange behaviour. Sometimes it connects and successfully obtains an IP address (I assign specific IP's to specific MAC addresses via DHCP on my network). Sometimes it just says that the network is unavailable (given that the phone is next to the access point this cannot be signal strength) - actually since the first couple of successful connections today, it has remained in this mode where it won't connect at all.

When it did work my RADIUS server reported successful authentication (which it had to in order for the device to get to the point where it would receive an IP address from the DHCP server), the only problem was that I couldn't connect to anything - most basic test was to try to connect to a couple of sites using PIE - whether I used the name of the site or the IP address I got the message that it was not possible to reach the site.

So in summary, I have two problems:

1) The device will no longer connect to the wireless network... I've not changed anything on that side, and the only thing I've done on the Vario III is to delete and recreate my wireless connection.

2) When I was able to connect to the network, I was unable to connect to any web-sites.

I've not had a ppc with Wi-fi before so any advise on either/both the above issues would be appreciated!

Thanks,

Dom

Link to comment
Share on other sites

Number 1) seems to be sorted. I did a hard reset and can now reliably connect again, but I still can't access anything once connected to the network.

The only things I can think of are:

A) Not all the DHCP settings are being set on the Vario III correctly (i.e. I've got the IP address, but perhaps the default gateway has not been picked up?) Is there any way for me to check this? (like ipconfig /all on Windows XP). I did try manually setting the DNS servers, but this didn't have any affect at all.

or ;) Somehow PIE doesn't know that it should be trying to communicate via the WiFi connection - is there any way for me to check this or is it implicit? Looking at the Connections in the settings area of the device I only have "T-Mobile Internet" and "My Work Network", should there be another one for just WiFi? I couldn't see any way to add it but...

Thanks.

Link to comment
Share on other sites

Hmm, just tried jumping on the GNER wifi connection (train next to mine (their public access service)). Looks like it works on their network.... so either there's something funny going on with the device's connection to my network. Wish there was some logging on the WM side, cos I'm not seeing any errors logged on the infrastructure side of my network.

On a positive note, the Vario III makes a great modem when I'm out and about. Whereas the previous phone I used as a modem (Nokia 7600 ;)) would drop the connection on the train constantly and fail to reconnect for ages, the Vario 'just works' and gets on with reconnecting to whichever cellular service it can without any hassle.

Edited by dom
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.