Jump to content

So You Wanna Use Citrix Eh?


Guest Cooch1000
 Share

Recommended Posts

So, here's the skinny...

Got the new TyTn II and have been App Happy for a few days now, and WOW - awesome device.

My most anticipated uses were to utilize LogMeIn on the PPC to access and control Home and peripheral PC's, with NO PROBLEMS WHATSOEVER...

Now, at work, we have a Citrix based system. I was able to access my workstation from my home PC with no holdups, no issues. Just downloaded the appropriate client and voila - I was in.

Now, I tried the same with the Kaiser. Downloaded the latest ICA Client from Citrix for PPC (there is a .CAB) available HERE: http://www.citrix.com/English/SS/downloads...amp;pID=186#top (for ARM Processors. If yours is something else, its there too - Smartphone is not currently supported ;) )

Installed the client, ran the App. Went to my work link HTTPS://citrix.XXXXXX.com, was able to Log In with my credentials. When attempting to access the internal apps, however, the following would occur:

The Launch ICA file would download, and Citrix would proceed to connect, leading to the following error (which may or may not occur with YOUR particular Citrix entity...depends on the security settings)

"SSL Error 61: Could not run - You have not chosen to trust the security certificate UTN User-FIRST Hardware"

Crap! Now, I did some muttering around before I asked for help, and found the missing certificate I needed via a google search HERE: http://www.openvalidation.org/en/service/c...tml?CAnumber=16

The code was present for the certificate, but damned if I knew how to Get It On Me Kaiser!! Couldn't get SmartphoneAddCert to install on my device to save my life. So, it was Paul at Modaco to the rescue...

Seems Paul was able to copy the code on the openvalidation.org site and create a handy little .cer file which installed automatically quite nicely when I copied it to the Root Storage of my SD card, and SOLVED THE CITRIX issue! I was able to log in without difficulties. Now, if only Citrix had scalability options like LogMeIn, we'd be living the High Life!

So the jist of this post is, if anyone is having problems installing non-traditional security certificates to PPC, there IS A CURE! If you know where to access the certificate you NEED, and just can't get it in the right format or the right place to install, read on, and hopefully Paul can shed some insight on the process he used for creating the .CER that made the planets align for me. Thanks again Paul.

(I know this is a hot topic on Citrix forums also, many newbies like myself struggled with the solution)

Cooch

Link to comment
Share on other sites

Now, if only Citrix had scalability options like LogMeIn, we'd be living the High Life!

Seriously? A crappy program that basically does what RDP does, made by some random people that started a couple of years ago, or the industry standard, corporate fully supported application? Citrix > LogMeIn.

Link to comment
Share on other sites

I got round this a different way, i'm guessing you've got a comodo security certificate protecting the SSL on your webinterface box.

Put in a support request from comodo for a SSL Certificate signed by GTE Cybertrust Global Root and your problems will be solved. This will also allow linux and mac based clients to connect easier, as most devices don't trust UTN User-First Hardware or the other root comodo like to use which is AAA-Certificate-Services.

http://support.citrix.com/forums/thread.js...4&tstart=60

You'll need to generate another CSR from your webserver, then rerun the Web Interface configuration to point to the new certificate.

Oh and citrix >>>>>>>>>>>>> logmein

Flubster

Edited by Flubster
Link to comment
Share on other sites

Oh I agree that Citrix is magnificent. I only wish it scaled so its usable on PPC. With LogMeIn I can scroll around - I'm stuck with the Citrix ICA client - very tough to move around. But hey - at least I can log on and forward my emails to my personal acct. ;)

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.