Jump to content

Exchange ActiveSync Schedule


Guest hotphil
 Share

Recommended Posts

I have ActiveSync set with a weekday 08:00-18:00 peak time schedule for "as items arrive" and off-peak as "manually". Yet every Sat and Sun at 08:00 it syncs. This is surely a major bug and will be costly if I am roaming. Any way to actually make the schedule work and let me have a lie-in?

Edited by hotphil
Link to comment
Share on other sites

After just reading your other post with regards to Activesync and contact filtering. Can I ask .. are you using over the air active sync to a Microsoft Exchange Server ?

Link to comment
Share on other sites

yes, syncing to an Exchange server. I've hard reset since I first noticed this behaviour too. it' intesnsely irritating me now. It activates a sync at 08:00 when it's not supposed to. this wakes me up and greets me with all my work emails and ruins my weekend for me. No other accounts are set to sync and after the initial sync it then stays inactive all day as it should. in actual fact, this is more annoying than the unscheduled sync as I usually deal with the mails on my laptop and yet the Kaiser still shows a whole load of unread ones.

Link to comment
Share on other sites

yes, syncing to an Exchange server. I've hard reset since I first noticed this behaviour too. it' intesnsely irritating me now. It activates a sync at 08:00 when it's not supposed to. this wakes me up and greets me with all my work emails and ruins my weekend for me. No other accounts are set to sync and after the initial sync it then stays inactive all day as it should. in actual fact, this is more annoying than the unscheduled sync as I usually deal with the mails on my laptop and yet the Kaiser still shows a whole load of unread ones.

I can imagine that must be immensely irritating. I'm a freak about not having the X unread items on the homepage. I very much doubt this would help but have you tried setting your sync schedule to 8:01 or 8:05 or something stupid? I doubt that'll have any effect but worth a try for next weekend. Bit weird though.. Strange no one else has reported having a problem!

Link to comment
Share on other sites

So you have Saturday and Sunday unchecked in the Peak Times config box right?

P

Yep. Schedule is set as Monday through Friday 08:00-18:00 only. "Use these settings when roaming" is unchecked. I'll try the following tonight and see what happens:

Close absolutely all running apps

Put phone on silent

Deselect Tuesday from schedule

Set Schedule as 07:30-19:00

If it still syncs up at 07:30 tomorrow, then there's definitely a nasty bug.

Link to comment
Share on other sites

confirmed that the behavior still happens even when a day is not selected in the schedule...

yesterday I deselected tuesday and altered both the start and end times. this morning it has synced itself - at the new time entered in the schedule, even though the day is not selected, proving it isn't anything else activating the data connection and AS piggybacking cos it can. this is a major bug - a device that initiates a data transfer and incurs data charges for its owner even when told specifically NOT to connect.

anyone else care to verify this behaviour on their device?

also, I wonder if this is device-specific or not? worth moving the wm6 area to see if anyone else has this?

Edit - would appear to be a problem that's been around quite some time http://pdaphonehome.com/forums/samsung-i73...hedule-wm5.html

Surely MS must be aware of this major, and potentially costly, bug? Anyone know the best place to report it to them?

Edited by hotphil
Link to comment
Share on other sites

Good man! As mentioned the steps I took to reproduce error are:

Confirm AS is set to peak times "as items arrive", off peak times "manually"

Change schedule to a specific time, say 07:16

Change schedule to deselect the next day

Reboot phone before going to bed (so no other apps running and phone is left 'clean' overnight)

Check AS status after 07:16 the next morning and the latest entry will confirm that a sync initiated at 07:16

Problem with reproducing the error is that you can only do it once a day I guess.

I'm off to the US next week and although my phone's a company one and I never see the bill, I'd rather not rack up unnecessary roaming data charges for them. But if I can't be confident that deactivating certain days in the AS schedule will actually work, then I may ask for the bill and send it to MS!

My device is a 'stock' Vodafone V1615 - no fancy ROM or anything :)

Edited by hotphil
Link to comment
Share on other sites

I get this as well - it can be avoided by disconnecting from the internet and using the Modaco NoData tool, but I shouldn't have to do this when I've already explicitly told ActiveSync when to connect and disconnect.

Yes, I'm using "Sync when items arrive", but the 2 weekend days are deselected...

Edited by Mr.Clark
Link to comment
Share on other sites

I'm with you. I shouldn't have to install any 3rd party apps to get round such a fundamental bug. I can't put my phone into flight-mode or silent or anything at night/weekends because if something at work blows up, I'll be getting a call. But I need the schedule function to actually do what it is supposed to. It's not acceptable for such a flaw to make it into a production unit.

Link to comment
Share on other sites

I wonder if no one's noticed because of this:

I've never used this, but does the dialog start off with all the times set to 00:00 - 23:59?

Because if you had a disabled day, you wouldn't change the times, right?

So you wouldn't care that it synced at midnight, because technically thats still the day before. That's a pretty lame explanation but I can't see how no one has noticed this before?

Link to comment
Share on other sites

I've never used this, but does the dialog start off with all the times set to 00:00 - 23:59?

Because if you had a disabled day, you wouldn't change the times, right?

The default for Peak Times is M-F 8am to 6pm, so if the A/S schedule is set for 'As Items Arrive' at peak times, and 'Manually' for Off Peak, there should be no Auto Sync between 6pm on Friday and 8am on Monday.

My WM6 Ameo does conform to 'the rules' , as does a new device I'm currently testing for one of the operators :)

Link to comment
Share on other sites

That's perhaps the most annoying part - it does a one-time sync and then remains idle (as it should). That's annoying as in my standard use it'll wake me up at 08:00 on Saturday with any new mails. Being a conscientious type, I'll then fire up my laptop and action/read them, but because the phone doesn't then sync again until 08:00 Sunday (which, again, it's set not to do!), it displays all the unread items still. Unless I manually activate a sync.

I'd be interested to find out the cause. If it doesn't seem to be widespread, then I can only think it is something specific to my device or company Exchange server, but I can't see that somehow. I certainly don't do anything funky on the device that should interfere - out the box, connect to Exchange, set schedule.

I wonder what's different with neil5459's Ameo ActiveSync?

Link to comment
Share on other sites

If it doesn't seem to be widespread, then I can only think it is something specific to my device or company Exchange server, but I can't see that somehow.

No, I'm not convinced. If ActiveSync is manually closed and the internet disconnected, the phone will still fire both of them up again at 8 the next morning (8:45 for me, but same principle).

I don't see how that could be anything on the Exchange end - how would it know where my phone was, for one thing?

Link to comment
Share on other sites

That's what I figured. Unless there's something like a dirty disconnect on last sync and it tries to clean itself up at the next scheduled time, but ignores days. But all my Status and logs look good - no errors.

Edited by hotphil
Link to comment
Share on other sites

I wonder what's different with neil5459's Ameo ActiveSync?

It would seem at present to be a specifically TyTnII thing? In the past year I've had the same settings on a MiniS (WM5), SPV M700 (WM5 & 6) and Ameo (WM6), plus a new WM6 device, and all have conformed to the rules of Peak Times.

Link to comment
Share on other sites

Definitely still a problem for me. And even more annoying than getting woken up when told not to, I've found that if I power off the phone at night, and then power it up at a day/time when a schedule is not set, it STILL does a sync.

Link to comment
Share on other sites

So its a bug.

I have Dutty's latest rom on mine. I will runa trial with peak/offpeak starting at 2.25pm each day and weekends offpeak, close activesync and see if it does it.

UPDATE: It didnt! Seems its either specific to your rom or its simply been fixed in later builds?

Edited by jimbouk
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.