Jump to content

Omnia Grandprix updater can't connect to my Omnia, please help !

Guest demieg

Recommended Posts

Guest demieg

Hi Everyone,

I've installed S0cks custom rom on my omnia but movie-record-function isn't working anyone. So I like to instal an other Rom. (Revert to the original Dutch Rom). I've downloaded the i900_Dutch_XKHJ3.exe. When I try to launch the installer it says 'waiting for device'. The start button cant be pressed to install the rom :D .

I tried to uninstall Activesync. I tried to disable advanced network functionality. I've installed the original Omnia modem drivers. Nothing works. I even tried to install the original rom from the samsung site. (after editing my version in the registry). Still the error 'incorrect software' pops up...

I've followed the exact manual described here :

Flashing instructions (only for Windows XP users, Vista [as always] is not supported):


a. Installed Samsung Drivers

b. Installed ActiveSync

1. Charge your phone (!!!)

2. Turn it off

3. Connect phone to PC using USB cable

4. Start updater (EXE file from archive)

5. Turn on phone

6. When the "Start" button becomes enabled press it < START BUTTON DOESNT ENABLE !!!!

7. Wait until "Job done" messsage appears

8. You can disconnect phone from PC and close application now - congratulations! you have new firmware!

I'm out of ideas. Can anyone be of service :lol: ?

Thanx in advance ! :lol:

Edited by demieg
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.