Jump to content

Pulse - glitches?


Guest Pulseowner
 Share

Recommended Posts

Hi,

Anyone noticed these problems?

1. Predictive text does not work. As soon as you tap a key, it takes you back to the input window. Standard input seems ok.

2. Barcode scanner app does not recognise camera.

Regards

Link to comment
Share on other sites

I don't have either of these problems actually (MCR 1.1).

P

Well reloading MCR1.1 solved the keyboard problem, but I can't get the camera to work with the barcode scanner/shopsavvy apps. Works fine through the standard camera app.

Anyone else with this problem? Thanks

Link to comment
Share on other sites

I have found that when I try to change the email settings so that delete also deletes from the server, the systems just shows "contacting server" forever. One time it crashed.

I remember that happened with my HTC Magic as well. Forgotten how to fix it.

(note: I use Yahoo email)

Edited by colonel_butt
Link to comment
Share on other sites

  • 2 weeks later...

@Pulseowner/McSpoon: Has either of you gotten the Barcode Scanning apps to work?

I'm a Moderator on one of the German Android Forums. A few users there (myself included) have also been complaining about the barcode scanners not working. There were (albeit sparse) mentions of the Barcode Scanners working, but I thought those were the result of people not knowing what they were talking about.

But recently, the reports of working Barcode Scanners increased and someone on my forum even posted a picture of his Pulse scanning. (Plus Paul says his Pulse is also scanning fine, but I just found that out when coming here, so... :D)

Now I've had two users - one with working Barcode Scanning ability and one without - wipe their respective devices. The wipe didn't change the behavior: the guy for whom the scanners worked could still use them, and the other couldn't.

There is also no difference between their devices OS-wise. Both are non-rooted and the Android build is the exact same (at least according to the "About phone" page in the settings).

I'm currently leaning towards calling this a hardware defect, but one thing is still bothering me: The native Camera app and apps not using the camera API but opening the phone camera app directly (e.g. the game "A World of Photo") work perfectly. I'm not a dev so I have no clue, but do you, Paul, or anyone else, know if it makes a difference hardware-wise if the camera is accessed through the API or through the phone camera app? My guts tells me that it shouldn't make a difference, but as I said, I don't know.

This issue is really weird.

Link to comment
Share on other sites

Maybe someone with a rooted device and a not working camera (in scanner apps) could check the logs! I think u have to be root to read them! There should be an error message when u try to launch the scanner app!

My camera is working fine in all apps!

mapero

Link to comment
Share on other sites

Funny I also had the problem with Barcode Scanner not working. This was with the original firmware. But I have installed Paul's modified ROM and I just tested Barcode Scanner again and now it works. With the original application the camera did not seem to focus. Of course the device is now rooted, so that might also be the solution.

Link to comment
Share on other sites

Funny I also had the problem with Barcode Scanner not working. This was with the original firmware. But I have installed Paul's modified ROM and I just tested Barcode Scanner again and now it works. With the original application the camera did not seem to focus. Of course the device is now rooted, so that might also be the solution.

Well, my problem hasn't been that the camera doesn't focus or something like that. The screen stays black - the cam isn't accessed.

So is anyone here with a rooted Pulse who can't use Barcode scanning apps?

Link to comment
Share on other sites

Hi,

Anyone noticed these problems?

1. Predictive text does not work. As soon as you tap a key, it takes you back to the input window. Standard input seems ok.

2. Barcode scanner app does not recognise camera.

Regards

I bought a pay as you go Pulse yesterday. Got it home, set it up and downloaded bar code app and shop savvy. As mentioned, neither of these worked. Blank screen with the red pulsating line as reported. I took the phone back to the T-mobile shop today to complain about this as they advertise heavily shop savvy for use on the Pulse. I demonstrated it not working. They offered a replacement phone which I took. Got home tonight, set the phone up and then downloaded the bar code app first and tested it, IT WORKED, then downloaded Shop Savvy, tested it and IT WORKED. I'm one happy Pulse owner now. There appears to be no difference in the builds, so I dont know why it now works.

Link to comment
Share on other sites

Shop Savvy doesnt work on mine either. Only bought it last week so might take it back today.

How do I go about deleting everything and getting it back to a 'just bought' condition. I havent rooted or installed any roms on it, I just want to get rid of apps and any personal info.

Will a hard reset do this and a format of the sd card, or will this also remove tmobile add ons?

Thanks

Edited by demusss
Link to comment
Share on other sites

I've got a rooted pulse with MCR 1.1. ShopSavvy did not work with my phone, even after updating. So do you tell me, that there are differenz pulses out there? Some with issues and others that don't have these issues?

Link to comment
Share on other sites

Shop Savvy doesnt work on mine either. Only bought it last week so might take it back today.

How do I go about deleting everything and getting it back to a 'just bought' condition. I havent rooted or installed any roms on it, I just want to get rid of apps and any personal info.

Will a hard reset do this and a format of the sd card, or will this also remove tmobile add ons?

Thanks

A hard reset will do the trick ('just bought' condition). However I'm afraid you can't remove the T-mo stuff like Web'n'walk, Mobile jukebox from the original phone.

Having said that, you can give Paul's custom ROM a go:

http://android.modaco.com/content/t-mobile...ure-stock-roms/

It's still for the most part the original ROM that came with the phone with some nice improvements.

Link to comment
Share on other sites

Hi guys,

I'm new to Android, and new to Pulse.

I have a problem, when I use the data services, and an incoming call appears.

I answer the call, but after a few seconds, the phone line brakes.

I dont think it is normal.

Do you know something about this issue?

Regards,

lg

Link to comment
Share on other sites

I found the factory reset in settings (thats a dangerous button and could do with a password) and wiped everything off the phone.

Installed shop savvy and it still doesnt work.

If its a phone version thing going on here, my serial number is BG7NAD1992400669 (not IMEI) whats everyone elses?

Link to comment
Share on other sites

I wrote into the forum at the shop savvy producers (http://getsatisfaction.com/biginjapaninc). Let's see if they can give some help.

Edit: I got an email from the producers of the app. They are asking if anyone has a contact on huawei. They didn't react on the calls and emails of the software engineers. So if anyone does have a personal contact on huawei it would be great to let me know and I'd turn the contact informations to Big In Japan Inc.

Edited by Aton
Link to comment
Share on other sites

Hi,

Anyone noticed these problems?

1. Predictive text does not work. As soon as you tap a key, it takes you back to the input window. Standard input seems ok.

2. Barcode scanner app does not recognise camera.

Regards

As my Pulse is now working with SopSavvy and Barcode scanner I bought another Pulse today for my partner. I got this home, set it up, downloaded and tested barcode scanner, all ok, and then downloaded shopsavvy, tested and all OK, so I now have two Pulses in the family that work with these particular apps. Result.

I also noticed something funny on mine today. I know people have said they are having problems with the cams autofocus, this may be the reason. I took the back off mine today and looked through the hole in the cover, there was a little clear plastic tab covering the hole. I thought at first it was a cover on the inside but it wasn't. From the inside I carefully pushed out the plastic glass ( the one with the writing around the edges ) this just left the cover then with a hole in it and this little ring of plastic with the tab sticking across the middle. I removed this tag and placed the plastic lens back in the cover. The camera now works a treat. It may be worth checking yours guys. BTW the second pulse I bought today didn't have this.

Edited by Sengadog
Link to comment
Share on other sites

I wrote into the forum at the shop savvy producers (http://getsatisfaction.com/biginjapaninc). Let's see if they can give some help.

Edit: I got an email from the producers of the app. They are asking if anyone has a contact on huawei. They didn't react on the calls and emails of the software engineers. So if anyone does have a personal contact on huawei it would be great to let me know and I'd turn the contact informations to Big In Japan Inc.

I had written them (Big in Japan) because of this issue already. They probably won't be able to do anything about that anyway, since most barcode apps are based upon the ZXing Barcode Scanner library. And they cannot provide a fix, since the main camera on the Pulse doesn't react to the standard API. So yeah, only T-Mobile and/or Huawei can tell us what the problem is.

It does seem like it's an issue with the Pulse hardware.

Btw: My serial number is BG7NAC1991708767. It's different, although I don't know anything about them serial numbers, so it doesn't necessarily mean that they're not supposed to be different. But we might be able to gather some info using them.

Link to comment
Share on other sites

Good news:

The guys at Big in Japan wrote me back just now. They say they had contacted Huawei about the camera issue and they did reply! They said that the issue (the camera not reacting to the API) is a known issue and that it had already been fixed 3 months ago. I was also asked to answer a few questions. Things are certainly looking up for the people who are affected by this issue.

Pyrazol

Link to comment
Share on other sites

Good news:

The guys at Big in Japan wrote me back just now. They say they had contacted Huawei about the camera issue and they did reply! They said that the issue (the camera not reacting to the API) is a known issue and that it had already been fixed 3 months ago. I was also asked to answer a few questions. Things are certainly looking up for the people who are affected by this issue.

Pyrazol

Same here. I sent them some T Mobile contact details to help out.

Whats your Kernel? Mine is 2.6.27-perf [email protected] #1

I'm wondering if we've got an early version of the phone.

Edited by demusss
Link to comment
Share on other sites

My kernel is exactly the same.

It's really weird though. I'm a Mod in a german Android forum and I've asked around. For a small(er) amount of people the Barcode Scanners ARE working. But there are more people for whom they aren't.

The firmware/baseband/kernel version and build number are not different for those two kinds of people. I even had one guy with a working barcode scanner and one without a working one wipe their devices simultaneously, but that didn't provide any new results for either one.

I really hope this can be fixed by a software update, I really don't want to take my Pulse back to exchange it.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.