Jump to content

Programs Auto-Closing!


Recommended Posts

Guest leshats

I think I have found a solution for auto closing programs problem. First I upgraded firmware to JB1 from Secany.

And I could not have more then two programs running.

And then I removed these links from StartUp:

AutoRotation.lnk - I do not like autorotation and setup button for this. BTW autorotation still works in Opera and Samsung video player. How can I turn it off?

CHomeManager.lnk - I do not know for sure what is this program for.

LinkMgr.lnk - I use MortButtons instead of Samsung Main Menu.

PlayerAutoUpdate.lnk

poutlook.lnk

ScreenCapture.lnk - This program makes previews for Samsung Task Switcher. I use ArkSwitch instead.

I did not touch

HKLM\System\OOM

cbLow

cbVlow

cpLow

cpVlow

as default values look reasonable.

And now I can have up to eight (8) applications running. Including even Opera and Skype and ICQ together.

So I can conclude that autoclosing problem is in number of running processes limit of WM 6.5 (max 32) and not in memory shortage. At least in JB1 firmware.

Link to post
Share on other sites
Guest Rapid81
CHomeManager.lnk - I do not know for sure what is this program for.

PlayerAutoUpdate.lnk

PlayerAutoUpdate.lnk is responsible for the update of the media player libraries after a soft reset

CHomeManager.lnk is for today screen (titanium)

I was removed these:

CHomeManager.lnk

LinkMgr.exe

PlayerAutoUpdate.lnk

poutlook.lnk

ScreenCapture.lnk

Now I have 66MB free RAM after soft reset, instead of 55 before with JB1.

I'm using TouchFlo3d 1.3, and nothing else.

Edited by Rapid81
Link to post
Share on other sites
Guest dwallersv
I think I have found a solution for auto closing programs problem. First I upgraded firmware to JB1 from Secany.

And I could not have more then two programs running.

And then I removed these links from StartUp:

AutoRotation.lnk - I do not like autorotation and setup button for this. BTW autorotation still works in Opera and Samsung video player. How can I turn it off?

CHomeManager.lnk - I do not know for sure what is this program for.

LinkMgr.lnk - I use MortButtons instead of Samsung Main Menu.

PlayerAutoUpdate.lnk

poutlook.lnk

ScreenCapture.lnk - This program makes previews for Samsung Task Switcher. I use ArkSwitch instead.

AutoRotation.lnk? Did you mean RotationSupport.lnk? I don't have the former, and I'm guessing that's there from installing the AutoRotation app developed by one of our fellow members.

I would like to get rid of RotationSupport.lnk (and the resident process) if I don't need it... I use manual rotation via a button.

I'll try disabling it and report back.

How about RetrySMSDaemon? Do we really need that? My intuition is that all this does is keep retrying to send SMS in the background if failure on initial attempt to send. I can live without that automation, as I can't remember the last time I had an SMS not go out on the first try, and if it doesn't, it will just sit in your outbox until you try to send it again manually.

I'd rather not lose the automation feature, but prioritized against running all sorts of other stuff that I do use a lot and care about, this is not important.

Anyone know?

Edited by dwallersv
Link to post
Share on other sites
Guest dwallersv

RotationSupport.lnk

Okay, just did some quick testing, and it looks pretty certain that all this does is provide autorotation for certain apps. I suspect they are the apps listed in the registry (can't remember the location).

Disabling this service kills all autorotation. Opera no longer rotates by itself, the shell, etc.

Manual rotation via a button still works the same, and even seems to be a bit faster.

Finally, this is a net plus for me, because it was annoying to have some apps rotate when I didn't want them to, particularly opera.

Link to post
Share on other sites
Guest leshats

In my phone (i8000 JB1 firmware) link AutoRotation.lnk points to \Windows\RotationSupport.exe. I removed this link from StartUp and there is no RotationSupport.exe process running. But autorotation in Opera and samsung player still works. So I can not turn autorotation off.

Edited by leshats
Link to post
Share on other sites
Guest CF Chong
I think I have found a solution for auto closing programs problem. First I upgraded firmware to JB1 from Secany.

And I could not have more then two programs running.

And then I removed these links from StartUp:

AutoRotation.lnk - I do not like autorotation and setup button for this. BTW autorotation still works in Opera and Samsung video player. How can I turn it off?

CHomeManager.lnk - I do not know for sure what is this program for.

LinkMgr.lnk - I use MortButtons instead of Samsung Main Menu.

PlayerAutoUpdate.lnk

poutlook.lnk

ScreenCapture.lnk - This program makes previews for Samsung Task Switcher. I use ArkSwitch instead.

I did not touch

HKLM\System\OOM

cbLow

cbVlow

cpLow

cpVlow

as default values look reasonable.

And now I can have up to eight (8) applications running. Including even Opera and Skype and ICQ together.

So I can conclude that autoclosing problem is in number of running processes limit of WM 6.5 (max 32) and not in memory shortage. At least in JB1 firmware.

On JB1, I am still having programs been auto closed when they are in the background if the memory falls below 40MB. If OOM is tweaked, programs in the background will auto close when memory falls below 30MB.

On soft reset, the memory is above 70MB (disabled a number of startup programs/services/plugins). Launching multiple programs is not an issue. The problem starts when over time, gwes.exe will grow larger and larger and free memory will get lesser and lesser. Then background programs will start to auto close. It will reach a point where only one program can be executed. The other program not in the foreground will not survive. A soft reset is required to start the cycle all over again. How long the cycle is will depend on what programs are commonly use and how often these programs are opened and closed.

When a program is started, gwes.exe will grow a bit. When the program is closed, chances are gwes.exe will not release the same amount that it gained earlier. Opening and closing the same program many times will make gwes.exe larger and larger. If a program is needed often, dismissing it to the background instead of closing it when not in use will help delay the growth of gwes.exe.

Sorry to say that this is the first winmo phone that I have that is having this problem. My previous were Dopods and HTCs.

Edit:

The attachment shows the system having only 39MB of free memory although hardly any program is running at the time. Over the day, I have used the phone for calls, smses, emails, rss, internet surfing, MSN, etc...now it has reached a point where a soft reset is required. 72MB of memory has already been used by the main system services. I am no longer able to run my pRSSReader and Internet Explorer without the other closing when swapped to the background.

post-60018-1266424484_thumb.jpg

Edited by CF Chong
Link to post
Share on other sites
Guest leshats
The attachment shows the system having only 39MB of free memory although hardly any program is running at the time. Over the day, I have used the phone for calls, smses, emails, rss, internet surfing, MSN, etc...now it has reached a point where a soft reset is required. 72MB of memory has already been used by the main system services. I am no longer able to run my pRSSReader and Internet Explorer without the other closing when swapped to the background.

Windows has memory leaks. This is true and this is sad. Doing soft reset once a week is a common practice for me with Windows Mobile. And Windows desktop too btw.

But so dramatically leeks that you describe can be occasioned by some third party software. I can remember such problems with SPB Weather, SBP Pocket Plus etc. May be you can try to uninstall suspicious programs one by one.

Edited by leshats
Link to post
Share on other sites
Guest CF Chong
Windows has memory leaks. This is true and this is sad. Doing soft reset once a week is a common practice for me with Windows Mobile. And Windows desktop too btw.

But so dramatically leeks that you describe can be occasioned by some third party software. I can remember such problems with SPB Weather, SBP Pocket Plus etc. May be you can try to uninstall suspicious programs one by one.

:D That suspicious program would be pRSSReader. I use it most of the time...drawing news from 47 feeds. For me, this is still the best rss program...unfortunately, it is been abandoned...sigh...

My earlier post was to highlight that the amount of free memory did play a part in the auto closing of background programs and it is only happening on the i8000. My TyTNII with just 128MB does not suffer from this issue although it is running the same 3rd parties programs.

Link to post
Share on other sites
Guest johnchan
On JB1, I am still having programs been auto closed when they are in the background if the memory falls below 40MB. If OOM is tweaked, programs in the background will auto close when memory falls below 30MB.

On soft reset, the memory is above 70MB (disabled a number of startup programs/services/plugins). Launching multiple programs is not an issue. The problem starts when over time, gwes.exe will grow larger and larger and free memory will get lesser and lesser. Then background programs will start to auto close. It will reach a point where only one program can be executed. The other program not in the foreground will not survive. A soft reset is required to start the cycle all over again. How long the cycle is will depend on what programs are commonly use and how often these programs are opened and closed.

When a program is started, gwes.exe will grow a bit. When the program is closed, chances are gwes.exe will not release the same amount that it gained earlier. Opening and closing the same program many times will make gwes.exe larger and larger. If a program is needed often, dismissing it to the background instead of closing it when not in use will help delay the growth of gwes.exe.

Sorry to say that this is the first winmo phone that I have that is having this problem. My previous were Dopods and HTCs.

Edit:

The attachment shows the system having only 39MB of free memory although hardly any program is running at the time. Over the day, I have used the phone for calls, smses, emails, rss, internet surfing, MSN, etc...now it has reached a point where a soft reset is required. 72MB of memory has already been used by the main system services. I am no longer able to run my pRSSReader and Internet Explorer without the other closing when swapped to the background.

post-60018-1266424484_thumb.jpg

I know exactly what you are talking about. And I HIGHLY doubt this is a Windows Mobile OS memory leak... I had other phones before, HTC, SEX1, and NONE of them leak memory like this.

After a reboot, I can run about 6 programs, Opera, SMS/Messaging, Navizon, Google Maps, and a few apps like that. However, after JUST ONE DAY, if I start Opera, almost everything else closes.

The BEST fun I have... which I wanted to throw the O2 out of my car, was when I was looking for a restaurant. I opened Opera and then Googled the restaurant number, called them, then I inputted their address into Google Maps, but could not find the street name. So I wanted to switch back to Opera to call them again... BUT OPERA WAS AUTO-CLOSED.

So I start Opera again, call them, got a nearby street, and want to switch to Google Maps, BUT GOOGLE MAPS IS AUTO-CLOSED.

So I restart Google Maps, wait for it to get GPS fix again... hai.

Then I want to SMS to someone, tell them I will arrive shortly... after sending the SMS, GOOGLE MAPS FREAKING AUTO-CLOSED AGAIN.

Unbelievable. I FEEL LIKE SMASHING SAMSUNG O2.

On the other hand, I found that some apps almost NEVER GET KILLED. For example, I could be running the Samsung Media Player the whole time, and it is almost NEVER CLOSED. Same for the Samsung SMS/Messaging app... it is rarely closed.

So I am guessing there is something that is giving these Samsung apps high priority, and killing everything else like Google, Opera, etc.

But the above was one time I wanted to just throw the O2 out the Window. From now on, if I want to use the O2 in the car, I will prepare myself by rebooting the phone before I leave home, then I can be sure it won't kill apps while I'm driving the car. Imagine how dangerous it was that day... and how annoying.

Edited by johnchan
Link to post
Share on other sites

For me, Opera Mobile 10 beta 3 (but previously also beta 2) seems to be part of the auto-close problem because it uses a lot of memory. Even though the task manager shows that the Opera process is only using a few MB of RAM, free program memory goes down by tens of MB (usually down to around 20MB). On the other hand, on my Tytn II with less memory I never noticed programs auto-closing, even when running Opera.

I've applied the various tweaks mentioned in this and other threads, and they seem to help only a little or not at all. If I remember correctly, these are the tweaks I applied:

  • HKLM\System\GDI\GLYPHCACHE: Delete limit0 entry
  • HKLM\Software\Microsoft\Shell\LowMem: Set ProgramMem to 96
  • HKLM\System\OOM: Set cbLow and cbVLow to 32768, cpLow and cpVLow to 16
  • Disabled startup entries CHomeManager, LinkMgr, PlayerAutoUpdater and SendMTMSG (moved them from Windows\Startup to a new Windows\Startup2 folder)

However, in this and other threads, people seem to suggest that the Samsung TaskMon service may actually cause the auto-close problem. Using MemMaid I've set this service to Manual Start (as other people suggested killing this service once it is running will make the device unstable) and restarted my device.

With this service disabled, I've been able to run up to 10 programs, including Opera with 7 tabs open and some other programs that take quite a lot of memory. I currently have 12.25MB free RAM, but I've seen it as low as 5MB. I cannot seem to run more than 10 applications; when I start an eleventh program another program is closed independently of the amount of free memory. So this is probably the limit in the number of processes.

I haven't done enough testing yet for any conclusive results, but you may want to try this out yourself. Please note that I don't know the purpose of the TaskMan service; disabling it may have some unwanted side effects so do this at your own risk. So far I haven't encountered any of the problems mentioned in other threads (screen not turning off, and slide function of keyboard no longer working is not applicable to the i8000).

Maybe a programmer can test whether applications now receive a WM_HIBERNATE message in low memory conditions instead of a WM_CLOSE message with the TaskMon service disabled?

BTW I'm running the JB1 ROM.

Link to post
Share on other sites
Guest dwallersv
However, in this and other threads, people seem to suggest that the Samsung TaskMon service may actually cause the auto-close problem. Using MemMaid I've set this service to Manual Start (as other people suggested killing this service once it is running will make the device unstable) and restarted my device.

With this service disabled, I've been able to run up to 10 programs, including Opera with 7 tabs open and some other programs that take quite a lot of memory. I currently have 12.25MB free RAM, but I've seen it as low as 5MB. I cannot seem to run more than 10 applications; when I start an eleventh program another program is closed independently of the amount of free memory. So this is probably the limit in the number of processes.

I haven't done enough testing yet for any conclusive results, but you may want to try this out yourself. Please note that I don't know the purpose of the TaskMan service; disabling it may have some unwanted side effects so do this at your own risk. So far I haven't encountered any of the problems mentioned in other threads (screen not turning off, and slide function of keyboard no longer working is not applicable to the i8000).

Okay, I think this is really, truly, finally a solid solution. I just tried this, and what d'ya know? It's actually working!

Killed this damn service off from MemMaid, switched the service to manual start, and now like you I can open a bunch of apps, free mem will go way down (18MB right now with 7 open apps) and stay there -- stable, nothing closing. Looks like a solution.

GOD D*MN F*CKING C*CKSUCKING SAMSUNG :D :D :lol: :lol: :D

Please excuse my severe profanity. It is definitely out of character. However, it is the only way to vent how I feel at the moment. It also explains why all these attempted tweaks to WM6.5 are ineffective -- it looks very much like this never had anything to do with WM.

I'll report back again after spending a day with this change. If it looks good, I'll put together a CAB to fix this for people -- shouldn't have to have MemMaid or SKTools (although you really should have SKT B) ) to fix this.

...okay, end of post, 'been several minutes while I wrote this, and nothing's changed on the phone... all seven apps still open, free RAM still under 18MB... I AM THRILLED!

Link to post
Share on other sites
Guest dwallersv

OMG, lookie here:

post-479152-1266518418_thumb.jpg

Stayed stable like this for about 5 minutes so far, with active switching between the apps, doing things with them, etc.

I've driven it down to less than 5MB of free RAM, and it'll operate there for a little bit, but then apps close until it gets back over about 40MB.

I'm guessing -- and it's just a guess -- that all those other tweaks to WM6.5 are operative when the stupid Samsung TaskMon service is knocked out of the picture.

The only one I've done is HKLM\Software\Microsoft\Shell\LowMem\ProgramMem => 128. I'm thinking those OOM parms have something to do with thresholds for how much to free up when the OS does it itself, and can modify this to just get ack up to 10-20MB when WM memory management kicks in.

Let's all experiment!

Link to post
Share on other sites
Okay, I think this is really, truly, finally a solid solution. I just tried this, and what d'ya know? It's actually working!

Killed this damn service off from MemMaid, switched the service to manual start, and now like you I can open a bunch of apps, free mem will go way down (18MB right now with 7 open apps) and stay there -- stable, nothing closing. Looks like a solution.

GOD D*MN F*CKING C*CKSUCKING SAMSUNG :D :D :lol: :lol: :D

Please excuse my severe profanity. It is definitely out of character. However, it is the only way to vent how I feel at the moment. It also explains why all these attempted tweaks to WM6.5 are ineffective -- it looks very much like this never had anything to do with WM.

I'll report back again after spending a day with this change. If it looks good, I'll put together a CAB to fix this for people -- shouldn't have to have MemMaid or SKTools (although you really should have SKT B) ) to fix this.

...okay, end of post, 'been several minutes while I wrote this, and nothing's changed on the phone... all seven apps still open, free RAM still under 18MB... I AM THRILLED!

Do you mean the "Task Monitor" (TaskMon.Dll) service? You left it to Manual or Disabled? I just putted it in Manual; will let you guys know how it goes...

Link to post
Share on other sites
Guest dwallersv
Do you mean the "Task Monitor" (TaskMon.Dll) service? You left it to Manual or Disabled? I just putted it in Manual; will let you guys know how it goes...
That's the one. I recommend people grab DotFred's free TaskManager app (one of the best TMs for PPC out there, free or paid, IMO), and use it to stop, and then disable or switch to manual start (doesn't really matter) for this service.

It identifies itself as "Task Monitor(TKM0:)" in the Services tab.

Link to post
Share on other sites

I've done some more reading on the topic; if I understand correctly the taskmon service is also responsible for turning off the device after the time-out that you can set in Samsung settings. I always turn off my phone manually and have the time-out set to 5 minutes, so didn't encounter this problem yet myself.

The thread I mentioned earlier suggests to set HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\DisableGwesPowerOff from 0 to 1 to solve this problem; I think this should be the other way around (e.g. set from 1 to 0 to enable GWES power off). I think this also means that you can no longer set the inactivity time-out via Samsung Settings, but that you have to use the standard Windows Mobile Power settings. You can enable the relevant settings applet by setting HKLM\ControlPanel\Power\Group to 1 and by removing or renaming the HKLM\ControlPanel\Power\Redirect key (of course, you need to have the original WM settings menu enabled as described in other threads).

I think we should not (only) complain to Samsung about the amount of reserved memory, but complain that their taskmon service auto-closes applications even if there is plenty of memory left. Why don't they just let Windows Mobile handle low memory situations?

Link to post
Share on other sites
I've done some more reading on the topic; if I understand correctly the taskmon service is also responsible for turning off the device after the time-out that you can set in Samsung settings. I always turn off my phone manually and have the time-out set to 5 minutes, so didn't encounter this problem yet myself.

The thread I mentioned earlier suggests to set HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\DisableGwesPowerOff from 0 to 1 to solve this problem; I think this should be the other way around (e.g. set from 1 to 0 to enable GWES power off). I think this also means that you can no longer set the inactivity time-out via Samsung Settings, but that you have to use the standard Windows Mobile Power settings. You can enable the relevant settings applet by setting HKLM\ControlPanel\Power\Group to 1 and by removing or renaming the HKLM\ControlPanel\Power\Redirect key (of course, you need to have the original WM settings menu enabled as described in other threads).

I think we should not (only) complain to Samsung about the amount of reserved memory, but complain that their taskmon service auto-closes applications even if there is plenty of memory left. Why don't they just let Windows Mobile handle low memory situations?

Damn it, that put me down. Your are correct, the device doesn't turn off the screen anymore now, and its quite a hassle for what you describe to set certain X time to let it auto turn off, right?

Link to post
Share on other sites
Guest dwallersv
Damn it, that put me down. Your are correct, the device doesn't turn off the screen anymore now, and its quite a hassle for what you describe to set certain X time to let it auto turn off, right?

@Ruud: Thanks a ton for adding your knowlege to this (really, all the info that seems to actually solve this). Still "fixed" on my O2 so far...

@Dan: No, not really a hassle at all. I followed Ruud's explanation above and modified the appropriate reg keys, set the power-off timeout via the "classic" WM Power control panel, and the device auto-powered off as expected. One reg changes are made and the device rebooted, manipulating these settings is just as easy as with the reskinned Samsung interfaces.

Until I can get a CAB together, here's what you need to do to expose the classic interface:

HKLM\Security\Shell\StartInfo\HideSettings => 0

HKLM\System\CurrentControlSet\Control\Power\DisableGwesPowerOff => 0 (note: Was 1 on my 920... as Rudd, I supect the original post about this was backwards)

HKLM\ControlPanel\Power\Group => 1

Delete HKLM\ControlPanel\Power\Redirect

Reboot.

You can get to the classic Settings cpl from the WM6.5 Start button menu. You'll have to disable TouchWiz to get there. From there, the power timeout settings you want are in the usual place: System->Power. Set the power off timeouts as desired, and they will work -- GWES is managing sleep now, instead of Samsung's idiotic TaskMon.

Edited by dwallersv
Link to post
Share on other sites
HKLM\Security\Shell\StartInfo\HideSettings => 0

HKLM\System\CurrentControlSet\Control\Power\DisableGwesPowerOff => 0 (note: Was 1 on my 920... as Rudd, I supect the original post about this was backwards)

HKLM\ControlPanel\Power\Group => 1

Delete HKLM\ControlPanel\Power\Redirect

Reboot.

You can get to the classic Settings cpl from the WM6.5 Start button menu. You'll have to disable TouchWiz to get there. From there, the power timeout settings you want are in the usual place: System->Power. Set the power off timeouts as desired, and they will work -- GWES is managing sleep now, instead of Samsung's idiotic TaskMon.

I made all this and the phone screen still doesn't turn off :D

Link to post
Share on other sites
Guest dwallersv
I made all this and the phone screen still doesn't turn off :D

Uh, did you actually go into the settings panel for Power and set the power-off timeout? Not the samsung one, the WM6 one.

Link to post
Share on other sites
Guest siemi1-OmniaII
HKLM\Security\Shell\StartInfo\HideSettings => 0 i had changed it before to 0

HKLM\System\CurrentControlSet\Control\Power\DisableGwesPowerOff => 0 was 1 changed to 0

HKLM\ControlPanel\Power\Group => 1 was 4294967295 chanded to 1

Delete HKLM\ControlPanel\Power\Redirect delated

Reboot.

After reboot i heve 40,30MB free RAM

I have opened Opera Mobile 10 b3

And started to,open tabs with pda.pl, wmpoweruser.com, pocketnow, o2.pl, onet.pl, wp.pl modaco.com first 3 opene with no problems on rest some didn't load:/ or only tex loads. After that i have 9,46MB free ram and opera didn't close.

next step was opening Google maps 4.0.0 after loading Map Opera and maps auto Cloased:/ and i have 37,60MB free ram:/

On HTC TyTn II I could do more than on Omnia II:( i thing that only solution for takt is to put WM 6.1 rOM on that device more than 100MB free ram available there..

I'm using S2U2 so i dont care about backlight it works with it.

Edited by siemi1-OmniaII
Link to post
Share on other sites

after some reading, it seems this is not a good solution due to the screen-off problem. as reported before, once you disable the Task Monitor, the screen wont' turn itself off. then it was suggested to set DisableGwesPowerOff => 0, and then the screen will turn it self off.

hower, the problem is that we are not supposed to do so by MS's document:

"The Graphics, Windowsing, and Events Subsystem (GWES) can maintain an idle timer based on user input and suspend the system after a period of inactivity. This is the method used in versions of Windows Embedded CE prior to Windows CE .NET 4.1. "

"The following table shows the registry values that control the on-to-suspend power state for Windows Embedded CE. These values are stored as DWORDs in the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power registry key. A value of zero disables the action. "

BattPowerOff, ExtPowerOff, WakeupPowerOff, ScreenPowerOff

To enable GWES to control suspend timeouts, you must use these registry settings. "

So, not only we are not supposed to use this function, you have to change these time-out setting by directly editing registry. The "power" in control panel that was enabled as reported before, does not change these values. and also, from my observation, the screen backlight off stops to work.

so, back to where we started. what can we do to turn this thing off without using DisableGwesPowerOff => 0

Link to post
Share on other sites

again by MS document, OEM can choose to implement their own application to control the power management. which I would guess it the case fo O2 by Task Monitor.

if we turn task monitor off, and without using DisableGwesPowerOff =>0, then the default power management takes over. in which keys under [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\Timeouts] decides the power state switch timeout. it seems many OEM chose this route.

however, this set of key only controls the transition between states, but NOT actual action. so to actually control the actions, we need to define specific actions associated with each state, then it involves lots of other registry keys such as

"; Turn the backlight off during UserIdle.

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\State

\UserIdle]

"Default"=dword:2 ; D2

"Flags"=dword:0

; Turn the display off during SystemIdle.

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\State

\SystemIdle\{EB91C7C9-8BF6-4a2d-9AB8-69724EED97D1}]

"Default"=dword:4 ; D4 =>display off

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\Timeouts]

"ACUserIdle"=dword:a ; implies 10 seconds : Time after which

backlight will turn off

"ACSystemIdle"=dword:14 ; implies 20 seconds : Time after

which display will turn off

"

Now the problem with O2: the control panel "power" choice only changes value of [Timeouts\ACSuspendTimeout] and [Timeouts\BattSuspendTimeout] but not the more useful "ACUserIdle" and "ACSystemIdle". which means again you need to edit the registry when you want to change them.

... seems too much hassle to continue...

Edited by pine
Link to post
Share on other sites
Guest pbasiros

So conclusively we have that disabling the service TaskMonitor (taskmon.dll) we do not have the auto-close effect but we lose the auto screen-off.

As i've seen there is a solution to enable the WM handling of auto screen-off.

So for those who knows how to make a cab. just put there all the required registry settings to enable the auto screen-off. :D

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.