Jump to content

Programs Auto-Closing!


Recommended Posts

Guest babyjosef17

Following the tips above. Yes auto screen off can still work for both battery and external power. For me I set them as I minute and 5 minutes respectively.

One thing I noticed though is that until the screen auto-off, the backlight is on. The auto-off of backlight no longer works when you switch off taskmon.

Well, something for me is not a big deal as you can just manually switch off the screen. at least if you do leave it, there is still the WM power management that will switch it off for you.

Link to post
Share on other sites
if we turn task monitor off, and without using DisableGwesPowerOff =>0, then the default power management takes over. in which keys under [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\Timeouts] decides the power state switch timeout. it seems many OEM chose this route.

Thanks for your input, I guess you're right. I just had a look at a backup of my HTC Kaiser registry, which also has DisableGwesPowerOff set to 1.

however, this set of key only controls the transition between states, but NOT actual action. so to actually control the actions, we need to define specific actions associated with each state, then it involves lots of other registry keys such as ...

Now the problem with O2: the control panel "power" choice only changes value of [Timeouts\ACSuspendTimeout] and [Timeouts\BattSuspendTimeout] but not the more useful "ACUserIdle" and "ACSystemIdle". which means again you need to edit the registry when you want to change them.

... seems too much hassle to continue...

For me, I would rather have fixed (or hard to change) backlight off and suspend time-outs instead of programs auto-closing while having lots of memory available. But I agree with you that we should try to find a better solution that will also work for the more average user. I've attached the power registry settings from my Kaiser; maybe we can use similar settings on the O2?

I've also done some more testing on my O2, looks like the Samsung Settings application and the default WM Backlight and Power control panel applets change the same registry keys (both change HKCU\ControlPannel\Backlight\*Timeout for backlight time-out, HKLM\System\CurrentControlSet\Control\Power\Timeouts\*SuspendTimeout for suspend time out). So the registry hacks for enabling the regular WM control panel applets seem unnecessary after all.

Also, as noted before disabling TaskMon may have additional side effects apart from the backlight/suspend problem. So I still think the best solution would be to complain to Samsung about the auto-close problem (and not necessarily the lack of memory) and have them fix this.

Another idea; would it be possible to write some application that simply intercepts all WM_CLOSE messages originating from the TaskMon service and discard them, and/or patch taskmon.dll to send WM_HIBERNATE messages instead of WM_CLOSE messages?

Kaiser_Power_Settings.txt

Edited by Ruud S
Link to post
Share on other sites
Guest skoda60

Thank all all friends here for sharing this topic. Finally my Omnia2 worked as a windows mobile in multi-tasks.

I love my Omnia2.

I was on JB1 ROM. Only disabled the Samsung dialer.

my test with positive results. Run many programs as: 1)Garmin mobile XT from Singapore to Genting Malaysia on simulation mode. 2)O2 compass lattest. 3)browser opened 5 taps. 4)beelinGPS. 5)Notepad mobile. 6) mDict. 7) resco explorer. 8) sktool. 9)opened a photo. 10)wmwifirouter 11)cachemate. Done twice with the above programs for 20min and closed all the program to checked my free memory and I get 75mb.

My setting:

I used latest sktools > maintenance > Shadow services to Enabled freeup RAM.

It return the free RAM to 75mb twice with the above tests.

2) Sktools > maintenance > Services to do the fellowing:

2.1) MS My Phone > manual

2.2) Syn BT Service > manual

2.3) taskmon > manual

I used psshutxp to manually off the display, shut down and soft reset.

Cheer!

Edited by skoda60
Link to post
Share on other sites
Uh, did you actually go into the settings panel for Power and set the power-off timeout? Not the samsung one, the WM6 one.

Yep, everything was done like you've explained but no luck. I'm using s2u2 to lock the phone and screen it off but even though it was not working.

Strange... but also I didn't realize to be able to run more programs than before. Again Opera 10 beta3 closes some of the programs.

In fact even now I can start and use 5-6 programs without problems.

Actually, to be more precise until I haven't' launched the Opera :D

And when I launch more than 5-6 programs the phone starts to lag enormously so I loose all my comfort to use it.

PS I've stopped also the services SmartSync and Myphone.

Edited by surenz
Link to post
Share on other sites
Guest skoda60
Yep, everything was done like you've explained but no luck. I'm using s2u2 to lock the phone and screen it off but even though it was not working.

Strange... but also I didn't realize to be able to run more programs than before. Again Opera 10 beta3 closes some of the programs.

In fact even now I can start and use 5-6 programs without problems.

Actually, to be more precise until I haven't' launched the Opera :D

And when I launch more than 5-6 programs the phone starts to lag enormously so I loose all my comfort to use it.

PS I've stopped also the services SmartSync and Myphone.

Used HolyFox PowerOff, S2U2 and SPB mobile shell were memory eater. We need Omnia2 to be more stable then nice looking.

I used Resco today plugin and HolyFox PowerOff which I downloaded from one of the post in Modeco.

HolyFox_PowerOff.cab

Link to post
Share on other sites
Guest skoda60
For me, Opera Mobile 10 beta 3 (but previously also beta 2) seems to be part of the auto-close problem because it uses a lot of memory. Even though the task manager shows that the Opera process is only using a few MB of RAM, free program memory goes down by tens of MB (usually down to around 20MB). On the other hand, on my Tytn II with less memory I never noticed programs auto-closing, even when running Opera.

I've applied the various tweaks mentioned in this and other threads, and they seem to help only a little or not at all. If I remember correctly, these are the tweaks I applied:

  • HKLM\System\GDI\GLYPHCACHE: Delete limit0 entry
  • HKLM\Software\Microsoft\Shell\LowMem: Set ProgramMem to 96
  • HKLM\System\OOM: Set cbLow and cbVLow to 32768, cpLow and cpVLow to 16
  • Disabled startup entries CHomeManager, LinkMgr, PlayerAutoUpdater and SendMTMSG (moved them from Windows\Startup to a new Windows\Startup2 folder)

However, in this and other threads, people seem to suggest that the Samsung TaskMon service may actually cause the auto-close problem. Using MemMaid I've set this service to Manual Start (as other people suggested killing this service once it is running will make the device unstable) and restarted my device.

With this service disabled, I've been able to run up to 10 programs, including Opera with 7 tabs open and some other programs that take quite a lot of memory. I currently have 12.25MB free RAM, but I've seen it as low as 5MB. I cannot seem to run more than 10 applications; when I start an eleventh program another program is closed independently of the amount of free memory. So this is probably the limit in the number of processes.

I haven't done enough testing yet for any conclusive results, but you may want to try this out yourself. Please note that I don't know the purpose of the TaskMan service; disabling it may have some unwanted side effects so do this at your own risk. So far I haven't encountered any of the problems mentioned in other threads (screen not turning off, and slide function of keyboard no longer working is not applicable to the i8000).

Maybe a programmer can test whether applications now receive a WM_HIBERNATE message in low memory conditions instead of a WM_CLOSE message with the TaskMon service disabled?

BTW I'm running the JB1 ROM.

Thank for sharing this special method. I used skTools to do it and it worked great for me and no more reset and reset many time within 2 hours.

I enjoy the Omnia2 now.

Link to post
Share on other sites
Guest dwallersv

As always, no solution is perfect.

However, after 24 hours with this workaround, I must say that for me, it is well, well worth it.

The app closing problem is completely solved for me. While I routinely had things closing in the background all the time -- in fact, I was intimately sharing johnchan's pain as he described his frustration trying to switch back and forth between google maps and opera, I've been there.

The auto-off issues after getting rid of TaskMon are, for me, simply trivial in comparison. Like Ruud, I manually put my phone to sleep by habit whenever I set it down or put it back in its belt case. So this just isn't a big deal for me.

I found that the LargeIndicators feature stopped working, and this is much more annoying to me than the auto-off issues. Not sure if this is related to TaskMon itself, or the reg changes. I'm going to unwind it and figure it out after this post, and report back. If, as others seem to have found out the reg changes are not necessary (i.e. Samsung Settings app does the same thing), maybe backing these out will bring the large indicators back.

Anyway, for those of us who really want/need useful, functional multitasking, and can live with crippled auto-off, we've found the answer.

Edited by dwallersv
Link to post
Share on other sites
Guest dwallersv

Okay, backed out all the reg changes to expose the classic Power cpl through WM6 settings.

I'm not having any issues with either screen dimming, or auto-power off. I set the screen to dim in 15 seconds, and power-off (sleep) to 30 seconds, and it performs these actions as expected, with TaskMon not running.

I'm on a Verizon i920.

Still have the benefit of WM6 memory management instead of Samsung's braindead 50MB threshold. All's good.

LargeIndicators: Backing out the reg changes did not bring this back. It is related to TaskMon. HOWEVER, there is a workaround for this too. Seems all this needs is for TaskMon to start up, apparently initializing this feature. Then, TaskMon can be stopped, and Large Indicators continue to function. Woohoo!

So, the fix for this app-closing problem is modified slightly. I'm leaving TaskMon enabled, but in manual start mode. I'm going to make a little Mortscript to run at startup, immediately sleep for a few minutes, wake up and start TaskMon, sleep for a brief time (I'll determine what this needs to be by experimentation), then stop TaskMon and exit.

Assuming all this works (I have no reason to believe it won't), then this problem will be truly, completely resolved for me, without any compromise. Apps won't close unless memory gets truly low, device dims and sleeps just as before, and Large Indicators work.

I know this annoys many that we even have to do something like this, on principle, to make these devices usable. It bugs me too. However, I'm used to having to manipulate computing devices in deep, internal ways, or writing apps, etc., to get it to do what I want and need. It's the nature of the beast.

Hopefully Samsung will correct this screwup. The best solution (and I've emailed support to this effect) would be to add a configurable threshold to start closing apps to the Settings panel, and let people make their own decisions about this. I have no doubt the reason Samsung set the threshold so high was to ensure responsiveness and percieved performance for the vast, unwashed masses that don't dig in to thing like we do. I understand the motive, don't necessarily reject it completely, but things like this should always be designed with more flexibility and configurability to meet the needs of a broader customer base.

You make a device this powerful and capable you have to include in your plans and usage profile advanced users, and design with them in mind too.

Folks having dimming/autosleep issues: Which model of O2 are you on?

Link to post
Share on other sites
Okay, backed out all the reg changes to expose the classic Power cpl through WM6 settings.

I'm not having any issues with either screen dimming, or auto-power off. I set the screen to dim in 15 seconds, and power-off (sleep) to 30 seconds, and it performs these actions as expected, with TaskMon not running.

I'm on a Verizon i920.

Still have the benefit of WM6 memory management instead of Samsung's braindead 50MB threshold. All's good.

LargeIndicators: Backing out the reg changes did not bring this back. It is related to TaskMon. HOWEVER, there is a workaround for this too. Seems all this needs is for TaskMon to start up, apparently initializing this feature. Then, TaskMon can be stopped, and Large Indicators continue to function. Woohoo!

So, the fix for this app-closing problem is modified slightly. I'm leaving TaskMon enabled, but in manual start mode. I'm going to make a little Mortscript to run at startup, immediately sleep for a few minutes, wake up and start TaskMon, sleep for a brief time (I'll determine what this needs to be by experimentation), then stop TaskMon and exit.

Assuming all this works (I have no reason to believe it won't), then this problem will be truly, completely resolved for me, without any compromise. Apps won't close unless memory gets truly low, device dims and sleeps just as before, and Large Indicators work.

I know this annoys many that we even have to do something like this, on principle, to make these devices usable. It bugs me too. However, I'm used to having to manipulate computing devices in deep, internal ways, or writing apps, etc., to get it to do what I want and need. It's the nature of the beast.

Hopefully Samsung will correct this screwup. The best solution (and I've emailed support to this effect) would be to add a configurable threshold to start closing apps to the Settings panel, and let people make their own decisions about this. I have no doubt the reason Samsung set the threshold so high was to ensure responsiveness and percieved performance for the vast, unwashed masses that don't dig in to thing like we do. I understand the motive, don't necessarily reject it completely, but things like this should always be designed with more flexibility and configurability to meet the needs of a broader customer base.

You make a device this powerful and capable you have to include in your plans and usage profile advanced users, and design with them in mind too.

Folks having dimming/autosleep issues: Which model of O2 are you on?

Awesome posts you've made man!

I'm having the dimming / sleep issue. Are you saying it's supposed to keep working as usual even with TaskMon disabled? Or if we STILL have problems after fiddling with the reg keys and using WM utility to set the time out? If it's the first then yes, I have a problem because in mine it doesn't work.

I own a I8000L and that's where this happens.

Please keep up posted on your future developments over this! Thanks!!!

Link to post
Share on other sites

Well, I stess-tested this and out of the box it didn't work. After setting the service to manual, I could never get the free memory under 40 MB while opening applications, because the device would still close them as I went.

Are you supposed to set the service in manual or what? Now I've tried editing the reg key and setting the "Enabled" one to 0. Soft resetting as I write and I'll try again

EDIT: Yeah, that still didn't work. Apps kept closing by themselves below 40 MB and also the big notifications still work, so I assume that the service is still running or something? :S

Edited by Guest
Link to post
Share on other sites
Guest dwallersv
Well, I stess-tested this and out of the box it didn't work. After setting the service to manual, I could never get the free memory under 40 MB while opening applications, because the device would still close them as I went.

Are you supposed to set the service in manual or what? Now I've tried editing the reg key and setting the "Enabled" one to 0. Soft resetting as I write and I'll try again

Did you reboot, and if not did you also stop the service?

Simply setting it to Manual without either rebooting or stopping it will not have any effect. The service is still running then, monitoring apps and memory, and closing them.

As for your differences w.r.t. the autosleep and dimming issue, I'd look first to the fact that you are on slightly different hardware than me (although I'm doubtful that is the problem), and also probably on a different OS (the verizon i920 ships with "official" 6.5 -- 6.5.2, I think).

I'd put money down that we have different OS's, and that's the problem. Are you running one of the cooked 6.5 ROMs that is really 6.1 with a 6.5 face on it?

Link to post
Share on other sites
Guest damienloh

Just realised S2U2 now fail to auto-activate. After manual activate, it turned off the screen as usual. However the battery still drained significantly, about 40% over last 5 hours, with radio turned off! I shall try the registry value.

Edited by damienloh
Link to post
Share on other sites
i8000 has official WM 6.5 (Not 6.5.3 just 6.5) ROM too. And auto power off and auto turn backlight off does not work on it when TaskMon disabled.

He is correct. The auto power off / dim doesn't work when the service is set to manual. And yes, of course I soft rebooted after changing it. Also, I'm running WM 6.5 which, as he said, came preinstalled with the unopened device from the factory

Link to post
Share on other sites
Guest janvalek

Has anyone tried this on Omnia Qwerty/B7610?

Cause when i tried i got the same results Dan has posted above..

Disabled taskmon then set it to manual. Service is off says MemMaid

But large icons still work, taskman button still opens taskmanager, and still autocloses..

Ok, after some fiddling iv managed to stop taskmon from running. Still some autocloses when i run opera for example.

And somehow the Largeicons still work. Also S2u2 doesnt autoactivate

Edited by janvalek
Link to post
Share on other sites
Guest elementalfusion

I tried disabling the taskmon and it really seems to help, now I can surf using opera 10 with pocketmusic in the background!

kudos to the one who discovered it!

Edited by elementalfusion
Link to post
Share on other sites
Guest CF Chong
However, in this and other threads, people seem to suggest that the Samsung TaskMon service may actually cause the auto-close problem. Using MemMaid I've set this service to Manual Start (as other people suggested killing this service once it is running will make the device unstable) and restarted my device.

With this service disabled, I've been able to run up to 10 programs, including Opera with 7 tabs open and some other programs that take quite a lot of memory. I currently have 12.25MB free RAM, but I've seen it as low as 5MB. I cannot seem to run more than 10 applications; when I start an eleventh program another program is closed independently of the amount of free memory. So this is probably the limit in the number of processes.

I haven't done enough testing yet for any conclusive results, but you may want to try this out yourself. Please note that I don't know the purpose of the TaskMan service; disabling it may have some unwanted side effects so do this at your own risk. So far I haven't encountered any of the problems mentioned in other threads (screen not turning off, and slide function of keyboard no longer working is not applicable to the i8000).

Maybe a programmer can test whether applications now receive a WM_HIBERNATE message in low memory conditions instead of a WM_CLOSE message with the TaskMon service disabled?

BTW I'm running the JB1 ROM.

wow...Ruud S...I could really kiss you...

thanks for pointing out this simple solution to an issue that I have resigned to learn how to live with after so many months.

Link to post
Share on other sites
Guest CF Chong
However, in this and other threads, people seem to suggest that the Samsung TaskMon service may actually cause the auto-close problem. Using MemMaid I've set this service to Manual Start (as other people suggested killing this service once it is running will make the device unstable) and restarted my device.

With this service disabled, I've been able to run up to 10 programs, including Opera with 7 tabs open and some other programs that take quite a lot of memory. I currently have 12.25MB free RAM, but I've seen it as low as 5MB. I cannot seem to run more than 10 applications; when I start an eleventh program another program is closed independently of the amount of free memory. So this is probably the limit in the number of processes.

I haven't done enough testing yet for any conclusive results, but you may want to try this out yourself. Please note that I don't know the purpose of the TaskMan service; disabling it may have some unwanted side effects so do this at your own risk. So far I haven't encountered any of the problems mentioned in other threads (screen not turning off, and slide function of keyboard no longer working is not applicable to the i8000).

Maybe a programmer can test whether applications now receive a WM_HIBERNATE message in low memory conditions instead of a WM_CLOSE message with the TaskMon service disabled?

BTW I'm running the JB1 ROM.

Finally, I am able to run my MSN and Skype in the background but without Samsung Today as the today screen.

I found that Samsung Today closes the background programs.

post-60018-1266644531_thumb.jpg

Link to post
Share on other sites
Guest janvalek
I'm going to unwind it and figure it out after this post, and report back. If, as others seem to have found out the reg changes are not necessary (i.e. Samsung Settings app does the same thing), maybe backing these out will bring the large indicators back.

Im reverting the reg changes as well. Could someone tell me what the original value of

HKLM\ControlPanel\Power\Redirect

is? I deleted it without making a backup :D

Link to post
Share on other sites
Im reverting the reg changes as well. Could someone tell me what the original value of

HKLM\ControlPanel\Power\Redirect

is? I deleted it without making a backup :lol:

me too but seems that everything works even without this key :D

you know that the registry seems to have at least 20% wasted keys :D

Pity that this trick doesn't work for some people incl me. My OS is JA5 original release by Secany so WinMo 6.5 (build 5.2.21889.5.0.87).

Edited by surenz
Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.