Jump to content

09/Feb 1.7 - MoDaCo Custom ROM - U8230 Vanilla Style (now with online kitchen)


Guest PaulOBrien

Recommended Posts

Guest Perrier
Hi,

I just installed the custom U8230 ROM V1.1 on my pulse, but I'm having trouble installing apps on the ext3 partition.

I did a wipe before installing the ROM, but when I try to install an app it fails.

The only way to install apps is to go in to recovery and select repair ext filesystem, but after a reboot it stops working again.

Hope you van help me with this problem,

Remon

How did you make your partitions? Recovery image make a swap partition which isn't allowed by this rom afaik. You have to make the partitions manually using parted in a shell or just delete the swap partition created.

Edited by Perrier
Link to post
Share on other sites
  • Replies 961
  • Created
  • Last Reply

Popular Posts

Note: Version 1.8 Beta now available - click for more details! The MoDaCo Custom Custom ROM 1.7 for Pulse - U8230 Vanilla Style online kitchen is now available! The online kitchen is currently onl

Posted Images

I've had a problem with the v1.0 and my bluetooth car kit, a Parrot CK3100.

The phone doesn't pass the audio to the carkit. It does work correctly with a Jabra 250v headset though.

I reverted to my backup and the stock T-Mobile firmware works fine with both bluetooth devices, so I conclude there's something in the U8230 that doesn't like my carkit.

Nothing in the changelog seems to suggest that the 1.1 firmware would fix this? Am I wrong?

Link to post
Share on other sites

Paul, is there a way to get the recovery ROM update e2fsck before and after the update? and/or is there a way that we can work out what's causing it to become corrupt, are their shutdown scripts that aren't umounting it when you reboot or something? I don't really know enough to jump straight to the problem, but I'd quite like to work out what's up ;)

Link to post
Share on other sites
Guest brandt14
Perhaps you have the same problem I did. I ran repair ext filesystem and fix package uid mismatches and rebooted - problem still there. I did it again, problem went away. Go figure!

Nikki

I ran the repair ext filesystem and fix package uid mismatches again, and now the apps seem to install without problems, even after a reboot. ;)

Thanks for your help ;)

Link to post
Share on other sites
Guest shuangg
How did you make your partitions? Recovery image make a swap partition which isn't allowed by this rom afaik. You have to make the partitions manually using parted in a shell or just delete the swap partition created.

It is quite simple

./adb shell

sdparted -efs ext4 -ss 0

This creates no swap, ext4=512M, fat32=remaining free space

Link to post
Share on other sites
Guest niko1986

Just moved onto this updated ROM but i'm having issues installing apps. They all say installation unsuccessful, i have repaired the ext partition etc multiple times. My card has a 7.5gb fat32 partition and 0.5 ext4 partition. I've also reapplied the update, and still the same.

Any ideas? Because i love this ROM and how fast it is.

Edited by niko1986
Link to post
Share on other sites
Just moved onto this updated ROM but i'm having issues installing apps. They all say installation unsuccessful, i have repaired the ext partition etc multiple times. My card has a 7.5gb fat32 partition and 0.5 ext4 partition. I've also reapplied the update, and still the same.

Any ideas? Because i love this ROM and how fast it is.

Hi I had similar problems. Ultimately I did a factory reset from recovery mode, repartioned SD-Card and after that I could

install applications again.

Link to post
Share on other sites
Guest niko1986
Hi I had similar problems. Ultimately I did a factory reset from recovery mode, repartioned SD-Card and after that I could

install applications again.

Seems to have sorted it with alot of restarts and ext repairs :S

Edited by niko1986
Link to post
Share on other sites
Guest Richard_Arkless

Hi im new to wiping my pulse, how do I do this

I checked under the recovery menu and there is an option to factory reset, does that wipe it or do I need to select something else

Edited by Richard_Arkless
Link to post
Share on other sites
Hi im new to wiping my pulse, how do I do this

I checked under the recovery menu and there is an option to factory reset, does that wipe it or do I need to select something else

Hi Richard,

yes it's called Factory Reset, it removes all userdata from the phone and resets/wipes it to factory state, except

it does not revert to the factory ROM (since that's not on the device), it leaves the newly installed ROM (MCR1.4 I presume)

intact.

Link to post
Share on other sites
Guest Richard_Arkless
Hi Richard,

yes it's called Factory Reset, it removes all userdata from the phone and resets/wipes it to factory state, except

it does not revert to the factory ROM (since that's not on the device), it leaves the newly installed ROM (MCR1.4 I presume)

intact.

Thanks so factory reset it then install this rom?

Link to post
Share on other sites
Thanks so factory reset it then install this rom?

Personally I would say yes, Paul said it is higly advisable (see first post). I think Paul is more knowledgeable on this platform

than me. My experience told to wipe first. I think it is always on the safe side to do so. So sorry

not the ultimate answer, but hey this is all quite experimental stuff anyway.

Edited by rss2k
Link to post
Share on other sites
Guest Richard_Arkless
Personally I would say yes, but Paul said it is higly advisable. I think Paul is more knowledgeable on this platform

than me. My experience told to wipe first. I think it is always on the safe side to do so. So sorry

not the ultimate answer, but hey this is all quite experimental stuff anyway.

OK thanks so ill backup first

Link to post
Share on other sites

I'm very happy with my U8230 altough i'm still experiencing some problems with my bluetooth connection.

I'm dealing with this problem for a few days now. I also did a complete wipe, but that doesn't seem to be a solution.

The carkit (Renault Carminat) does pair properly.

When I receive an incomming, or make an outgoing call, the volume of my radio mutes also correctly.

But then the audio goes still over the phones mic and speaker.

Anyone any idea of what reason this could be?

And my second question; the T-mobile rom does include a Dutch dictionary for touchpal.

Can this be ported to the U8230 ROM?

At last I want to thank paul for providing this adorable ROM.

Link to post
Share on other sites
I'm very happy with my U8230 altough i'm still experiencing some problems with my bluetooth connection.

I'm dealing with this problem for a few days now. I also did a complete wipe, but that doesn't seem to be a solution.

The carkit (Renault Carminat) does pair properly.

When I receive an incomming, or make an outgoing call, the volume of my radio mutes also correctly.

But then the audio goes still over the phones mic and speaker.

Anyone any idea of what reason this could be?

And my second question; the T-mobile rom does include a Dutch dictionary for touchpal.

Can this be ported to the U8230 ROM?

At last I want to thank paul for providing this adorable ROM.

Bluetooth is still troublesome with Android (remember it didn't even support bluetooth when it was introduced).

You can find lots of problems on the internet regarding this subject. I have a Ford Mondeo with the Bluetooth

option Converse+ system (through a Sony carstereo) and the Pulse conects correctly and I can make and

receive calls, but only phonenumbers are shown, no contactnames.

Results differ greatly depending on car. I am not sure whether 1.6 or 2.0 are better with regards to

bluetooth support.

Edited by rss2k
Link to post
Share on other sites
I'm very happy with my U8230 altough i'm still experiencing some problems with my bluetooth connection.

I'm dealing with this problem for a few days now. I also did a complete wipe, but that doesn't seem to be a solution.

The carkit (Renault Carminat) does pair properly.

When I receive an incomming, or make an outgoing call, the volume of my radio mutes also correctly.

But then the audio goes still over the phones mic and speaker.

Anyone any idea of what reason this could be?

And my second question; the T-mobile rom does include a Dutch dictionary for touchpal.

Can this be ported to the U8230 ROM?

At last I want to thank paul for providing this adorable ROM.

I have similar issues but its very random in that it some times works with my bluethooth and some times dosent.

This rom is awesome and has may phone really quick and has got rid of the nasty pulse ui!

Link to post
Share on other sites
Guest dac_kufer

for this rom my sd card mast be partitioned or not,i instal this rom and in the recoveri console i have to much errors,repair ext,ext2 to ext3,and more errors,i have reinstall and the same evry time.pls help

SORRY FOR MY ENGLISH

Link to post
Share on other sites
Guest Richard_Arkless

just wiped my phone and installed this rom, I think this is way better than the tmobile customized ones (I think its the pink on black look which I dont like), its really fast as well

thanks for releasing another great release

Link to post
Share on other sites
Bluetooth is still troublesome with Android (remember it didn't even support bluetooth when it was introduced).

You can find lots of problems on the internet regarding this subject. I have a Ford Mondeo with the Bluetooth

option Converse+ system (through a Sony carstereo) and the Pulse conects correctly and I can make and

receive calls, but only phonenumbers are shown, no contactnames.

Results differ greatly depending on car. I am not sure whether 1.6 or 2.0 are better with regards to

bluetooth support.

Well the strange thing is, that it did work with the original T-mobile ROM! Maybe it will be fixed in the upcomming 2.0 release...

Link to post
Share on other sites
And my second question; the T-mobile rom does include a Dutch dictionary for touchpal.

Can this be ported to the U8230 ROM?

At last I want to thank paul for providing this adorable ROM.

yeah thats the one thing i miss most atm .. dutch dictionary for touchpal. i actually bought betterkeyboard from market just for the dutch dictionary. but touchpal just is better. if there is a way someone could get the dutch dictionary somehow from the t-mobile rom i'd be very pleased. or just posting a "how to" if its an easy thing to do.(dictionary's shouldn't be that hard to copy from one device to another right?)

Link to post
Share on other sites
I fixed my errors but now i have internal memory 101MB and my sd card is gone:sd card-total space/unavailable:available space/unavailable how can i fix this???pls

I had the same, I repartioned and reformatted the whole SD-Card again. Also make sure you do not create a swap partition.

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.