Jump to content

09/Feb 1.7 - MoDaCo Custom ROM - U8230 Vanilla Style (now with online kitchen)


Guest PaulOBrien

Recommended Posts

Guest zoidster
Hi, not sure if you've sorted it yet but the way I got into the Recovery menu was to install Paul's Superboot as per this thread: http://android.modaco.com/content/t-mobile...cing-superboot/

This installed an app called Quick Boot, which allows you to boot into Recovery. I'm not very clued up on all this Rom business lol so there may be another easier more practical method (adb??), but anyhow that's the way I did it.. good luck!

Perfect ! Worked a treat ... thanks mate

Link to post
Share on other sites
  • Replies 961
  • Created
  • Last Reply

Popular Posts

Note: Version 1.8 Beta now available - click for more details! The MoDaCo Custom Custom ROM 1.7 for Pulse - U8230 Vanilla Style online kitchen is now available! The online kitchen is currently onl

Posted Images

Guest Downloaderz

Just flashed my new pulse with this rom. Vanilla > T-Mobile

I was just wondering, is it possible change any of the three homescreens to be the default? Also, anyway to edit the lockscreen?

Edited by Downloaderz
Link to post
Share on other sites

Does anyone know if Touchpal has languages next to English when I flash my Pulse with this rom?

I don't mind my phone to be in English (it already is), but T9 in Dutch would be great if this rom does it.

/EDIT, I just read in the changelog that "Restore other languages for TouchPal" is planned for a future release. I guess it's not included in this one then.

Edited by bas-r
Link to post
Share on other sites
Guest Samlock

Paul - felt I should probably make my first post a thank you one... Your custom ROM is the mutts nuts! Far better than T-Mobile rubbish, especially as I'm using an Orange PAYG SIM so I don't wanna have to stare at the stupid pink rubbish >.<

Loving it mate, keep up the good work! Will be subscribing after pay day! (expensive christmas so far, the missus is now interested in a Pulse for christmas too!)

Link to post
Share on other sites
Guest kayahah

Amazing rom, really it even made the trackball more easy to use and the speed difference is insane didnt think android could get quicker but it did.. Great job paul and anyone else making this one available and continue ur great work.

Link to post
Share on other sites
Guest JingleManSweep
Oops - I guess it must get part of user agent from ro.product.model in /system/build.prop.

Yes, I recommend changing build.prop as this string (including your SSH password) is also used in the "Name" of your Pulse when Bluetooth is enabled. So, in effect, someone could get your phones root password just by browsing for Bluetooth devices.

Link to post
Share on other sites

Hi

I have followed all of the instructions to get this rom installed and most of it works ok. However, I dont think A2SD is working. I have used a file browser to look for data within /system/sd and there are no folders under there (eg no /system/sd/app). I downloaded some apps from market place but i think they ended up on the phones internal memory as this keeps dropping when i install a new app.

Can someone 100% confirm App2sd is working correctly on this rom? I know on the other rom 1.4.0 Paul had forgotten the a2sd script and added it back to 1.4.1. Could the same thing have happened here?

Also trying to check if compcache is running. Can you only run adb against the phone when in recovery mode? I type in free from the adb shell but see no datasize for swap so think it is not running. Or does compcache not run in recovery mode? People have mentioned running a terminal emulator, does this mean I can check these things from the phone without connecting a pc? If so what terminal emulator should i install and where do i get it from?

Thanks.

Link to post
Share on other sites
Guest bounty123

I can confirm it to you, that apps2sd works with this rom just fine. I have about 80MBs of apps installed, and the device shows 90MB free space. (This is the storage size which is 60MB at start with the stock rom). You need an ext partition as 2nd one behind the fat32 partition on the SD card. You can try running ext repair from the recovery menu, because if the ext2 partition isn't unmounted correctly (happens all the time, each reboot or usb transfer basically) then it won't get mounted at the next reboot.

I don't think you'll have compcache in recovery mode. Regarding the terminal emulator: yes, in it you can run the commands just as if it was a regular linux shell. Commands like free, df, top, mount etc. work. I use the Better Terminal Emulator app for this.

Link to post
Share on other sites
Guest kayahah

I need some help now, after a reboot my market wouldnt let me install apps so i went into recovery mode to and did the Fix EXT or what it was called, and now it just wont boot again it get stuck on the Android text when it boots the phone and nothing happend for around 30min... Is there anyway to fix this?

EDIT: Found an old post about this problem so trying to fix it through amon recovery now.

2nd EDIT: Did a wipe of the sd:ext partion and it booted, almost got an heartattack!

Edited by kayahah
Link to post
Share on other sites
Guest kayahah
Although you would of now killed google maps doing the ext wipe.

If your using the latest recovery image it should be as simple as:

factory reset

create a ext3 partition and no swap

update

I downloaded a new copy of google maps now(which couldnt be installed ;) so will do a new fresh install instead), but thx for informing me hadnt noticed it being gone even, and now i atleast know the right way to do it if it happens again. Also i used ext4 filesystem maby i shudve used ext3 instead?

Btw the problem with Market not being able to install apps after reboots, would it be fixed if i get a class 6 sd card? Right now im using the 2gb that came with the phone(got no clue if its class 6), but will change it this week.

Edited by kayahah
Link to post
Share on other sites
Yes, I recommend changing build.prop as this string (including your SSH password) is also used in the "Name" of your Pulse when Bluetooth is enabled. So, in effect, someone could get your phones root password just by browsing for Bluetooth devices.

It only uses that if you don't set a BT name ;)

Link to post
Share on other sites
Guest Wharf82

Just got this ROM installed on my Pulse, wow what a difference.

Barcode apps would not work before, now work fine! Look & feel a lot better. I had issues with keyboard before but they seem to have gone away now too!

Just one more question, only a small thing... When I very first switch on I get a 'T-Mobile' logo still, any easy way to change that?

Thanks.

Link to post
Share on other sites
Guest Nikki Locke

I have found an issue with this ROM - the getprop command doesn't work (it always returns nothing).

This explains why the DNS server provided by my DHCP server is never used (the DHCP scripts use setprop to store the current server).

I don't know why this is, as I haven't found an explanation of where/how properties are stored in Android.

Please could other users please try running getprop from a command line, and let me know if it outputs anything, and what ROM they are using? If yours does, then it is a problem with my phone. Otherwise it might be a problem with the ROM or the Pulse.

[Later] I found that getprop doesn't work from within an ssh shell prompt - but it does work from adb. I wonder why that is? Sorry for the noise!

Edited by Nikki Locke
Link to post
Share on other sites
Guest Shuflie
I have found an issue with this ROM - the getprop command doesn't work (it always returns nothing).

This explains why the DNS server provided by my DHCP server is never used (the DHCP scripts use setprop to store the current server).

I don't know why this is, as I haven't found an explanation of where/how properties are stored in Android.

Please could other users please try running getprop from a command line, and let me know if it outputs anything, and what ROM they are using? If yours does, then it is a problem with my phone. Otherwise it might be a problem with the ROM or the Pulse.

Works for me here in better terminal emulator. I get about 3 screens worth of information. I'm on the 1.1 U8230 based ROM.

Link to post
Share on other sites
Guest Janesy B

Hi,

Thanks for all the hard work that's been put into this. I have installed via recovery and didn't do a wipe.

Now phone is working fine except for when I switch between the home panes, it'll force a crash on the android process 'android.process.acore', has anyone seen this issue?

It also appears to happen, only when i've switched to the leftmost pane and then I attempt to go back home.

Edited by Janesy B
Link to post
Share on other sites
Hi,

Thanks for all the hard work that's been put into this. I have installed via recovery and didn't do a wipe.

Now phone is working fine except for when I switch between the home panes, it'll force a crash on the android process 'android.process.acore', has anyone seen this issue?

It also appears to happen, only when i've switched to the leftmost pane and then I attempt to go back home.

If you read the earlier posts in this thread you'll find the answer ;)

Basically, you need to wipe.

Link to post
Share on other sites
Guest Janesy B
If you read the earlier posts in this thread you'll find the answer ;)

Basically, you need to wipe.

Doing so now ;)

I just did a wipe and reinstalled the image and I got a french image :s I'm just trying again to make sure it wasn't a mistake on my part.

**EDIT**

Just did a wipe and it appears to be doing the same thing. I'll read back through the thread.

Ok, I did do a wipe and reapplied the zip but all my apps are still there ;)

What specific option should I choose in the recovery menu?

Edited by Janesy B
Link to post
Share on other sites
Guest Nikki Locke
Hi,

Thanks for all the hard work that's been put into this. I have installed via recovery and didn't do a wipe.

Now phone is working fine except for when I switch between the home panes, it'll force a crash on the android process 'android.process.acore', has anyone seen this issue?

It also appears to happen, only when i've switched to the leftmost pane and then I attempt to go back home.

That happened to me - I had to do a wipe. I think may be something to do with the 8230 having a different screen area for the icons.

Link to post
Share on other sites
Guest Nikki Locke
Works for me here in better terminal emulator. I get about 3 screens worth of information. I'm on the 1.1 U8230 based ROM.

I find getprop works from adb shell, but not if I putty/ssh in from outside. Wierd.

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.