Jump to content

24/May r4 - HTC Legend rooting guide - Now with 1.31.x


Guest PaulOBrien
 Share

Recommended Posts

Guest tripledes

Hi there,

could you post you ROM version? if you got > 1.31 you're doomed like lots of us....

Sorry to p*ss on your chips Paul (so to speak). thanks for the hard work, however, this will not work on the latest HTC Legends running...

LEGEND UNKNOWN SHIP S-ON

HBOOT-0.43.0001

I've tried 3 different goldcards (Kingston/Scandisk/other) so it's NOT the goldcard that is causing the problem.

On step 1 the following error occurs in BOTH Linux boot CD and Windows XP

INFOchecking main version...

FAILED (remote: 43 main version check fail)

On step 2 the following error occurs

error: device not found

Now, it seems to me a vast majority of people posting on this forum are having the same problem. It seems to be with the latest HTC Legends.

I've tried downgrading to 1.21 but still having issues.

If anyone has a solution please post it, because as from here in anyone with a new HTC Legend will not be able to flash it using this guide.

Link to comment
Share on other sites

Guest borgfather

for so far rooting went perfect

i can now boot into recovery end re-flash my Legend without any problem

BUT !! i have trouble getting Apps2SD working as it should

once it worked fine till the next reboot and all my apps ( included market ) were gone only the apps instaled on the system partition were usable

i think it has trouble recognizing the Ext3 partition in some way

i flashed it now to the rom provided with the rooting pakkage

can someone help me please

Link to comment
Share on other sites

Guest Balu5

hey,

i got an ota update yesterday, version: OTA_Legend_HTC_WWE_1.31.405.5_R-1.31.405.4_R_release_signedr69y197g1beojn9c.zip

but i cannot update my phone. i tried the automatic update process, and after that manually with recovery-windows.bat, it says verification error, flash failed.

what to do now? :(

Link to comment
Share on other sites

Guest tripledes

Hi,

I think if you flash it you'll lose your root but with that release I think you will still able to re-root your legend....now, take the zip, push it to your goldcard and flash it from recovery menu.

Take care.

hey,

i got an ota update yesterday, version: OTA_Legend_HTC_WWE_1.31.405.5_R-1.31.405.4_R_release_signedr69y197g1beojn9c.zip

but i cannot update my phone. i tried the automatic update process, and after that manually with recovery-windows.bat, it says verification error, flash failed.

what to do now? :(

Link to comment
Share on other sites

Guest Balu5
Hi,

I think if you flash it you'll lose your root but with that release I think you will still able to re-root your legend....now, take the zip, push it to your goldcard and flash it from recovery menu.

Take care.

hi,

do i need goldcard for update?

does this update worth it to lose my root? is there any changelog for that?

thx for help!

Link to comment
Share on other sites

Guest Phyxius89

Hello.

A few days ago i decided to give rooting a go.. I made a gold card which was fairly easy, and then went on to the first step in the actual rooting. I unpacked the needed files, and navigated to them in command prompt, connected my phone (got the red marked fastboot usb line). Then i started the step1-windows.bat file and i got this:

Legend Root Step 1

Erasing cache and rebooting in RUU mode

< waiting for device >

It kept being like this for ten minutes though, and i figured something was wrong. I have tested it on both Windows 7 64 bit and Windows XP 32 bit. I do not have any linux experience, so i havent tested it there. I have a mac available though, but no experience in mac terminal.

If anyone could help me get on with this it would be awesome, so i can get my phone rooted. The command prompt was of course run as administrator, and i had usb debugging checked on my phone.

Thx in advance, Phyxius.

Link to comment
Share on other sites

Guest puma79

Hello everyone, I have a HTC branded Legend Fastweb Italy, I followed the guide to get root permissions, everything went well, but continues to operate only with sim htc legend Fastweb, there is a way to unlock the SIM? Thanks

Link to comment
Share on other sites

Guest borgfather

Can someone help me please

I have rooted my Legend with success but for some reason my ext3 partition on my sd card is not reconized

sometimes it is and sometimes it is not

i had the coocked rom om my phone and a2sd worked till next reboot

after that my apps were gone and the ext3 partition too

i had to reflash my phone again to gain acsess

please help me

ok i tried an other sd card and the same problem

it first boots fime bus as soon there are programs on the sex partition

this partition is not mounted on boot

Edited by borgfather
Link to comment
Share on other sites

Guest zakengen

:( thanks Paul

Y R GR8

it very nice thing that you are supporting legend

for the time been what is the available method for adding new fonts :(

Link to comment
Share on other sites

Guest borgfather

Dear Paul

I would like to understand more about the rooting prosess

can you please expland step one and two :

what hapends in these steps ?

some questions i have about the prosess are :

* if one sucseeded in getting the rom replaced withe the rooted one does this meen all the steps went well or is it possible some parts of the oritional system remaind and is interfering with the new Rom ( in my case the Ext2 partition is verry unstable )

* if i enter in recovery mode , use the command ./recovery-linux.sh to get the menu on the phone , and update from a romfile on the sd card dou this wipe the former rom installed or is it copyed on top of it ?

as for now i have the MoDaCo rom Without addons installed and if i insert a sd card with an ext partition on it it copys my apps to the sd card mount it and by the next boot it is all gone and my phone has no apps installes ( exept the ones from the rom ) not even the marked app

i'm trying to understand why this is happening

Thanks

Link to comment
Share on other sites

Guest huangxuling

Hi, Paul!

i updated my legend to "RUU_Legend_Vodafone_AU_2.02.178.2" and found that i cannot root it anymore! and also cannot return to 1.31 version....

can anyone help me???!!!

Link to comment
Share on other sites

Guest Ale Baba
i updated my legend to "RUU_Legend_Vodafone_AU_2.02.178.2" and found that i cannot root it anymore!

There's no way to root it at the moment.

Allow me a question: Why do you update your phone without reading up on the topic?

Both XDA and Modaco do have threads/posts about not being able to root newer versions. If you got the device with such a build that's bad luck, but updating and then starting to cry is the worst idea of all!

Link to comment
Share on other sites

Guest Ravrahn

I'm trying to root my Legend (unlocked British Legend, 1.31.x I believe) with a 32-bit Windows 7 Enterprise machine.

I made it past step 1 fine.

When I ran step 2, this happened:

C:\Users\Ravrahn\Documents\Downloads\r4-legend-root>step2-windows.bat

Legend Root Step 2


Pushing required files to device...


* daemon not running. starting it now on port 5037 *

ADB server didn't ACK

* failed to start daemon *

error: cannot connect to daemon

adb server is out of date.  killing...

ADB server didn't ACK

* failed to start daemon *

error:


Pushing update file to device sdcard - this may take a few minutes...


adb server is out of date.  killing...

ADB server didn't ACK

* failed to start daemon *

error:

adb server is out of date.  killing...

ADB server didn't ACK

* failed to start daemon *

error:


Now wipe and apply rootedupdate.zip from the recovery image menu.


adb server is out of date.  killing...

ADB server didn't ACK

* failed to start daemon *

error:
I tried it again, same thing. My phone is on a screen with a grey phone next to a big red ! in a triangle. I think the problem is to do with the adb drivers. Is it safe to remove my phone from my PC and attempt step 2 on a Mac? Alternatively, can I install the drivers on a 32-bit Windows 7 Enterprise machine, while the phone's still on this screen? If I can, how? I've tried HTC Sync, it doesn't work, I've tried the default Device Manager installer, it didn't work. Is there a download for the adb drivers that I can install with the cmd or something? EDIT: OK, so I took it to the Mac, and ran the entire process again. I tried going into Recovery after running it, and going into it before, and various other things. None worked. With most I got:
Pushing required files to device...


* daemon not running. starting it now *

* daemon running successfully *

error: device not found

error: device not found


Pushing update file to device sdcard - this may take a few minutes...


error: device not found

error: device not found


Now wipe and apply rootedupdate.zip from the recovery image menu.
But in the first try, I got something like this:
 -exec 'system/bin/sh' does not exist

A couple of times, then it stopped.

How can I finish the root? I'm stuck with the test image, and I can't stay with that!

Edited by Ravrahn
Link to comment
Share on other sites

Guest borgfather

for some reason my ext partition fails to mount

i folowd the rooting gide and have now the modaco rom without anny add ons

i cant understand why but wathever i try it does not show up in /system/sd

can somebody help me please

fat32 mounts O.K.

Link to comment
Share on other sites

Guest lampux

paul when will you give us a new simpler method to root our legend? I read on twitter you're focusing on a very ugly phone the dell streak...who care about a phone bigger than a interphone??? Try to focus on cool phones like legend ok? Cheers

Link to comment
Share on other sites

Guest AJLEGEND

Good day Paul,

I was wondering if it would be possible for you to root the 1.32 rom or atleast show us it its possible to downgrade to the rootable rom version.

Us Legend users in India run on 1.32,. This is my first android device and would love to have root access with ur help ofcourse.

Appreciate all u ve done so far. if here s any resource u d need for this, do let me know nd i ll try me best to find it.

Regards

AJLEGEND

Link to comment
Share on other sites

Guest Ale Baba
i folowd the rooting gide and have now the modaco rom without anny add ons

If I understodd you correctly and you followed the guide only, then you'll have a rooted Legend, but no A2SD support. You'll have to flash an image with A2SD built in.

paul when will you give us a new simpler method to root our legend?

Were you able to root your Legend?

If no, what exactly is your problem with the method Paul published? Anything that didn't work?

Link to comment
Share on other sites

Guest borgfather
If I understodd you correctly and you followed the guide only, then you'll have a rooted Legend, but no A2SD support. You'll have to flash an image with A2SD built in.

Correct but i do not want to have the add-ons so i want to set it up by hand

the problem is : my Ext partiton is not recognized

or sometimes it is ( direct after flashing and wiping ) but then at the second boot it is gone ( taking all installed aps with it )

Link to comment
Share on other sites

Guest borgfather
paul when will you give us a new simpler method to root our legend?

Just to ensure you : it is not that difficult or complex !!

really have a good look at the process

after rooting it the first time it is just a few minutes to put an other rom on it

good luck

Link to comment
Share on other sites

Guest frullewulle

HI,

I've succesfully rooted my legend.

when checking for the new update from htc (1.31.405.5), i can download it, but the installations hangs

is this a known issue?

any ideas how to fix this

i've allready have remove the superuser apk and /system/xbin/su as mentioned in another tread...

thnkx

Link to comment
Share on other sites

Guest Ravrahn
OK, so I took it to the Mac, and ran the entire process again. I tried going into Recovery after running it, and going into it before, and various other things. None worked. With most I got:

Pushing required files to device...


* daemon not running. starting it now *

* daemon running successfully *

error: device not found

error: device not found


Pushing update file to device sdcard - this may take a few minutes...


error: device not found

error: device not found


Now wipe and apply rootedupdate.zip from the recovery image menu.
But in the first try, I got something like this:
 -exec 'system/bin/sh' does not exist

A couple of times, then it stopped.

How can I finish the root? I'm stuck with the test image, and I can't stay with that!

Can someone please help? I don't want too be stuck using this test image!

Do I need to run just step 2, or do it all again without removing the goldcard, or something more complex?

Please help!

Link to comment
Share on other sites

Guest frullewulle
HI,

I've succesfully rooted my legend.

when checking for the new update from htc (1.31.405.5), i can download it, but the installations hangs

is this a known issue?

any ideas how to fix this

i've allready have remove the superuser apk and /system/xbin/su as mentioned in another tread...

thnkx

Fixed it: installed RUU_HTC_Legend_1.31.xxx.exe that i found on google (hotfile donwload)

http://www.hotfile123.com/download.php?fil...6592.signed.exe

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.