Jump to content

24/May r4 - HTC Legend rooting guide - Now with 1.31.x


Guest PaulOBrien

Recommended Posts

Guest jakontil

ok i have tried to move to another OS, using the mac

as soon as i typed in ./step1-mac.sh

permission denied

the same with ./fastboot-mac devices

permission denied

weird...

under winXP, it isnt denying any access, but any action under goes, failed...

i have no idea where i went wrong... i should have got the goldcard correctly

Link to post
Share on other sites
Guest SimoxTa

Stuck at this point...

Windows 7 Professional x64 (I launched the bat both in standard mode and in admin mode, which instantly closes the app) any suggestions?

post-593226-1272994702_thumb.png

Link to post
Share on other sites
Guest theintelligent

Successfully rooted with HBoot 0.43 and ROM 1.31 with no problems.

Paul you are great. Now I am anxiously waiting for your ROM :P Hope it will be out soon.

Link to post
Share on other sites
Guest squitsaintis

hey there.. noob here.. and im from Asia.. Have been reading and following alot on these rooting stuff..

try to root my htc legend (Asia Rom .43 and 1.31).. and it worked on the !st attempt..

thanks so much Paul... Appreciate it...

*just be follow the simple steps and it will definitely work...

Link to post
Share on other sites
Guest bBarou
Stuck at this point...

Windows 7 Professional x64 (I launched the bat both in standard mode and in admin mode, which instantly closes the app) any suggestions?

I had the same problem. But I dual boot linux and it works fine under it.

Link to post
Share on other sites
Guest SimoxTa
I had the same problem. But I dual boot linux and it works fine under it.

ok thanks. i guess it's virtual machine time then :D (sometimes it's nice to don't feel so noob :P )

Link to post
Share on other sites
Guest ilos

same for me : French Legend Branded SFR rooted :P

just to be sure : when i click on "superuser permissions" i must see something ? coz just a black screen :D ( i will look other thread in the forum to learn more about it )

Edited by ilos
Link to post
Share on other sites
Guest nieldk

Hi Paul, (and others, please)

I have updated using R3.

WiFi now works, however, I still experience connection issues with mobile network. Pages wont locate at all.

Connection is established and I get a 3G (or H sometimes) symbol. But pages just wont resolve.

A remark. It may be connected to the fact that I am currently roaming in Lithuania. But, the original 1.31 ROM was indeed able to roam and use cellular data, so I feel pretty sure this is not the issue.

Anyways, great job, and a congraulation is in place mate.

Link to post
Share on other sites
Guest chinana

hi thx to the updates, now im in the final stage of the "wipe" option.

im click in the wipe option and there are few option as below:

wipe data/factory reset

wipe cache

wipe dalvik-cache

wipe sd:ext partition

wipe battery stats

wipe rotate settings

i selected the wipe sd: ext partition

but it shows wipping ext filesystem:

Error : Run 'wipe ext' via adb!

what is that means?

can anybody help me? pls... thx.lot..

Edited by chinana
Link to post
Share on other sites
Guest wildcathcmc
hi all, im running on the 1st step...

"In the terminal window, enter either 'step1-windows.bat', './step1-mac.sh' or './step1-linux.sh' as appropriate."

after type that in the terminal window it shows: as below :

Microsoft Windows XP [Version 5.1.2600]

© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Ronald>cd\

C:\>cd\root\

C:\Root>step1-windows.bat

Legend Root Step 1

Erasing cache and rebooting in RUU mode...

erasing 'cache'... OKAY

... OKAY

About to start flash...

< waiting for device >

sending 'zip' (121756 KB)... OKAY

writing 'zip'....

and my phone is appearing HTC word on the screen with black wallpaper...

i waited about 20 min.. it still showing the same things...

may i know whats going wrong?

thx..

Same problem

I tried so many times, still got "writing zip...."

Windows 7 32

Paul, you can help?

Thanks

Link to post
Share on other sites
Guest chinana
Same problem

I tried so many times, still got "writing zip...."

Windows 7 32

Paul, you can help?

Thanks

hi wildcathcmc...

i managed to solve that problem ... you just need to restart ur pc or laptop and try again

i tried and it works..

thx.. now im stuck at the last stage... @@

help me paul...

Link to post
Share on other sites
Guest FrankT

I tried to run the wireless tethering but it keeps the root permissions not respondind, i did the root upgrade, but now is not the goldcard inside, it suppossed to be ok?

regards

Link to post
Share on other sites
Guest amirroso

Few questions:

should i extract the file i download to the directory in the SD card or in my computer?

If not on SD card, how can i update zip from SD card if the card is Empty?

PLEASE HELP.

Link to post
Share on other sites
Guest FrankT

I try too, downloading a terminal, i write "su" and enter, and show me a black screen with "SU request" but it doesn't do anything...

any help? i think i don't need to be the goldcard always inserted... but i think that it's an error in root mode... How i know if i'm root?

Regards

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.