Jump to content

30/Jun r5 - MoDaCo Custom ROM for GSM Hero now with Online Kitchen - Android 2.1


Guest PaulOBrien
 Share

Recommended Posts

Thanks for the reply.

You mean i need to Bake and Reflash my Hero again? :( can Titanium backup my entire phone including the prefs?

Kind of lazy to go thru the whole process again. ;)

Regards

I'm also lazy so I pushed the file with adb. Just put the zip in sdk/tools and then

adb remount
adb push bootanimation.zip /system/customize/resource/bootanimation.zip
adb reboot[/codebox]

The path to the zip should be correct but I'm on a different 2.1 right now so you should double check it before you push.

Link to comment
Share on other sites

I'm also lazy so I pushed the file with adb. Just put the zip in sdk/tools and then

adb remount
adb push bootanimation.zip /system/customize/resource/bootanimation.zip
adb reboot[/codebox]

The path to the zip should be correct but I'm on a different 2.1 right now so you should double check it before you push.

Hey Thanks Skywrit3r! It works now! ;)

I did thot abt the pushing using adb part.. but missed out the remount part. hehe

Link to comment
Share on other sites

I think I don't have enough space to install HTC CIME. that's why it cause the error, how to free more system space?

I check with android terminal df it stats

/dev/block/mtdblock3 available 24372 86% /system

Link to comment
Share on other sites

I think I don't have enough space to install HTC CIME. that's why it cause the error, how to free more system space?

I check with android terminal df it stats

/dev/block/mtdblock3 available 24372 86% /system

Did you deselect HTC IME in the kitchen? Looks like you can only install one or the other

Link to comment
Share on other sites

Did you deselect HTC IME in the kitchen? Looks like you can only install one or the other

Kitchen for premium members wo, I don't have oh. ;)

Link to comment
Share on other sites

if we install this, do we have to rewipe to install the new when the final 4.0 comes out? and also, i've read that it's not good to restore stuff like system settings using mybackup pro.. surely contacts, sms and stuff like that are ok? cheeeeeeers

also also, how is battery life? i saw earlier in the thread that it's not so great..

Edited by JamieGrossman
Link to comment
Share on other sites

Hi guys,

quick question, should i use A2SD or A2SD+. what are the benefits of each? Sorry if this has already been asked but I've looked and can't find which to use. Just about to cook my first 2.1 rom after coming back from holiday!

Cheers, Dave

Link to comment
Share on other sites

Hello Guys,

I've happily flashed r4 build 3 on my hero, and things have been working great.

I used the kitchen and excluded Sync since I don't use that tool.

Now when I plug my phone, it doesn't offer me to mount the SD card for the computer access.

Going to phone settings and Connect with PC menu, it just force closes com.android.settings

Any recommendations? USB debugging has been enabled or disabled, still same result.

Thank you.

Link to comment
Share on other sites

Hello Guys,

I've happily flashed r4 build 3 on my hero, and things have been working great.

I used the kitchen and excluded Sync since I don't use that tool.

Now when I plug my phone, it doesn't offer me to mount the SD card for the computer access.

Going to phone settings and Connect with PC menu, it just force closes com.android.settings

Any recommendations? USB debugging has been enabled or disabled, still same result.

Thank you.

You need HTC sync to connect to PC, rebake with HTC Sync included.

Link to comment
Share on other sites

Hi guys,

quick question, should i use A2SD or A2SD+. what are the benefits of each? Sorry if this has already been asked but I've looked and can't find which to use. Just about to cook my first 2.1 rom after coming back from holiday!

Cheers, Dave

don't use A2SD+ if you have partitioned your SD card, which I assume you have.

but please! somebody answer my questions im dying to flash this rom!

1. how is the battery life?

2. must we wipe when the final build comes out?

thank you!!

Link to comment
Share on other sites

don't use A2SD+ if you have partitioned your SD card, which I assume you have.

but please! somebody answer my questions im dying to flash this rom!

1. how is the battery life?

2. must we wipe when the final build comes out?

thank you!!

The Battery Life is good on this ROM, for me it lasts for about 1 to 1.5 days with heavy WiFi usage, As far as the Wipe is concerned, It may not be necessary to Wipe but It will be better if you Wipe, But it'll surely work without a Wipe.

Link to comment
Share on other sites

right ok i took the plunge and installed it, and everything seems to be in order, except one annoying thing :/ i restored my contacts from mybackup pro, and every time i try to link the contacts with my facebook, no contacts come up. it says none found, even when i haven't searched for anyone. really annoying as i love when my contact pictures come up

anyone else having this issue? thanks :lol: and thank you paul!!!

edit: same issue when tyring to make a new contact.. however! when i go into the photos app, i can look at my facebook friends albums, so i obviosuly am connected.. what?

edit edit: and now it's working.. well im not going to complain :D

Edited by JamieGrossman
Link to comment
Share on other sites

don't use A2SD+ if you have partitioned your SD card, which I assume you have.

Hi

Why do you say not to use a2sd+ with an already partitioned card?

Link to comment
Share on other sites

Hi

Why do you say not to use a2sd+ with an already partitioned card?

i actually misread the front page. it says you can either have a2sd, or a2sd+.. not together, so i am not actually sure. hopefully someone more knowledgable can answer your question

Link to comment
Share on other sites

right ok i took the plunge and installed it, and everything seems to be in order, except one annoying thing :/ i restored my contacts from mybackup pro, and every time i try to link the contacts with my facebook, no contacts come up. it says none found, even when i haven't searched for anyone. really annoying as i love when my contact pictures come up

anyone else having this issue? thanks :lol: and thank you paul!!!

edit: same issue when tyring to make a new contact.. however! when i go into the photos app, i can look at my facebook friends albums, so i obviosuly am connected.. what?

edit edit: and now it's working.. well im not going to complain :D

I think it takes quite a while to do the initial sync. After a new flash, FB photos started appearing next to my contacts in batches, trickling in over the course of a couple of hours.

Link to comment
Share on other sites

I installed over 3.2. Had to do a complete wipe. Works very nice and smooth. I can't find any problems with it. Battery life seems about the same as 3.2. Makes me like my Hero even more than I already did. I'll have no problems sticking with it for some time to come. :lol:

Edited by lannatwin
Link to comment
Share on other sites

Argh it happened again last night before i went to bed. adb kept telling me i cannot remount though when i connected to my pc :lol:

also was not getting any messages saying a usb device was connected. going to change the default setting from charge to disk drive and see if that helps when it happens next time

argh so this has just started happening again!!!!

the adb logcat isn't working. it gives me this message:

adb server is out of date. killing...

* daemon started successfully *

- waiting for device -

i really don't know what to do at this point. any help would be greatly appreciated!

Link to comment
Share on other sites

argh so this has just started happening again!!!!

the adb logcat isn't working. it gives me this message:

adb server is out of date. killing...

* daemon started successfully *

- waiting for device -

i really don't know what to do at this point. any help would be greatly appreciated!

snap.. and when i try to reinstall adb, it doesn't let me install the drivers from a specific location :/

Link to comment
Share on other sites

argh so this has just started happening again!!!!

the adb logcat isn't working. it gives me this message:

adb server is out of date. killing...

* daemon started successfully *

- waiting for device -

i really don't know what to do at this point. any help would be greatly appreciated!

snap.. and when i try to reinstall adb, it doesn't let me install the drivers from a specific location :/

Have you guys used Droid Explorer by anychance?.... I had the same problem yesterday,....

http://forum.xda-developers.com/showthread...7955&page=2 .... might help.

Link to comment
Share on other sites

You need HTC sync to connect to PC, rebake with HTC Sync included.

HTC Sync is for using HTC Sync in the computer, it should have nothing to do with plugging the USB and receiving the options to mount the SD card in the connected computer.

Going to try it anyway, but on previous online kitchens I've excluded it and never had problems.

Does anyone else have this issue when plugging by USB?

Thank you.

Link to comment
Share on other sites

HTC Sync is for using HTC Sync in the computer, it should have nothing to do with plugging the USB and receiving the options to mount the SD card in the connected computer.

Going to try it anyway, but on previous online kitchens I've excluded it and never had problems.

Does anyone else have this issue when plugging by USB?

Thank you.

in this kitchen, u need sync included for usb menu.

Link to comment
Share on other sites

HTC Sync is for using HTC Sync in the computer, it should have nothing to do with plugging the USB and receiving the options to mount the SD card in the connected computer.

Going to try it anyway, but on previous online kitchens I've excluded it and never had problems.

Does anyone else have this issue when plugging by USB?

Thank you.

There is a similar issue on the new Villain ROM,.... Go to Settings -> Connection to PC -> Uncheck "Ask".

You wont get the screen asking what to do, but you should be able to pull the nitifications down, then select usb, then mount?

Link to comment
Share on other sites

I'm getting this error with CIME.. Any ideas?

E/dalvikvm(  253): /system/app/HTC_CIME.apk odex has stale dependencies

E/dalvikvm(  253): odex source not available -- failing

W/dalvikvm(  253): threadid=15: thread exiting with uncaught exception (group=0x4001e390)

E/AndroidRuntime(  253): Uncaught handler: thread android.server.ServerThread exiting due to uncaught exception

E/AndroidRuntime(  253): *** EXCEPTION IN SYSTEM PROCESS.  System will crash.

E/AndroidRuntime(  253): dalvik.system.StaleDexCacheError: /system/app/HTC_CIME.apk

E/AndroidRuntime(  253): 	at dalvik.system.DexFile.isDexOptNeeded(Native Method)

E/AndroidRuntime(  253): 	at com.android.server.PackageManagerService.performDexOptLI(PackageManagerService.java:2164)

E/AndroidRuntime(  253): 	at com.android.server.PackageManagerService.scanPackageLI(PackageManagerService.java:2542)

E/AndroidRuntime(  253): 	at com.android.server.PackageManagerService.scanPackageLI(PackageManagerService.java:2098)

E/AndroidRuntime(  253): 	at com.android.server.PackageManagerService.scanDirLI(PackageManagerService.java:1994)

E/AndroidRuntime(  253): 	at com.android.server.PackageManagerService.<init>(PackageManagerService.java:584)

E/AndroidRuntime(  253): 	at com.android.server.PackageManagerService.main(PackageManagerService.java:335)

E/AndroidRuntime(  253): 	at com.android.server.ServerThread.run(SystemServer.java:135)

E/AndroidRuntime(  253): Crash logging skipped, no checkin service

Link to comment
Share on other sites

Hi Paul,

2 issues I've noticed in the v3 WIP release

1 - The minimum level of backlit is somehow limited. You cannot set to real 5% or even switch off. Minimum real backlit level is ~20% even if you set to the lowest in settings. I often read ebooks at night and its hurt my eyes badly. Third party app can lower the lit level for a second but the OS corrigate back immediately.

2 - The backlit of the buttons are never go sleep. It can be really annoying using a browser/ebook reader at night. In the previous OS, the button lights are switched off after few seconds of inactivity.

I've totally wiped before the flash, and reinstalled all applications one by one.

About the battery usage:

The new radio ROM punched out the battery KO within a few hours! So I decided to switch back to the previous radio ROM. (63.18.55.06JU_6.35.09.26)

Now the new ROM with Juicedefender consumed only 4% for 5 hours standby and 15 minutes browsing on 3G. (GPS off)

I hope the lighting issues can be solve fast and I don't have to switch back to the old and slow Android 1.5.

regards:

fred

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.