Jump to content

30/Jun r5 - MoDaCo Custom ROM for GSM Hero now with Online Kitchen - Android 2.1


Guest PaulOBrien
 Share

Recommended Posts

Orange UK Locked. Flashed with baked version including Radios and I've got the Network Locked message.

This was over MCR version 3.2 with a wipe.

Any ideas?

Nevermind!

I went back to the latest Radios listed in the other Radio thread and all seems fine.

Phew!

Link to comment
Share on other sites

constant boot loop here.

performed full wipe. tried the a2sd and a2sd+...same result.

first boot shows the progress bar at the bottom. each loop after that no progress bar displayed. r4 was (is) working perfectly well.

Link to comment
Share on other sites

constant boot loop here.

performed full wipe. tried the a2sd and a2sd+...same result.

first boot shows the progress bar at the bottom. each loop after that no progress bar displayed. r4 was (is) working perfectly well.

When I seleted neither a2sd or a2sd+ I found R5 started working for some reason

Link to comment
Share on other sites

ase.png
Fed up with pushing @ratson's market speedup XML manually, so i've now added ASE and a script to this ROM. :lol:

P

PS Yes, screenshot is from my N1, but, you know... :D
Link to comment
Share on other sites

Hey Paul!

What's the Market speedup XML? Every 2.1 ROM I've tried has had a problem with the market being really slow until I've installed about 20+ apps, then all of a sudden, it starts working normally. It seems to halt at the permissions screen for ages before showing them to me and offering the last Install button...

Is this what the XML file fixes...?

If so, I can't believe this is the first mention I've seen of it - I've searched here and XDA-Devs - perhaps my keyword searching skills aren't as good as they once were... :lol:

Smiffy.

Link to comment
Share on other sites

FWIW, installing r5+APP2SD even after wiping the device caused a boot loop. Logs seemed to indicate that it failed on something in /system/sd/app-private while scanning this directory, so my fix was simply to rename this directory to .old and reboot.

Just FYI.

Thanks a lot for providing this ROM.

TBX

Link to comment
Share on other sites

FWIW, installing r5+APP2SD even after wiping the device caused a boot loop. Logs seemed to indicate that it failed on something in /system/sd/app-private while scanning this directory, so my fix was simply to rename this directory to .old and reboot.

Great, that did the trick! Thanks for the hint!

Link to comment
Share on other sites

@TBX that cracked it! my shell skills were a bit rusty but i got there in the end. thanks a lot man :lol:

Glad I could help -- for the rest of you, do:


[email protected]$ adb -d shell
# mv /system/sd/app-private /system/sd/app-private.old
# reboot
[/codebox]

You could of course 'rm -rf' it too, but you might want to see if your phone boots ok first..

Now, if the guys who made this boot loader (nice work) make the "check filesystems" menu execute 'fsck -fy' when checking ext3 file systems instead of just '-y', we would all be happy. Had to put the memory card into a linux box to get rid of the stale NFS file handle errors (fsck -y /dev/mm... did not work as the file system was marked clean).

TBX

Edited by TBX
Link to comment
Share on other sites

I managed to solve my continuing problems with A2SD roms boot-looping by repairing my ext partition and choosing to upgrade from ext2 to ext3, then wiping the ext partition also. I only mention all the steps because i did them all at once and it worked, though obviously i needed to restore all my applications using titanium backup. So not the order of the partitions causing a problem in my case, but something else. I've since re-installed every application that was running from SD ( including data ), and no problems, so not quite sure exactly what the problem was, but just wanted to post how i'd resolved it :lol:

Oh, using an Orange locked handset, and went for the new WWE radio 63.18.55.06PU_6.35.15.11 ( http://www.mediafire.com/?nif1igt3moz ), linked from XDA ( http://forum.xda-developers.com/showthread.php?t=714075 )

Edited by englishpunk
Link to comment
Share on other sites

Pretty impressed with the new rom :lol:

Anyone else having issues putting it to sleep? Usually I press the call end button and it will lock the screen and got to sleep but it is not doing this now.

Link to comment
Share on other sites

Pretty impressed with the new rom :lol:

Anyone else having issues putting it to sleep? Usually I press the call end button and it will lock the screen and got to sleep but it is not doing this now.

I have seen error messages pertaining to the "gapps" application -- I was unable to make a phone call unless I force closed it ("Wait" did nothing).

TBX

Link to comment
Share on other sites

Pretty impressed with the new rom :lol:

Anyone else having issues putting it to sleep? Usually I press the call end button and it will lock the screen and got to sleep but it is not doing this now.

Found the problem, Spare Parts setting for 'home, then sleep' does nothing so changed it to 'sleep'

Link to comment
Share on other sites

Just get Calculator.apk from MCR3.2 and put in in /system/app

i first deleted 2.1 calculator and than put 1.5 version to /system/app but i can't find it among installed applications. any suggestions?

Link to comment
Share on other sites

Anyone know if this r5 fixes issues with Spotify?

I listen to synced playlists (both local and Spotify files) whilst the phone is in my pocket, asleep, whilst I'm commuting on the London Underground, but find that Spotify seems to stop/pause after a song has ended.

Reaching into my pocket and tapping a button to bring the phone out of sleep seems to trigger the next song to start.

I've also noticed that any network activity, or phone activity (gmail syncing, wifi going out of range, incoming emails or even just the weather widget doing it's 2.1 full screen sense thing) makes the music crackle, stutter, pause and very rarely force close...

Anyone else experiencing this? (I got NONE of the above with MCR 3.2)

Link to comment
Share on other sites

Glad I could help -- for the rest of you, do:


[email protected]$ adb -d shell
# mv /system/sd/app-private /system/sd/app-private.old
# reboot
[/codebox]

I renamed it directly in Nautilus (explorer in Linux) after mounting the SD card on my computer, works as well. Of course Windows users might have problems mounting the EXT3 partition...

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.