Jump to content

Disable startup sound on rooted HTC Tattoo

Guest cheyrou

Recommended Posts

Guest cheyrou


I've rooted my HTC Tattoo for the specific reason of disabling the startup sound. It often reboots at night and the startup sound wakes me up. Rooting has allowed me to use ADB to shell onto the handset and chmod and push/pull files around. I've pushed an edited version of the file:


on to the handset successfully. The .xml looks like this:









image_bg = "/system/media/boot_bg.gif"

useAudio="0" // 1: true ; 0:false



The important bit being the 'useAudio' part being set to 0. However when I reboot the device either manually or using adb reboot the changes appear to be overwritten and the startup sound remains. I've tried several times ensuring that the file is rw for root and even edited the file in ASTRO File Manager to do the same thing. The last modified date for the file has been updated so my changes did take effect - it just appears that some part of the startup process is overwritting the changes made.

Any suggestions about how to proceed with this? It seems like a bad reason to buy a new phone but I can't leave this unresolved.

Link to comment
Share on other sites

Guest EddersC

Is your quote the entire xml file? Mine had various options commented out, so if you're altering a commented out section it won't make any difference.

However, this is probably easier: How about renaming boot.mp3 to boot.mp3.old, or alternatively changing a line in the xml to audio="/system/media/boot_temp.mp3" so that it doesn't point to a real file? This worked for me.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.