Jump to content

[Resolved] Help!! LG Optimus GT540 stuck after failed attempt to update.


Guest Ixirim
 Share

Recommended Posts

Hi, I tried updating my firmware using KP500-Utils-EN. Everything went fine. The phone connects, it checks some stuff and starts to update. However somewhere during the update, it says that it has lost connection to the phone. Told me to unplug the cable, restart the phone and try again. I restart the phone and it's stuck at the LG screen. So right now, the phone can no longer connect to the com. Thus unable to retry.

EDIT 1: Managed to go to Emergency Mode.

EDIT 2: KP500-Utils-EN is asking for some URL after I entered my S/N and IMEI. What URL?

EDIT 3: I thought I'll try and put the .kdz URL. Right now it's saying "#R&D SVCProcessing..."

EDIT 4: Apparently even in Emergency Mode the phone isn't connected to the computer. So now I'm stuck at "Emergency Mode" screen. Oh and under devices, I can see all three drivers. The "LG Android Phone", "LG Android (Modem)" and "LG Android (Serial)".

EDIT 5: All the drivers disappear when I click on "LG Android (Modem)".

Fixed : All right, fixed it. Had to try a few times, but I manage to flash the phone with KDZ_FW_UPD.

Edited by Ixirim
Link to comment
Share on other sites

Hi, I tried updating my firmware using KP500-Utils-EN. Everything went fine. The phone connects, it checks some stuff and starts to update. However somewhere during the update, it says that it has lost connection to the phone. Told me to unplug the cable, restart the phone and try again. I restart the phone and it's stuck at the LG screen. So right now, the phone can no longer connect to the com. Thus unable to retry.

EDIT 1: Managed to go to Emergency Mode.

EDIT 2: KP500-Utils-EN is asking for some URL after I entered my S/N and IMEI. What URL?

EDIT 3: I thought I'll try and put the .kdz URL. Right now it's saying "#R&D SVCProcessing..."

Wait u used kp500 software on gt540, why?!

Link to comment
Share on other sites

Hi, I tried updating my firmware using KP500-Utils-EN. Everything went fine. The phone connects, it checks some stuff and starts to update. However somewhere during the update, it says that it has lost connection to the phone. Told me to unplug the cable, restart the phone and try again. I restart the phone and it's stuck at the LG screen. So right now, the phone can no longer connect to the com. Thus unable to retry.

EDIT 1: Managed to go to Emergency Mode.

EDIT 2: KP500-Utils-EN is asking for some URL after I entered my S/N and IMEI. What URL?

EDIT 3: I thought I'll try and put the .kdz URL. Right now it's saying "#R&D SVCProcessing..."

EDIT 4: Apparently even in Emergency Mode the phone isn't connected to the computer. So now I'm stuck at "Emergency Mode" screen. Oh and under devices, I can see all three drivers. The "LG Android Phone", "LG Android (Modem)" and "LG Android (Serial)".

EDIT 5: All the drivers disappear when I click on "LG Android (Modem)".

Fixed : All right, fixed it. Had to try a few times, but I manage to flash the phone with KDZ_FW_UPD.

how did you managed to flash it? i bricked my phone when i tried to downgrade back from 2.1 to 1.6 and now im stuck in emergency mode...

now, it connects to computer even in emergency mode. but when i start flashing via kdz_fw_upd, the computer loses connection to phone after few seconds and nothing happens...

Link to comment
Share on other sites

how did you managed to flash it? i bricked my phone when i tried to downgrade back from 2.1 to 1.6 and now im stuck in emergency mode...

now, it connects to computer even in emergency mode. but when i start flashing via kdz_fw_upd, the computer loses connection to phone after few seconds and nothing happens...

I also did the same, tried to downgrage back to 1.6 just to see if it was possible, and also got stuck in emergency mode..

I managed to get my phone working again, but only with the 2.1 ROM, not sure if it might not even be possible to go back to 1.6 after upgrading to 2.1, unless someone else has managed to find a way, i certainly havent though..

Here is how to get your phone working again from the problems you are having which are the same as I had.

Power on the phone into emergency mode (VOlume down button + Power button), then connect to the PC USB cable.

Go into device manager on your computer, and under the "modems" section you will see one that says somethin glike "lge android usb modem", right click it and click disable.

Open up KDZ_FW_UPD and re flash to the 2.1 rom (V21b).

Wait for it to finish and it should boot up as normal but into the 2.1 version.

Noto oquite sure why but for some reason if the model isnt disabled in device manager it seems to cause the phone to lose sonnection.

Hope this helps.

Link to comment
Share on other sites

I also did the same, tried to downgrage back to 1.6 just to see if it was possible, and also got stuck in emergency mode..

I managed to get my phone working again, but only with the 2.1 ROM, not sure if it might not even be possible to go back to 1.6 after upgrading to 2.1, unless someone else has managed to find a way, i certainly havent though..

Here is how to get your phone working again from the problems you are having which are the same as I had.

Power on the phone into emergency mode (VOlume down button + Power button), then connect to the PC USB cable.

Go into device manager on your computer, and under the "modems" section you will see one that says somethin glike "lge android usb modem", right click it and click disable.

Open up KDZ_FW_UPD and re flash to the 2.1 rom (V21b).

Wait for it to finish and it should boot up as normal but into the 2.1 version.

Noto oquite sure why but for some reason if the model isnt disabled in device manager it seems to cause the phone to lose sonnection.

Hope this helps.

VOlume down button + Power button gives me download mode, but my phone keeps saying it is not connected.

anything else? it is also not recognized by KDZ. it can not find it. :lol:

Link to comment
Share on other sites

I also did the same, tried to downgrage back to 1.6 just to see if it was possible, and also got stuck in emergency mode..

I managed to get my phone working again, but only with the 2.1 ROM, not sure if it might not even be possible to go back to 1.6 after upgrading to 2.1, unless someone else has managed to find a way, i certainly havent though..

Here is how to get your phone working again from the problems you are having which are the same as I had.

Power on the phone into emergency mode (VOlume down button + Power button), then connect to the PC USB cable.

Go into device manager on your computer, and under the "modems" section you will see one that says somethin glike "lge android usb modem", right click it and click disable.

Open up KDZ_FW_UPD and re flash to the 2.1 rom (V21b).

Wait for it to finish and it should boot up as normal but into the 2.1 version.

Noto oquite sure why but for some reason if the model isnt disabled in device manager it seems to cause the phone to lose sonnection.

Hope this helps.

thank you very much, this worked for me :lol: B)

Link to comment
Share on other sites

VOlume down button + Power button gives me download mode, but my phone keeps saying it is not connected.

anything else? it is also not recognized by KDZ. it can not find it. :lol:

somehow it picked up the phone now! but it keeps on sayding model dll msg not found.

ANYONE?!!!!!!!!!!!!!!

Link to comment
Share on other sites

Why would you want to go back? It's almost the same, with more app compatibility and Live Wallpapers.

for one, to see if it's possible.

for another, perhaps a dire need for root access.

Link to comment
Share on other sites

  • 1 month later...
I also did the same, tried to downgrage back to 1.6 just to see if it was possible, and also got stuck in emergency mode..

I managed to get my phone working again, but only with the 2.1 ROM, not sure if it might not even be possible to go back to 1.6 after upgrading to 2.1, unless someone else has managed to find a way, i certainly havent though..

Here is how to get your phone working again from the problems you are having which are the same as I had.

Power on the phone into emergency mode (VOlume down button + Power button), then connect to the PC USB cable.

Go into device manager on your computer, and under the "modems" section you will see one that says somethin glike "lge android usb modem", right click it and click disable.

Open up KDZ_FW_UPD and re flash to the 2.1 rom (V21b).

Wait for it to finish and it should boot up as normal but into the 2.1 version.

Noto oquite sure why but for some reason if the model isnt disabled in device manager it seems to cause the phone to lose sonnection.

Hope this helps.

you sir are THE MAN!!!, I had a bricked phone because i too tried the 2.1 to 1.6 downgrade and bricked my phone!, Now Its running nicely.. and its not going to lg at my expense either!

Kudo's to you, thanks soo much!

Link to comment
Share on other sites

  • 3 weeks later...
I also did the same, tried to downgrage back to 1.6 just to see if it was possible, and also got stuck in emergency mode..

I managed to get my phone working again, but only with the 2.1 ROM, not sure if it might not even be possible to go back to 1.6 after upgrading to 2.1, unless someone else has managed to find a way, i certainly havent though..

Here is how to get your phone working again from the problems you are having which are the same as I had.

Power on the phone into emergency mode (VOlume down button + Power button), then connect to the PC USB cable.

Go into device manager on your computer, and under the "modems" section you will see one that says somethin glike "lge android usb modem", right click it and click disable.

Open up KDZ_FW_UPD and re flash to the 2.1 rom (V21b).

Wait for it to finish and it should boot up as normal but into the 2.1 version.

Noto oquite sure why but for some reason if the model isnt disabled in device manager it seems to cause the phone to lose sonnection.

Hope this helps.

seems to have worked for me, still observing my phone after a bad flash. thanks for this, this is awesome.

Link to comment
Share on other sites

Hi i have bricked my lg i was on 2.1 and i found a 2.2 i tryied to get on 2.2 and it bricked my phone turns on loads lg screen only then freezes i can load download mode but KDZ_FW_UPD comes on i have windows enabler on i turn android modem off but KDZ_FW_UPD won't let me do anything were cdma is i click that to change but not letting me also nothing works on it not even to find .KDZ file but im using windows 7 would i have to use xp

Link to comment
Share on other sites

Hi, I tried updating my firmware using KP500-Utils-EN. Everything went fine. The phone connects, it checks some stuff and starts to update. However somewhere during the update, it says that it has lost connection to the phone. Told me to unplug the cable, restart the phone and try again. I restart the phone and it's stuck at the LG screen. So right now, the phone can no longer connect to the com. Thus unable to retry.

EDIT 1: Managed to go to Emergency Mode.

EDIT 2: KP500-Utils-EN is asking for some URL after I entered my S/N and IMEI. What URL?

EDIT 3: I thought I'll try and put the .kdz URL. Right now it's saying "#R&D SVCProcessing..."

EDIT 4: Apparently even in Emergency Mode the phone isn't connected to the computer. So now I'm stuck at "Emergency Mode" screen. Oh and under devices, I can see all three drivers. The "LG Android Phone", "LG Android (Modem)" and "LG Android (Serial)".

EDIT 5: All the drivers disappear when I click on "LG Android (Modem)".

Fixed : All right, fixed it. Had to try a few times, but I manage to flash the phone with KDZ_FW_UPD.

you'r very lucky i tried reflashing KDZ file and now my phone won't turn on :P

Link to comment
Share on other sites

you'r very lucky i tried reflashing KDZ file and now my phone won't turn on :P

I have a LG Optimus t p509 that I also messed up the emergency mode / emergency flash. My phone will not power on at all even to get to emergency mode, just dead. 99% sure it's bricked without any special JTAG'ing or something. Shot in the dark but any POSSIBLE solutions?

Link to comment
Share on other sites

I have a LG Optimus t p509 that I also messed up the emergency mode / emergency flash. My phone will not power on at all even to get to emergency mode, just dead. 99% sure it's bricked without any special JTAG'ing or something. Shot in the dark but any POSSIBLE solutions?

I think it's time for you to visit LG Customer Service Center. I had the same problem. But I thought let the experts handle it instead of I messing it up. :P :P ;)

Link to comment
Share on other sites

I think it's time for you to visit LG Customer Service Center. I had the same problem. But I thought let the experts handle it instead of I messing it up. :P :P ;)

Tejas please PM me so that i can help both of you out.

You dont need to contact Customer Service i have found a working solutions for this.

Edited by Alexxx18
Link to comment
Share on other sites

Hi,

I was try and follow these steps. I bricked the lg gt540. I am desperate, don't know what to do. Here is the log file when i try to reflash it again. I made a mistake when i was downgrading from 2.1 (20A) to 1.6 (10c)

[R&D Test Tools Log File]

12:28:33 : Launching SW update

12:28:33 : Unpacking KDZ

12:28:36 : KDZ file extraced

12:28:38 : Files were extracted.

12:28:38 : LGMobileDL Load.

12:28:38 : Port = -1

12:28:38 : Connecting to phone

12:28:48 : Check Phone mode = 1

12:29:07 : Phone type check.......

12:29:11 : LGMobileDL.DLL Loading....

12:29:11 : _SetAuthMark Fail

12:29:11 : AuthMark°ˇ Á¤Č®Č÷ Phoneżˇ Write µÇÁö ľĘľŇ˝Ŕ´Ď´Ů!

12:29:11 : _SetAuthMark Fail

12:29:11 : LoadCDMAPhoneData() Error

12:29:11 : _DetachDLL Call

12:29:11 : _DetachDLL Call End

12:29:11 : Param : Path = C:\ProgramData\LGMOBILEAX\Phone\DZ_GT540AT-00-V20b-BAL-XXX-SEP-13-2010.dz

12:29:11 : Param : moduleDir =

12:29:11 : Param : waitTime = 0

12:29:11 : Param : UsbHighSpeed = 1

12:29:11 : Param : PhoneMode = 1

12:29:11 : Param : BinVersion = V20B_00

12:29:11 : Param : AuthMark = 0

12:29:11 : Call fn_StartUpgrade

12:29:21 : Smart : wParam = 3, lParam = 0

12:29:21 : Smart : wParam = 205, lParam = 0

Link to comment
Share on other sites

My phone is stuck on the android logo and i did everything. Open windows enable. Open KDZ. Select KDZ file. Disable android modem. Flash it. After the phone restarts by it self it still stuck at the android logo. This is getting me on my nerves.

Link to comment
Share on other sites

Hi,

I was try and follow these steps. I bricked the lg gt540. I am desperate, don't know what to do. Here is the log file when i try to reflash it again. I made a mistake when i was downgrading from 2.1 (20A) to 1.6 (10c)

[R&D Test Tools Log File]

12:28:33 : Launching SW update

12:28:33 : Unpacking KDZ

12:28:36 : KDZ file extraced

12:28:38 : Files were extracted.

12:28:38 : LGMobileDL Load.

12:28:38 : Port = -1

12:28:38 : Connecting to phone

12:28:48 : Check Phone mode = 1

12:29:07 : Phone type check.......

12:29:11 : LGMobileDL.DLL Loading....

12:29:11 : _SetAuthMark Fail

12:29:11 : AuthMark°ˇ Á¤Č®Č÷ Phoneżˇ Write µÇÁö ľĘľŇ˝Ŕ´Ď´Ů!

12:29:11 : _SetAuthMark Fail

12:29:11 : LoadCDMAPhoneData() Error

12:29:11 : _DetachDLL Call

12:29:11 : _DetachDLL Call End

12:29:11 : Param : Path = C:\ProgramData\LGMOBILEAX\Phone\DZ_GT540AT-00-V20b-BAL-XXX-SEP-13-2010.dz

12:29:11 : Param : moduleDir =

12:29:11 : Param : waitTime = 0

12:29:11 : Param : UsbHighSpeed = 1

12:29:11 : Param : PhoneMode = 1

12:29:11 : Param : BinVersion = V20B_00

12:29:11 : Param : AuthMark = 0

12:29:11 : Call fn_StartUpgrade

12:29:21 : Smart : wParam = 3, lParam = 0

12:29:21 : Smart : wParam = 205, lParam = 0

Wait.. "C:\ProgramData\LGMOBILEAX\Phone\DZ_GT540AT-00-V20b-BAL-XXX-SEP-13-2010.dz" ? Shouldn't it be a .kdz file?

Link to comment
Share on other sites

My phone is stuck on the android logo and i did everything. Open windows enable. Open KDZ. Select KDZ file. Disable android modem. Flash it. After the phone restarts by it self it still stuck at the android logo. This is getting me on my nerves.

Try in this order.

  1. Open windows enabler.
  2. Turn ON windows enabler
  3. Connect phone to PC
  4. Disable android modem
  5. Open KDZ_FW_UPD
  6. Select KDZ file
  7. Flash the phone.

Oh and maybe putting both KDZ_FW_UPD and the .kdz file in C:/ might help.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.