Jump to content

Downgrading from Froyo OTA

Guest PaulOBrien

Recommended Posts

Hi guys, I need a big help.

I followed the procedure to downgrade the Htc Legend from Froyo, unfortunately while i was in windows's terminal and I typed crackin.bat the terminal replied me c---rw---- 1 1001 2002 90, 0 jul 19 16:19 /dev/mtd/mtd0

I tried to restart my device or to clearing the phone to factory settings but my device now doesnt' get a signal.

Did i brick my device? :lol:

How i can solve this situation?

Thanks in advacnce

Edited by abrhp
Link to comment
Share on other sites

  • 3 weeks later...
Greet tutorial~~~Work perfectly for me!! Thanks You

My Legend Hast Updated to Asia 2.2 and come with HBOOT 1.001...I has successful downgrade using 1.31 RUU..

Surprising is when i downgrade to 1.31 there HBOOT still remain at 1.001

Now i become 1.001 with ROOT :P :D :huh:

Hallo brother

Can you tell me...tutorial..step by step..... has successful downgrade your Legend..cause I new on android :P

I hope u can tell it


Link to comment
Share on other sites

  • 2 weeks later...
Guest raushan
Thanks to Paul with this tutorial i´ve solved the HBOOT problem that unable install Froyo rooted for me.

This is a HOW TO that i´ve made for help all people who has this problem.


In spanish and english.


the site is in spanish how to get the english version...... plzzz help

Link to comment
Share on other sites

Guest JoePhanDro
For some reason it isnt working for me when I enter this in CMD:

Microsoft Windows [versie 6.0.6002]

Copyright © 2006 Microsoft Corporation. Alle rechten voorbehouden.

C:\Users\Gebruiker>cd c:\AndroidSDK\tools\

c:\AndroidSDK\tools>adb shell

$ su


su: permission denied

$ su



What Am I doing wrong? I am not getting any messages on my device:S

Help me please!

Thanks in Advance


Edit:Yeah! I downgraded and rooted it! Thanks very much Paul! Gl with ur other tuts.


i have the same Problem Like Tomm3rd. Can someone help me?


Link to comment
Share on other sites

  • 3 months later...
Guest protum

Thank You, Paul!

I successfully downgraded my legend to 1.31

To the others, if you have hard 2.2 and soft 3.5, and you can not install visionary r13, try to install r14

from here

Link to comment
Share on other sites

  • 4 weeks later...
  • 3 months later...

If (like me) you got flashed the Legend Froyo OTA and now you can't downgrade, you can do the following..

- Follow this guide to the end (the last stage will appear to have failed)

- Temproot with VISIONary r13 (install the downloaded file as per a normal APK)

- Once you are temprooted, connect via 'adb' and do 'su' (to get root) then '/data/local/flash_image misc /data/local/misc1-2.img'

You should then be able to downgrade in the normal way.

You try this at your own risk... I successfully did this on my device, but of course YMMV. :rolleyes:


Paul, used the visionary+ method above, many many thanks for the guide

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.