Jump to content

Basic CM61-Pulse0.40 ROM installation with modifications


Guest twrock

Recommended Posts

  • Replies 517
  • Created
  • Last Reply

Popular Posts

Note: (2011 12 10) This rom has been superseded by the new TXG rom. TXG has all the benefits of this rom and more. It is easier to install (there is only one installation file). I do not intend to

For people who are new to installing custom roms, here are some ideas to help you get started. The first boot is always slow and prone to what seems like hangups and hiccups. Don't worry about i

Welcome to the party. Looks like you are a quick learner. :) Roms are a matter of taste. Each has advantages and disadvantages. Some are still very much in an "early beta" form, and you only will w

Posted Images

Guest Fulcrum_X

You're absolutely right twrock!

I really thought I followed every single step, but somehow I missed the "format" actions in the partitions menu of Clockwork. I always did whipe data/factory reset and whipe cache. Also in the previous installs I never did this... probably the reason why i had lots of troubles with not receiving text messages. Thanks for your help :P

Edited by Fulcrum_X
Link to post
Share on other sites
You're absolutely right twrock!

I really thought I followed every single step, but somehow I missed the "format" actions in the partitions menu of Clockwork. I always did whipe data/factory reset and whipe cache. Also in the previous installs I never did this... probably the reason why i had lots of troubles with not receiving text messages. Thanks for your help :P

I'm glad you found the problem, and I really think it will work this time.

It's too complicated to explain here "why" that step is necessary. It has to do with the original CM update scripts, but at the moment I'm not interested in taking the time to edit those (and possibly really mess something up in there as well). So I tell people that they "must" format /system. Actually, it's not always necessary for everyone. But since I can't possibly know what everyone is starting with as their previously installed rom, the safest thing for me to do is to tell you that you must do it.

And yes, I personally think a lot more nagging problems would go away if /system got formatted every time someone installs a rom. But there is a reason it's not in the CM rom, and there is a history behind it as well.

Link to post
Share on other sites
Thank you! Great job! Its pretty stable and fast. One thing that bothers me is GPS icon when its off... Is there any chanse of being fixed?

Sorry, but you've got me there. I had no idea that there was a problem. I guess it's like the rotation bug that I don't have either. I just don't seem to have these problems, so I don't know what to even start looking for. :P Maybe someone else can shed some light on this.

Is it reproducible? (Not that I want to have the problem, but it's hard to know what people are talking about when you don't see it yourself.)

Link to post
Share on other sites
Guest Fusion0306
Sorry, but you've got me there. I had no idea that there was a problem. I guess it's like the rotation bug that I don't have either. I just don't seem to have these problems, so I don't know what to even start looking for. :P Maybe someone else can shed some light on this.

Is it reproducible? (Not that I want to have the problem, but it's hard to know what people are talking about when you don't see it yourself.)

I have the gps icon problem too.

Reproduction: enable gps, open maps, press my location, wait for maps to pinpoint the location, exit maps, disable gps. the icon just stays in the notification bar and I have to reboot to make the icon disappear

EDIT: But that was a problem with every CM port, just like stuck rotation, so you're not to blame :D

Edited by Fusion0306
Link to post
Share on other sites
Guest jimmie32

Not reproducible over here. Tried it many times, haven't found any abnormality with the GPS functions, icons or other things.

Perhaps a reinstall would fix that problem? Its weird, but sometimes flashing the ROM once again after formatting System and wiping data seems to fix a lot of problems for me. Like I couldn't get the Market working, or locked orientation, etc.

Edit: Confirmed, Reproducible on my version too after a couple of reboots and tries. It doesn't bother me, haven't noticed it too much before, and it's only reproducible in very rare situations for me. Oh well. There isn't a perfect software that has no bugs, though :P

U8220 256MiB RAM version here. :D

Edited by jimmie32
Link to post
Share on other sites
Guest Fusion0306
Not reproducible over here. Tried it many times, haven't found any abnormality with the GPS functions, icons or other things.

Perhaps a reinstall would fix that problem? Its weird, but sometimes flashing the ROM once again after formatting System and wiping data seems to fix a lot of problems for me. Like I couldn't get the Market working, or locked orientation, etc.

Edit: Confirmed, Reproducible on my version too after a couple of reboots and tries. It doesn't bother me, haven't noticed it too much before, and it's only reproducible in very rare situations for me. Oh well. There isn't a perfect software that has no bugs, though :P

U8220 256MiB RAM version here. :D

I always format the system (and all other partitions) when I flash new roms, so that can't be the problem.

Link to post
Share on other sites
Guest jimmie32

As an unrelated note, is the SMS Routing Problem present in any of your installs? I don't have this problem and I hope it won't happen for me, but I just want to be safe. I was going through my bookmarks today and found that, didn't have an Android before that so didn't bother to read in depth, but apparently 2.2.1 is affected.

Probably patch it or something, if possible? Just want to be safe. Can anyone confirm that this is not present or this is present and (rarely/whatever) reproducible? Please? Thanks.

Just being paranoid. I'd hate if my SMSs get routed to the wrong person.

Reading for those who haven't known about that: From the Official Code.Google/Android Tracker, Engadget.

Thanks!

Link to post
Share on other sites
change value on line ro.opengles.version=65536 to 65537 in build.prop

then goto reboot in recovery then flash the file below

(dont know if peoples build.prop file is different for each phone or if it can be flashed so never added to this zip (someone else made))

this rom seems fine, added SetCPU at maxed and got 28 on neocore and 430+ on Quadrant just changed the launcher to launcher pro becauase default one was messing up my dock bar was just disapearing all the time :S

Well, the results after the build.prop edit and file install were that my Neocore score dropped from 26.7 to 26.4. :P

If the score is at all affected by CPU speed, then that would explain my score both times being lower than yours, because I am only running at 576mhz. But I have no explanation why my score dropped slightly after installing the updated opengles. Any ideas?

Link to post
Share on other sites
I have the gps icon problem too.

Reproduction: enable gps, open maps, press my location, wait for maps to pinpoint the location, exit maps, disable gps. the icon just stays in the notification bar and I have to reboot to make the icon disappear

EDIT: But that was a problem with every CM port, just like stuck rotation, so you're not to blame :D

Whew, that's nice to know. And if smart people like Tom and the rest haven't been able to fix it, you can be sure I can't either. :P

Link to post
Share on other sites
Guest Boony123
Well, the results after the build.prop edit and file install were that my Neocore score dropped from 26.7 to 26.4. :P

If the score is at all affected by CPU speed, then that would explain my score both times being lower than yours, because I am only running at 576mhz. But I have no explanation why my score dropped slightly after installing the updated opengles. Any ideas?

dont know i why it would drop, I just ran it at 576 and got 23.4 lol same settings are you but vm size might be different. not messed much but the opengl is backwards compatable but it is a bigger size so maybe because the whole file gets processed? takes a little bit longer so a tiny frame loss? dont know really :D

my first test was ran at 691 and right after the flash of your rom.

Edited by Boony123
Link to post
Share on other sites
Guest Redparrot

twrock, thanks very much for this. I'd given up using my pulse because of all the FCs.

I followed your instructions to the letter and now I have a pulse that has never worked better!

Thanks, again.

Link to post
Share on other sites
Guest motherfucking_host

hi how difficult is it to remove all the useless programm like facebook, twitter, gmail, ... from the rom by myself? or by you :-) i think if someone want´s to use them they are all in the market.

thx

Link to post
Share on other sites
Guest jordanclarke69

hi twrock and all,

i know this thread is old, but it's the guide that first got me to install a custom rom so thought i'd post here.

i've downgraded to the 1.5 dec update, because by usb charger point's broke off and i'm gonna take it back to the store under warantee (though i'm not sure how sucessful i'll be as loads of people seem to have problems getting it fixed for free).

but when i eventually get it back, will i be able to go straight for the cyanogen mod as i already have made the SDcard partition??

or will i need to go official 2.1 first, the custom??

thanks!

Link to post
Share on other sites
hi how difficult is it to remove all the useless programm like facebook, twitter, gmail, ... from the rom by myself? or by you :-) i think if someone want´s to use them they are all in the market.

thx

I won't delete them for you. Many, if not most people want them. You are of course very welcome to do whatever to the rom you want to before you install it. Delete to your hearts content.

But it seems you don't understand the difference between what is installed in /system and what is installed in /data. You can easily delete what is installed in /data all by yourself after you install the rom. Just delete those apps like every other app you might have installed yourself from the Market. They show up in the Settings/Applications/Manage applications menu and can be deleted there. Facebook, Twitter, Filemanager, Maps, Google Voice, and ROM Manager are all in /data. (There might be others, but I don't remember.) Gmail, and the rest of the "standard" Google apps are installed into /system, but only if you install the gapps.zip as part of the total install. Think it through, and I believe you can figure out how not to install those apps. :P

But then again, you need to remember that installing apps from the Market uses up /data space. If you are using apps2sd and cachesd, that's not a big deal. If you aren't, /data space is at a premium. So you want to have the more "standard" apps installed in /system and not waste the space there.

So maybe you can start to understand that there are a lot of factors to consider when someone like me tries to modify a rom. Every decision has both positive and negative results. And everyone's got an opinion about what those should be. And the cool thing about it all is that every one of us can pretty much do whatever we want. :D

The only way you are ever going to get exactly the rom you want is to build it yourself.

Link to post
Share on other sites
hi twrock and all,

i know this thread is old, but it's the guide that first got me to install a custom rom so thought i'd post here.

i've downgraded to the 1.5 dec update, because by usb charger point's broke off and i'm gonna take it back to the store under warantee (though i'm not sure how sucessful i'll be as loads of people seem to have problems getting it fixed for free).

but when i eventually get it back, will i be able to go straight for the cyanogen mod as i already have made the SDcard partition??

or will i need to go official 2.1 first, the custom??

thanks!

This isn't the "old thread"; it's that other one. This one is very up-to-date. :P

You will need to install the official UK 2.1 update before you install this rom. That will give you the correct size partitions in rom, something 1.5 does not have. The SD card partitions are for getting Apps2SD and swap working, but do not help you with installing the CM ROM.

Link to post
Share on other sites
Guest Alcarne

Thanks for this rom, it has made the pulse good again.

Only thing I've found is the market is still the old version and it won't update. All the links to the new version are broken in other threads. Also I can't install flash player 10.1. It's not in the market. I've tried all the market fixes to no avail. It was available in CM6 v0.4 posted by TomG. I've tried finding the apk online and installing manually but this seemed to screw up the whole installation.

Link to post
Share on other sites
Guest Fusion0306
Thanks for this rom, it has made the pulse good again.

Only thing I've found is the market is still the old version and it won't update. All the links to the new version are broken in other threads. Also I can't install flash player 10.1. It's not in the market. I've tried all the market fixes to no avail. It was available in CM6 v0.4 posted by TomG. I've tried finding the apk online and installing manually but this seemed to screw up the whole installation.

I kinda like the old market better :P

Link to post
Share on other sites
Thanks for this rom, it has made the pulse good again.

Only thing I've found is the market is still the old version and it won't update. All the links to the new version are broken in other threads. Also I can't install flash player 10.1. It's not in the market. I've tried all the market fixes to no avail. It was available in CM6 v0.4 posted by TomG. I've tried finding the apk online and installing manually but this seemed to screw up the whole installation.

Ah, yet another thing I don't know about. I haven't paid any attention to whether or not there is a new Market app. I'll keep it in mind (unless I forget), and look into why it hasn't updated on its own, or consider putting the update into a future release. But no guarantees from me. I usually only get things done by being lucky. :P

Link to post
Share on other sites
Guest Boony123
Thanks for this rom, it has made the pulse good again.

Only thing I've found is the market is still the old version and it won't update. All the links to the new version are broken in other threads. Also I can't install flash player 10.1. It's not in the market. I've tried all the market fixes to no avail. It was available in CM6 v0.4 posted by TomG. I've tried finding the apk online and installing manually but this seemed to screw up the whole installation.

flash dont work on the pulse right at all bacause of the cpu ? arm6 not 7 or something like that. also flash lite wont work because of its not a HTC phone.

I had the new market for about 5 min before i flashed with aio v5 from lol any where to get a working apk file? if not i could restore my old back up and grab the files for us pluse users :P

Edited by Boony123
Link to post
Share on other sites

Hi all,

I like this rom very much, and it is working fine, but I have problem with dialer.

I miss the row ( number 8 on picture) so i can only enter numbers, but it is not searching in phonebook.

Can it be enabled somehow?

Thanks,

Pepe

post-836947-1297345735_thumb.jpg

Link to post
Share on other sites
Guest TaiwanCHT8k

Here's the IDEOS firmware I mentioned last time

I extracted everything out of it and de-odexed all the apps

but...thanks to the Big MAC, I'm still using froyo

http://www.mediafire.com/file/r3eiqn391vv1...OS2.2_TW.tar.gz

It's QVGA so most of the apps contain ldpi image set only

there shouldn't be a display problem except some icons would be a little bit blurry

..might consume less ram I guess

ro.build.description=U8150-user 2.2 FRF91 eng.huawei.20100903.194753 release-keys

ro.build.display.id=U8150V100R001C197B821SP03

Android_FET.apk>>>>>what's this?

HWCalla_TaiWan.apk>>don't know if there's any difference...new ver. maybe?

Link to post
Share on other sites
Guest CarpetDiem
Hi all,

I like this rom very much, and it is working fine, but I have problem with dialer.

I miss the row ( number 8 on picture) so i can only enter numbers, but it is not searching in phonebook.

Can it be enabled somehow?

Thanks,

Pepe

post-836947-1297345735_thumb.jpg

I miss it too.Can anyone help us poor?

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.