Jump to content

Sleep Of Death - Your Setup


Guest
 Share

Recommended Posts

i use everthing exept the cpu libs mentioned. running for 39hours now without SOD.

(probably i'll get one in 5mins :D )

For me only way to avoid SOD is SetCpu and setting min to 266MHz...tried 133, it works for a while, but after some time issue came back.

Link to comment
Share on other sites

For me only way to avoid SOD is SetCpu and setting min to 266MHz...tried 133, it works for a while, but after some time issue came back.

SetCPU is not needed. Just use mount.sh from kgp700.

Link to comment
Share on other sites

Just take mount.sh from kgp700 package and rename to o2b2update.sh and put on Mystorage. It worked. :D

PS: Its on neok_om2android_beta2_ver2_9r1.zip>ext2.tar>ext2>system>etc >>>mount.sh

Edited by slmz
Link to comment
Share on other sites

Just take mount.sh from kgp700 package and rename to o2b2update.sh and put on Mystorage. It worked. :D

PS: Its on neok_om2android_beta2_ver2_9r1.zip>ext2.tar>ext2>system>etc >>>mount.sh

Can you tell me where I can find that package? (neok_om2android_beta2_ver2_9r1.zip)

Does it really help with SOD problem? no more SOD? :(

Link to comment
Share on other sites

Can you tell me where I can find that package? (neok_om2android_beta2_ver2_9r1.zip)

Does it really help with SOD problem? no more SOD? :D

Here

Im justing testing, untill now no sod and no freeze.

Link to comment
Share on other sites

Just take mount.sh from kgp700 package and rename to o2b2update.sh and put on Mystorage. It worked. :D

PS: Its on neok_om2android_beta2_ver2_9r1.zip>ext2.tar>ext2>system>etc >>>mount.sh

If only rename it to o2b2update.sh it will work... but only once, because then this file is deleted. It should be replaced in /system/etc/

Link to comment
Share on other sites

If only rename it to o2b2update.sh it will work... but only once, because then this file is deleted. It should be replaced in /system/etc/

Ok! Thanks. We so must put mount.sh in folder named "etc" and put this into other named "system" and tar it to o2b2update.tar and after all compress it to o2b2update.tar.gz. dragging it to Mystorage.

Link to comment
Share on other sites

so anyone sharing o2b2update file they made?

as for sleep of death voytechst seems to be right about the cpu driver. i have lots of issues with it.

i also think the min proc speed has something to do with it.

3d drivers is possible to

task killer not sure as it doesnt seem to bother it

Link to comment
Share on other sites

Hi all,

first post among Omnia2droid...

i tested the beta1, beta2, different updates, for about a month now...

I found out that widgets can be couse of SOD in beta2, mostly clock+weather widgets.

I was having a very stable beta2 (no 3/3 update), after i istalled some progs from market i was starting to have random SOD, some freezes

Now I removed all widgets from home. My droid is SOD free... for days now... Later I dicovered that the clock widget was the problematic one, maybe related to weather and other refresh from 3G.

I tried beta2+3/3update, for me is a step back in terms of stability... i get random freezes, I think is sensors related, sensors are still a mess, magnetic compas is having a +-15° error (thats 30°!), level sensor working but not as responsive as is should be, but games are playable, google sky sensormotion is not smooth at all... I'm stuck with no 3/3 update for now.

Setup:

-beta2

-My Storage / EXT3 / 1024MB

-Stu's 2d3d drivers (3D ~ 100)

-CPUlibs 1.3 (linpack ~ 8 Mflops)

Battery drain isn't so good (1h-->5-8% in sleep mode)

CSC: I8000NXXIL2

WIMO: 6.5.5. (some old lite (GM) rom)

devs: good work, you rock!

Link to comment
Share on other sites

I've detected three main causes of SOD:

- newest cpu libs (these from beta 2 are ok)

- advanced task killer

- stu2k 2d/3d drivers - BUT they are ok if You will copy ONLY following files (format: size file_name):

@ voyteckst

Can you post an O2b2update with only necessary lib?

thanks

My Setup is:

- beta2

- MyStorage / EXT4 / 1024MB

- update_20110303

- stu's 2d/3d drivers

Link to comment
Share on other sites

I've detected three main causes of SOD:

- newest cpu libs (these from beta 2 are ok)

- advanced task killer

- stu2k 2d/3d drivers - BUT they are ok if You will copy ONLY following files (format: size file_name):

system/lib:  

36108 libEGL.so

21424 libGLESv1_CM.so

17328 libGLESv2.so

17544 libs3c2drender.so

170856 libsurfaceflinger.so


system/lib/egl:  

21 egl.cfg

21752 libChunkAlloc.so

76972 libEGL_fimg.so

114092 libGLES_android.so

3520112 libGLESv1_CM_fimg.so

2433848 libGLESv2_fimg.so


system/lib/hw:  

5280 copybit.GT-I5700.so

14060 gralloc.GT-I5700.so

as far as i see, i only needed to remove the libdvm. tried that but then the phone doesn't boot with the latest updates, get something about processes ending that are not tracked and also error loading libandroid_servers.

Link to comment
Share on other sites

as far as i see, i only needed to remove the libdvm. tried that but then the phone doesn't boot with the latest updates, get something about processes ending that are not tracked and also error loading libandroid_servers.

You need reinstall from scratch, cause drives were already in use on library.

Link to comment
Share on other sites

You need reinstall from scratch, cause drives were already in use on library.

It was a reinstall from scratch, I use a shell script in Ubuntu applying all patches (with exception of the sensors symlink which is done upon first boot).

Link to comment
Share on other sites

It was a reinstall from scratch, I use a shell script in Ubuntu applying all patches (with exception of the sensors symlink which is done upon first boot).

If you use mystorage try this pack: lastupdatepack

Edited by slmz
Link to comment
Share on other sites

I'm desperate with SOD. I've tried every configuration, every pack, every "trick", every library but SOD are still bugging me.

The most common SOD I suffer take place when I turn on the mobile in the morning (fully charged) and I execute Haret after WM is completely loaded. I use Android for a while and keep it in my bag to start working.... but after 2 hours (my first "time-out") I always find the mobile hanged up in SOD and the battery almost drained.

The battery consumption while SOD is awesome ¡¡¡¡ The battery is fully discharged from 100% to 0% in only 3 hours of SOD.

Meanwhile SOD don't be solved Android is completely unusable. I can't afford to run out of my battery when I'm in a journey because of SOD. Consequences will be disastrous.

Bye.

Link to comment
Share on other sites

I'm desperate with SOD. I've tried every configuration, every pack, every "trick", every library but SOD are still bugging me.

The most common SOD I suffer take place when I turn on the mobile in the morning (fully charged) and I execute Haret after WM is completely loaded. I use Android for a while and keep it in my bag to start working.... but after 2 hours (my first "time-out") I always find the mobile hanged up in SOD and the battery almost drained.

The battery consumption while SOD is awesome ¡¡¡¡ The battery is fully discharged from 100% to 0% in only 3 hours of SOD.

Meanwhile SOD don't be solved Android is completely unusable. I can't afford to run out of my battery when I'm in a journey because of SOD. Consequences will be disastrous.

Bye.

Have you tested dont enable wifi after android run after boot? It can be the cause, wifi dont going off properly.

Link to comment
Share on other sites

Have you tested dont enable wifi after android run after boot? It can be the cause, wifi dont going off properly.

I don't enable anything at all, neither 3G. After this first SOD of the day I boot in WM, recharge the phone, boot Android again and it works fine to the end of the day. No more SOD.

So it's quite clear that SOD is related in any way to the "power status", in fact while the phone is plugged to the power supply I don't expect any SOD. It's delirious ¡ :D

Bye.

Edited by lotuxete
Link to comment
Share on other sites

If you use mystorage try this pack: lastupdatepack

thanks a lot for that. diff-ing to my setup, it seems the critical part are the 3d drivers. just one thing - your package does not include the Feb 10 update that fixes the 3G DNS issue, which prevented the use of 3G at all. maybe let users know about that or have it included.

now my phone seems quite fast and stable :D

Link to comment
Share on other sites

thanks a lot for that. diff-ing to my setup, it seems the critical part are the 3d drivers. just one thing - your package does not include the Feb 10 update that fixes the 3G DNS issue, which prevented the use of 3G at all. maybe let users know about that or have it included.

now my phone seems quite fast and stable :D

The Feb 10 update is not included, cause it is a particular stand alone update, I dont use it, but if somebody wish that, just put in my storage and run Haret. :D

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.