Jump to content

[BETA] AUDI - Automated USB Driver Installer

Guest simonta

Recommended Posts

  • 1 month later...
  • 3 years later...
  • 1 year later...
Guest karlos68
On 4/17/2011 at 10:45 PM, Paris2011 said:





On 4/19/2011 at 7:47 PM, Fusion1296 said:
simonta said:
Hi folks. After spending many, many hours helping people to get their drivers installed, I've decided to try a different approach.


So here is version 0.2 of the AUDI, automatic USB driver installer. For now, this is for Vista and Windows 7 only. I am working on XP which has some significant challenges to overcome to fully automate things.


[CAUTION] I have tested this on Windows 7 32 bit only. It should work just fine on Vista and Win 7 64 bit but, to cover everyones' butt, I've included a system restore point feature. It doesn't do anything except monkey around with plug and play drivers but just to be safe, I recommend that folks create a restore point the first time you use it [/CAUTION]



Download from my Dropbox and unzip. http://dl.dropbox.com/u/10375731/audi.zip


Run the tool by right clicking and selecting "Run as administrator".


The first time you run it, it will ask for permission to download some files from Microsoft. You should say "Yes".


Using the tool


There are 2 things you need drivers for. Installing the Advent "stock" ROM from MyAdventVega and installing the Modaco Custom ROM from here (or any other install that says you need the "ADB" drivers). Make sure you know which one you need!


In Step 1, select what you are trying to do. Step 2 will show you what state your drivers are in and has an indicator at the end which will be red if there's a problem and green if everything is ready for you to install. I guess because you are here, it will be red :)


Click "Next". This will enable the buttons in Step 3.


Click Part A to create a "system restore point". This is a backup of Windows that will enable you to take your PC back to how it was before you ran this tool in case anything goes wrong (it won't :(). Don't skip this step unless you know what you are doing.


Click Part B. This will remove any existing drivers for the Vega to make sure we start from a clean state (for old hands, this automates what we ask people to do with USBDeview).


Click Part C.


Now select how you would like to install the drivers.


If you don't know what you're doing, just leave this first option selected and click "Do it". The tool includes the latest drivers (as of today) and will automatically install them.


Select the second option if you have your own drivers and specifically want to install them, e.g. the ADB drivers from the SDK.


The third option will search all of your disks for suitable drivers and will prompt you to install for each one it finds. Obviously, if you select one, it will install and the search will stop.


The tool might tell you that the driver is installed before Windows have finished it's work. If it says it has finished but the indicator is still red, just wait for 30 seconds or so. If the tool says the driver is installed but the indicator never turns green, please come back for help.


Please remember this is a test version. No matter what, it won't screw up Windows so please do try it.


Please also take the time to report success or failure. I will be actively developing new release so I need the feedback. I will be especially grateful for anyone who tests on Vista and Win 7 64 bit and reports back.


Finally, if you report a problem, please provide as much detail as possible. Screen shots would be graeat.






If you want to say "thanks", and you do not yet use Dropbox (it's enormously useful, especially with mobile devices), please consider signing up for it using my reference. They give me extra free space if you do :)


Sign up for Dropbox




thanks for doing this program im sure its going to help loads of people


i have a strange problem, i installed the drivers about 4 weeks ago and all was fine i installed the MCR and framework stuff , then all of a sudden it stopped working when i do ADB devices there are no devices , have tried on a friends computer and it works fine , when running your program and selecting install Modaco rom it comes up green all ok but i still have no devices when doing ADB devices , can you help me ?


Thanks Andy

hi, links no longer work is there anywhere i can get this? ive tried for two days now and still have a bricked vega? im running win 10 64bit, when i try to install usb drivers it says windows incountred a problem, which i assume is because they are for 23bit? thanks

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.