Jump to content

3G icon disappeared yesterday and wifi no longer working either..


Guest pedrojaime
 Share

Recommended Posts

I have been using FTB (2.1) ROM happily for a long time. This was flashed over Venezuela Movilnet (to retain 3G in Ecuador). A few days back I flashed Cyanogenmod 7.2 (2.6.32 kernel) and was very happy with the phone. I tested data2ext instead of apps2sd and everything was running smoothly. When I got home I noticed wifi was not working. There was no way to get it back so I re-flashed and it worked again.

Yesterday 3G icon in status bar dropped out and no amount of reflashing could fix this. I then decided to reformat my 8Gb SD card. It still does not work today.

So, I find it hard to believe this is down to hardware failure. Should I use Time Machine to take me back to 1.5 factory rom, re-flash Movilnet 2.1 and then go back up to 7.2?? Has this happened to people before? Is this down to software corruption on the phone (I have tred a fair amount of ROMs over the past year. What are people's recommendations to get back to a completely clean state on my phone? Does this sound like what needs to be done here to get 3G/WIFI back? Everything else runs perfectly well.

thanks for your time, any ideas welcome!

Peter

Edited by pedrojaime
Link to comment
Share on other sites

I have been using FTB (2.1) ROM happily for a long time. This was flashed over Venezuela Movilnet (to retain 3G in Ecuador). A few days back I flashed Cyanogenmod 7.2 (2.6.32 kernel) and was very happy with the phone. I tested data2ext instead of apps2sd and everything was running smoothly. When I got home I noticed wifi was not working. There was no way to get it back so I re-flashed and it worked again.

Yesterday 3G icon in status bar dropped out and no amount of reflashing could fix this. I then decided to reformat my 8Gb SD card. It still does not work today.

So, I find it hard to believe this is down to hardware failure. Should I use Time Machine to take me back to 1.5 factory rom, re-flash Movilnet 2.1 and then go back up to 7.2?? Has this happened to people before? Is this down to software corruption on the phone (I have tred a fair amount of ROMs over the past year. What are people's recommendations to get back to a completely clean state on my phone? Does this sound like what needs to be done here to get 3G/WIFI back? Everything else runs perfectly well.

thanks for your time, any ideas welcome!

Peter

think that you have to flash first with tre rom...and then flash with cyanogen 7.2...

the official Tre update uploaded to Mediafire. Here you go: http://www.mediafire...iddw2bpbiydkrso

tell me :)

Link to comment
Share on other sites

think that you have to flash first with tre rom...and then flash with cyanogen 7.2...

the official Tre update uploaded to Mediafire. Here you go: http://www.mediafire...iddw2bpbiydkrso

tell me :)

Correct me if I am wrong, but I think the u8220-6 is not exactly the same as our u8220 devices. I believe that Peter will want to flash the official rom made for his device.

Peter, I don't see why you need to flash the time machine. Only if you can't get the Movilnet rom to flash should this be necessary. The time machine does nothing other than setting a switch to make it possible to flash other official roms on your device. It does not change your partitions or any underlying firmware (radio, etc.), other than making it possible to flash other official roms, particularly letting you revert to an older official rom after flashing a newer one.

Your idea is good though. After you flash the Movilnet rom, you can run it for a while. If it does not give you the same problem after a few days of use, then you might be able to conclude there is nothing wrong with your hardware.

Good luck.

Edit: I'm still using FTB. I keep trying, but I just can't find something "better". ;)

Edited by twrock
Link to comment
Share on other sites

Hey guys, thanks for the help. I couldn't TRE 2.1 doesn't contain the necessary 3G frequency for me unfortunately. Cannot flash Venezuela official Movilnet 2,1 to get the 3G back. I had 3 time machine dload images - for some time I lost fastboot mode and recovery completely. Then I put Ecuador 1.5 dload on /sdcard. That worked, now on 1.5. Now in fastboot mode that works, now I can flash Amon-RA to get baseline 2.1 back on - SUCCESS here. Now I've rebooted into Amon-RA, I can follow these instructions to get Movilnet ROM back on..

Link to comment
Share on other sites

Hey guys, thanks for the help. I couldn't TRE 2.1 doesn't contain the necessary 3G frequency for me unfortunately. Cannot flash Venezuela official Movilnet 2,1 to get the 3G back. I had 3 time machine dload images - for some time I lost fastboot mode and recovery completely. Then I put Ecuador 1.5 dload on /sdcard. That worked, now on 1.5. Now in fastboot mode that works, now I can flash Amon-RA to get baseline 2.1 back on - SUCCESS here. Now I've rebooted into Amon-RA, I can follow these instructions to get Movilnet ROM back on..

Wow, sounds like a nightmare! Hope it all gets sorted.

Link to comment
Share on other sites

Well, I got Movilnet 2.1 on the phone again but still no 3G :( I am calling my operator to check that 3G has not been disabled for this device. Unfortunately I think the issue is more serious than this. In Movilnet I get 'unable to start wifi' so I have a seaking suspicion that the network interface is dead. The radio works and I can make and receive phone calls but that's it. I would like to get Clockwork on it again to flash FTB/CM7.2 to get terminal so I can see if the network interface is working.

Does anyone have any good commands to test network card via ADB or can someone tell me the best way to flash Clockwork recovery on the device please.. :(

I honestly think its my phone, everything was working fine and thenwifi/3G started failing..

Many thanks,

Peter

Link to comment
Share on other sites

Well, I got Movilnet 2.1 on the phone again but still no 3G :( I am calling my operator to check that 3G has not been disabled for this device. Unfortunately I think the issue is more serious than this. In Movilnet I get 'unable to start wifi' so I have a seaking suspicion that the network interface is dead. The radio works and I can make and receive phone calls but that's it. I would like to get Clockwork on it again to flash FTB/CM7.2 to get terminal so I can see if the network interface is working.

Does anyone have any good commands to test network card via ADB or can someone tell me the best way to flash Clockwork recovery on the device please.. :(

I honestly think its my phone, everything was working fine and thenwifi/3G started failing..

Many thanks,

Peter

I think it is easiest to flash CWRecovery from your computer over a USB cable with the phone in fastboot mode. Here's the zip you need. Unzip it on your computer and run the batch file/script (depending on your sytem). http://www.mediafire...v8z3usr5059ws5z

Edited by twrock
Link to comment
Share on other sites

hi. i have a u8220-6 and rooted whith flb 1.7 and 3g icon not work. i´m from chile. you write used a uruguay rom 1.5 to fix the problem and reinstal te flb 1.7. right?<br><br>You please post the link to uruguay rom , please i needed. <br>Thanks <br>

Link to comment
Share on other sites

Hi, thanks to everyone who responded offering help. Have been v. busy at work - no time to answer sooner.. In the end I got fastboot to work so was able to flash Clockwork recovery and get the desired CM7.2 rom back on the phone (replacing Movilnet). 3G was simply that 3G icon disappeared when my data plan ran out. It renewed yesterday and its back and working again after re-registering and selecting registered APN in Wireless settings.

Wifi was fixed by setting the MAC address with the CM7.2 app once and allowing this program superuser access.

I am not sure if 3G in Uruguay is in the same band as in Ecuador. I have Android 1.5 Ecuador ROM (where 3G works in my country. This post (in spanish) was extremely helpful and carefully details all the steps necessary. I am not convinced that ALL these steps are necessary but this really helped now and in the past. I believe I downloaded Android 1.5 Movistar ROM from this site: http://u8220.blogspo...android-15.html

If there is a broken link let me know and I will create a mediafire/other account to upload my Movistar 1.5 ROM for you.

So in the end, my problem was fixed :D I am not convinced that CM7.2 is fully stable and ready yet. Market is a behemoth app in this rom and I miss how well the old Market and general stability of FTB 2.1 rom. I get reboots at times with 7.2 - I will detail my findings in that discussion thread.

@twrock: have you thought about implementing the kernel 2.6.32 into FTB? How about data2ext too? I tried installing and running data2ext --enable twice. The second time it told me its 'set but not enabled' Will do some more testing and report back in yout FTB thread about this. I think I need to run some more commands to get data2ext working in FTB

thanks again and let me know if you are not able to download Movistar 1.5 ROM from the site I mentioned.

Peter

Edited by pedrojaime
Link to comment
Share on other sites

could you guys share your "Baseband version"?

It is in Settings -> About phone -> Baseband version

Am I correct that your phones are u8220-6 ?

I'm trying to adopt UM840 (Movilnet/Venezuela) Froyo rom for Pulse, trying to figure out differences in radio (baseband processor).

Link to comment
Share on other sites

  • 1 month later...

could you guys share your "Baseband version"?

It is in Settings -> About phone -> Baseband version

Am I correct that your phones are u8220-6 ?

I'm trying to adopt UM840 (Movilnet/Venezuela) Froyo rom for Pulse, trying to figure out differences in radio (baseband processor).

HI Pier, Sorry for th delay in my response. I really appreciate what you do for our phone :)

It tells me Baseband Verion: 6383. Mine is a U8220-6 This is how its displayed on the back under the battery.

I just installed and ran one of twrock's included apps from his FTB ROM called 'Android System Info' which tells me the phone has:

-Internal Memory Max: 105.25MB Free: 57.69MB

-RAM Max: 104MB Free: 15Mb

Let me know if you need any more diagnostics output from terminal/ this app.

Peter

EDIT: inputting the IMEI code into the www.carphonewarehouse.co.uk site brings up that the model of this device is a U8220! Not sure if this is correct. I always assumed by the specs that it was a U8220. I now am running Styx rom and 3G is working fine. The Baseband no. that comes up in Settings is stil 6383 btw..

Edited by pedrojaime
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.