Jump to content

ZTE-Z990 Avail HowTo's

Guest mikefm

Recommended Posts

  • 1 month later...

I was able to successfully unlock my phone using your instructions. Thanks!!

I have been unable to root it using your instructions. I believe my problem is that the code (*983*7668#) entered through the dialer doesn't seem to put my phone in root mode and the next command then fails with "permission denied" error. I'm new to rooting a phone, and I'm sure its me, as others aren't having trouble. Should the phone do something after I enter the code to let me know its working??

Any help??


Edited by nedhed
Link to comment
Share on other sites

Guest Phydeux721

Actually, I used SOME of the instructions here.


Not the backup part (Me no use Windozes)

Using a VM, I was able to flash the 'unlock' portion (Since I use T-Mobile here in the US, I had to. There are a few more steps to get non-ATT carriers working))

But from there, I went on my own.

**Note: I can only say this works for the US AT&T Avail Z990. I do not know if it will work on the Merit or the Z990g **

** Use/follow at your own risk!!!! You brick it/break it/make it useless, it's YOUR fault ****

Here's what I did:

  • Used the "T card" method to get to a easily rooted ROM
  • After that boots, I sign in to Google (Since I didn't do the backup/restore, I have no wifi. We'll fix that in a few)
  • Went to settings > Applications > Development and enabled ADB
  • Downloaded from the Play Store : Superuser and Absolute System Root Tools (DO NOT RUN YET. Just install them)
  • Entered the *983*7668# code to get root started
  • Ran Superuser, and UPDATE IT
  • Now, I ran Absolute. Say "Allow" when Superuser asks. Then, I clicked on the "File Browser", went to /system/etc, clicked the "nv_4319.txt" file, and where the MAC addresses are, I commented ("#" if front of the one that doesn't have it) and uncommented the other MAC address (removed the "#" from in front)
  • Went to the wireless settings, shut off wifi, then back on, and was then able to get my wireless going

So, now I'm rooted, sim unlocked, and on wifi.

If all you need is root, try the code, then install/run/update Superuser. That's usually all you need. If it doesn't work, you may need to T-Card to get a ROM where the code works.

If you need a different carrier, or APN settings changed, "Skip" the login step, change/add your APN settings, then add your 'sync account' for Google and the Play Store

Link to comment
Share on other sites

  • 2 weeks later...
Guest downloadbob

New here and looking to unlock AT&T Avail ZTE-Z990. Following the instructions and got Part I done without much issue.

Part II was giving me some trouble: Downloaded and extracted the flasher tool to C:\flasher. Downloaded and extracted the firmware package to C:\flasher\files.

When I started Unlock.exe, I got a popup that says 'Fail to find "RecordCSV.sdi', please select setup folder." I was unable to locate this file anywhere on my system or inside any of the files I had downloaded.

I took a chance (thinking this may be some kind of "error log" file) and made a copy of the "WCDMA-DL_Setting.cfg" file and renamed the copy to "RecordCSV.sdi". Unlock.exe this time started with no popups and "Ready" was shown below the "Start" button. Pressed "Start" and crossed my fingers.

After a few minutes, the progress bar got to 99% and the phone rebooted into FTM mode. It never did finish 100%, so I unplugged it and completed Part III then rebooted the phone to check if it was unlocked.

Put in a few different SIMs and it appears to be working! The SIMs I have are for overseas use, but at least I'm no longer getting a message for the unlock code anymore, My new T-Mobile SIM is micro so until I get an adapter, I can't really fully test it.

Just thought I'd add this tidbit to the discussion in case someone else is trying to unlock this phone. Remember, YMMV and good luck!


Edited by downloadbob
Link to comment
Share on other sites

  • 2 weeks later...
Guest StefanEU

I had problems with this too because of a missing driver and nothing worked even after downloading many different drivers. This works, with this sofware package so the driver for the phone in FTM mode works.

After installing that software but not updating it, ADD the port in QPST Configuration and add the port the phone is on. After that it should be straight forward.

I'm on W7 64bit.



Edited by StefanEU
Link to comment
Share on other sites

  • 3 months later...
  • 1 year later...

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.