Jump to content

r2: Legacy Play Store (with all purchased apps visible)

Guest PaulOBrien

Recommended Posts

Guest PaulOBrien


[Edit: Updated to r2, see the changelog at the bottom of this post for details!]

The Play Store is great, but it really annoys me that I can no longer see a list of all my purchases on my device. This USED to be possible of course, but they removed the 'not installed' list in an update somewhere along the line. Rubbish.

Sooo.... i've retrieved a version of the Store with this feature and hacked it about to make it install alongside the regular Play store. :)

The APK can be downloaded below - you need to push it to /system/app and chmod it to 644. This is very much in testing - please let me know how you get on. [note: edited, I recommend pushing to /system/app on all devices now.]

Oh, you probably also want to turn off the update notifications in this version or you'll get duplicates!

  • r2 - DOWNLOAD (ROMraid) - MD5: c74fa97a9738265c53de630420237f78
    One last thing, PLEASE don't just go reposting this everywhere, link back to this topic.

    Enjoy! :)



    • Modified 'My Apps' list order to show 'Not Installed' apps above 'Installed' apps
    • Improved compatability with AOSP ROMs


    • Initial Release
Link to comment
Share on other sites

Guest h00py

Works fine on my HTC One X (CM9). I dropped it in to /system/app just in case I had problems.

Thanks again Paul, this was a feature I missed from the old Play Store :(

Edited by h00py
Link to comment
Share on other sites

Guest darrenjdoc

Excellent Paul. I tried the apk on the SGS3 but it would just f/c so i installed it to /system/app and it worked perfectly.

Many thanks :)

Link to comment
Share on other sites

Guest phunni

Installed on N1 running cyanogen 7 and it seems to work, but then simply gets stuck at the "loading" bit after allowing account access.

Link to comment
Share on other sites

Guest Silvake

Yeah, very handy, thanks Paul!

Working great on both HTC Desire and Samsung Galaxy Tab (P1000), both with CM9.

Same observation applies: you must push it to /system/app/, otherwise it force-closes, as @jamoiholland noticed earlier.

In my case, at first run, it also found updates to Google Play Music and Google Play Movies, which were not detected by the original Play Store (country policy, I guess).

Thanks again.

Link to comment
Share on other sites

Guest TheJoker79

Thanks Paul, i really missed this feature!

btw: although pushing to system might be the best and most stable option for this i just installed it normally and it works just fine :-)

Stock, non rooted htc one x...

Link to comment
Share on other sites

Guest kbkang

copyed to system/app and given permission using root explorer. app force closes

pushed with adb and given permission, app does not show up.

Nexus s with JB custom rom here.

Edited by kbkang
Link to comment
Share on other sites

Guest oscarthegrouch

Running Samsung epic touch 4g with EL29 gingerbread 2.3.6 rooted. I copied to /system/app with root explorer. Downloaded connectbot and ran using local. Su then accept root with super user. Followed last two lines of djfoo000's instructions then rebooted. Didn't use adb. Works fine now.

Link to comment
Share on other sites

Guest Wonsanim

Very Nice Thanks Paul.I Push Legacy Play Store to /system/app and install using ROM Toolbox in my Galaxy Note Running 4.0.4 :)

Link to comment
Share on other sites

Guest absro

Just great! Thank you very much :)

I have a Galaxy Note with ICS (XXLQ3), only rooted but with the original kernel (so this is a secure kernel - afaik adb remount doesn't work on secured kernels, but I was too lazy to check) and the regular install was producing FCs, so I used Stericson's Remount to mount the /system as RW, copied the apk, chmod 644, rebooted and everything works!

Again thank you Paul!

Link to comment
Share on other sites

Can't get it to work. No Play Legacy in app drawer.


I'm seeing a similar issue with the AOKP JB preview release.

On MoDaCo JR4 PhoneskyLegacy.apk and Phonesky.apk are both usable after install of PhoneskyLegacy.apk with set permissions and set owner/group. On AOKP JB preview they are both visible in system/app however only PhoneskyLegacy.apk is usable and showing in app drawer after reboot.

After reboot I can install PhoneskyLegacy.apk to data/app as an upgrade/replace app of the system app, installs fine, however doing the same with Phonesky.apk gives the following error: App not installed. An existing package by the same name with a conflicting signature is already installed. After deleting PhoneskyLegacy.apk from system and data and then rebooting I can complete an upgrade/replace app of the system app.

Link to comment
Share on other sites

Guest ChaosZero112

Pushed to /system/app with RootExplorer. F/C.

Galaxy Nexus 4.1.1 XenonHD.

Edit: Alright I got it working. Uninstalled/Cleared Data to start from scratch. Put it in /System/App and rebooted. After I rebooted, I installed it like a normal apk and it "updated" the system app. Now it's working.

Edited by ChaosZero112
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.