Jump to content

Few Vega Problems - Not powering on, NVFlash freezing...

Guest reddragon105

Recommended Posts

Guest reddragon105

Hi guys, hope someone can help - I've got a few faulty Advent Vegas with me at the moment, and I can't figure out what's wrong with some of them.

The faults are as follows -

1) Won't boot up, won't go into recovery (I've tried many times!). The only sign of life is the blue LED flashing when the power adapter is connected, indicating that it is charging.

2) Won't boot up, won't go into recovery (I've tried many times!). The blue LED flashes when the power adapter is connected, indicating that it is charging, and when the power button is pressed the blue LED near the camera also comes on. If the power button is then held down (to power off) that LED switches off. This also happens when I try to go into recovery mode.

3) I had a tablet with a damaged touchscreen (torn ribbon cable, so it won't connect to the mainboard anymore!). I thought the LCD was also damaged, as it was dimly lit and kept flickering, so I took the mainboard out and tried it in another tablet - however the display is still dim and flickering, so it must be the mainboard at fault! I've tried a few different ROMs on it, to no avail.

4) This tablet won't boot up, although it will go into recovery. When I first got it, it did boot up, but the touchscreen was unresponsive. I successfully flashed the P10 v1.10.4 ROM, intending to use it to recalibrate the touchscreen - but after flashing that, it wouldn't boot up. I put it into recovery to reflash, but now NVFlash freezes at the same point every time - "waiting for bootloader to initialize". I've tried flashing a few different ROMs (P10 v1.10.4, Stock v1.10, Modded Stock v1.10 v2, VegaCream Beta 3 and RC2 to name a few!) and it always hangs at the same point. I've tried flashing on two different computers, using all available USB ports and a few different USB cables.

Anyone got any ideas?

I'm suspecting bad boards with 1-3, but not sure if they would be fixable or not. 4 seems like a bad flash, which should be an easy fix, but it's not accepting any ROMs.

If anyone has any ideas of anything I can try, I would be most grateful!

Link to comment
Share on other sites

Guest richardmlea

Hi mate,

relevant all of them,

when you try to put them in NVflash mode is your PC pinging to say its detecting the tablet? what is windows calling the device?

Have you tried connecting a HDMI and a TV to them to see if the LCD's are the problem.

Are you sure the button boards are working properly, Try swapping one that you know is working 100% from another tablet.

Try the back button thing at different speeds, I am sure that you have noticed that different roms/tablet react differently to the button presses.

regarding the third one,

You could try swapping the HDMI board or the LCD cable. If the motherboard is knackered at least the LCD will be OK.

Regarding the forth,

A bad flash wont damage the bootloader or NVflash mode as we don't do anything to the bootloader when we flash roms. That is why the Vega is considered UN-brickable. However if the bootloader get corrupted or another part goes faulty (i.e the USB port, a random IC or the NVEC) the tablet is effectively bricked.

If it is saying waiting for bootloader to initialize then I don't think it's in NVflash mode or if it is then the usb driver on the pc is maybe wrong. What is device manger in windows calling the device (start, control panel, device manager, USB controllers). It should say "Nvidia USB boot recovery driver for mobile devices". If it is all correct and still hangs on "waiting for bootloader" then it's faulty, sorry

Good Luck

Edited by richardmlea
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.