Jump to content

Explained like you're 5: Install custom ROMs from scratch, install the official ICS update, root & more


Recommended Posts

Guest Tony5101

Your instructions are great, however I'm stuck. I'm at the point of installing my rom. This is the one I've gone for.

http://www.modaco.com/

topic/357228-ics-repack-403-b936-u8815-ota-release-rom/

Not sure whether I go for the full install or the repack?

Currently though, when I'm in CWM, I select 'install zip from sdcard' and all that happens is the tophat that's in the centre of the screen goes bold, but nothing else is shown on the screen. I don't get the option to select a file to install.

Hopefully it's just something that I haven't done! Thanks

Link to post
Share on other sites
  • Replies 258
  • Created
  • Last Reply

Popular Posts

This is really well done. I know there's a thread like this already on the forum, but this just takes it a bit further and breaks up the steps a little more as well as providing screenshots. It's very

Great tutorial, it will really help new users.Moderators should pin this thread.

Very very very very very very very very nice guide you've done :D I've pinned it so it doesn't get lost in the forum.

Posted Images

you try it again in clockwork.if you want to save time ,download quick boot from the play store and use it to get to clockwork quicker .then use volume up and down to you get to where you want and select the home button in the middle .

Edited by wrtease
Link to post
Share on other sites
Guest Tony5101

At the moment, I don't have access to the play store.

None of the options in clockwork seem to do anything at all. Even selecting reboot, all results in the same thing. Blank screen with the 'tophat' in bold.

Link to post
Share on other sites
Guest Tony5101

Sorry - don't know how to add a screenshot, but have taken a photo of the screen.

Essentially black screen with hat and orange circular arrows. This is the screen I get regardless of the option that is chosen.

post-992699-0-54447200-1347297139_thumb.

Edited by Tony5101
Link to post
Share on other sites
Guest PandaThing

I tried on a Laptop Windows 7 x32, UnlockRoot, same error, failed :(

Gabriel, the drivers for win xp are here. After the driver install (which can take up to ten mins) you can try this method, or you can try to use Paul's root tutorial and start from step 4.

And if you give up, the NZ ICS update (official sd update) is available here. I'm running it right now and its remarkably free of crap-ware.

Link to post
Share on other sites

At the moment, I don't have access to the play store.

None of the options in clockwork seem to do anything at all. Even selecting reboot, all results in the same thing. Blank screen with the 'tophat' in bold.

Tony, it looks like you are pressing the wrong button - you are getting the blank screen because you are pressing the menu button. You have to press the home button, which is the one in the middle, as shown below:

vDnHj.gif

tony you are using a g330 ,totally different mobile .,send me a message i can help you.

From the photo he showed, he is definitely using a G300. The G330 doesn't have the silver edges.

Edited by Guest
Link to post
Share on other sites

I used the rooting procedure described but don't get the Superuser app despite the procedure appearing to work as described. Repeating from step 7 doesn't make a difference (and can't really be expected to). Win 7 64-bit Home Premium.

Run it again and reboot your phone. I will update update the script tomorrow to auto reboot.

Edited by Guest
Link to post
Share on other sites
Guest Tony5101

Tony, it looks like you are pressing the wrong button - you are getting the blank screen because you are pressing the menu button. You have to press the home button, which is the one in the middle, as shown below:

vDnHj.gif

From the photo he showed, he is definitely using a G300. The G330 doesn't have the silver edges.

Thanks beggin.

With the help and patience of wrtease, managed to get things sorted...along with a huge amount of facepalming when I realised what I was doing wrong!

Link to post
Share on other sites
Guest theoldsmithy

Run it again and reboot your phone. I will update update the script tomorrow to auto reboot.

Hi, total newbie to Android here I admit, but quite familiar with Windows and Linux. I've got the same problem as seanspotatobusiness. Nothing happens when I run the g300.bat other than the display shown in the instructions. I have rebooted the phone but the superuser app is nowhere to be seen.

Edit - used this method:

http://www.modaco.com/topic/353386-how-to-root-your-huawei-ascend-g300-for-windows-mac-and-linux/

and that worked fine.

Edited by theoldsmithy
Link to post
Share on other sites

Updated the root script. Hopefully this will fix the problem where Superuser does not show.

Also, bat scripts and zips removed for rooting, unlocking bootloader and installing clockworkmod. Replaced with single exe files that you can download and run. (Windows only)

RootG300.exe

BootloaderG300.exe

ClockworkG300.exe

If the new root method is still not working for anyone, please let me know, with details.

Edited by Guest
Link to post
Share on other sites
Guest John Mills

Hi Beggin,

Firstly thank you for this, interestingly for me I wasn't able to Root the phone with Windows 7 32 or 64 bit edition initially on the default Huawei image using the .bat file. I used Paul's method instead. Once the phone was rooted I backed up the IMEI and then flashed the Huawei image (B934) from their website.

After the phone loaded with the new image I was able to use the .bat files that provided with no issues at all. Root worked perfectly as did unlock boot loader and install CWM. Perhaps there is an issue with with the default image you don't see once you have installed another firmware?

Anyway thank you once again for the tutorial it is very well done and easy to follow.

John

Link to post
Share on other sites
Guest discosteve

Hi, my 5 year old son (soon to be 6 so i'd better hurry up!) is going to help me with putting ICS on my G300 but has a question:

Can I go from B886 (U8815V100R001C185B886) - standard on my vendor un-locked phone - straight to B934 ICS. If so, I assume just follow steps 1 - 6. And is step 7 just for installing custom ROM's that have been created - non official Huawei?

The detailed screen shots are really great and fingers crossed it should all go well. Thanks in advance to beggin and anyone who helps out with the above...

Stephen

Link to post
Share on other sites

Hi, my 5 year old son (soon to be 6 so i'd better hurry up!) is going to help me with putting ICS on my G300 but has a question:

Can I go from B886 (U8815V100R001C185B886) - standard on my vendor un-locked phone - straight to B934 ICS. If so, I assume just follow steps 1 - 6. And is step 7 just for installing custom ROM's that have been created - non official Huawei?

The detailed screen shots are really great and fingers crossed it should all go well. Thanks in advance to beggin and anyone who helps out with the above...

Stephen

Hi Stephen. Follow pages 1 - 5 as you still need to root (required for IMEI backup) and backup your IMEI as a precaution. Also, instead of downloading the B934 update, download the newer B936 from Dazzozo's server: http://g300.thebrona...R001C02B936.zip

I haven't updated the guide to B936 yet because I'm still uploading it to my server and it's taking some time.

I'm working on a official ICS update guide, but as I said it's basically the same as pages 1 - 5 on installing a custom ROM.

Edited by Guest
Link to post
Share on other sites

Boot ok

root ok

clock work doesn`t work just hangs looking for device any help please

from post 40

How long does it hang on waiting for device? What OS are you using? Have you tried plugging it in to a difference USB port? Have you tried restarting your computer?

If it still doesn't work, delete the old ClockworkG300.exe and download this new ClockworkG300.exe

Edited by Guest
Link to post
Share on other sites

Hi Beggin,

Firstly thank you for this, interestingly for me I wasn't able to Root the phone with Windows 7 32 or 64 bit edition initially on the default Huawei image using the .bat file. I used Paul's method instead. Once the phone was rooted I backed up the IMEI and then flashed the Huawei image (B934) from their website.

After the phone loaded with the new image I was able to use the .bat files that provided with no issues at all. Root worked perfectly as did unlock boot loader and install CWM. Perhaps there is an issue with with the default image you don't see once you have installed another firmware?

Anyway thank you once again for the tutorial it is very well done and easy to follow.

John

Hi John, thanks for this. Some people seem to have problems with the included root method for Gingerbread phones, but it worked for me and others. I will update the pre-ICS root method to Paul's as this seems to work for everyone.

Link to post
Share on other sites

Hi. Thanks for all your hard work with this guide. I just wanted to ask you if you could do the same thing with downgrading from ICS to stock GB.And another noob question:WIll I be able to update OTA to the new ICS when releeased if I install a stock Vodafone UK GB ROM, even if my carrier is Vodafone RO?

Link to post
Share on other sites

Hi. Thanks for all your hard work with this guide. I just wanted to ask you if you could do the same thing with downgrading from ICS to stock GB.And another noob question:WIll I be able to update OTA to the new ICS when releeased if I install a stock Vodafone UK GB ROM, even if my carrier is Vodafone RO?

Hi, there's a really good detailed downgrade guide by timethrow over here - http://www.modaco.co...with-downloads/. I know it looks messy on a forum but it's very in depth.

As for your second question, most likely. I can't see a reason why you wouldn't receive the OTA update.

Edited by Guest
Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.