Jump to content

Help with rooting Huawei Vision U8850

Guest spoonium

Recommended Posts

Hi together,

I'm trying to find way to root my Huawei Vision U8850. The stock ROM is Android 2.3.7, so all the available tools like SuperOneClick, DooMLoRD or z4root don't work anymore, since most of them are using the zergRush exploit which has been fixed.

Is there any way to root the phone? Info about this phone is very sparse over the net, though I did find a Chinese forum which might have an apporach. But of course I do not speak Mandarin, and applying to the forum requires some sort of code.

http://translate.google.com/translate?hl=de&sl=auto&tl=en&u=http%3A%2F%2Fbbs.huaweifan.com%2Fshouji-15208--2.html resp. http://bbs.huaweifan.com/shouji-15208--2.html

I've also tried to run multiple update.zip files containing su from the recovery boot, but it just told me that the signature verification failed.

Looking forward to any help!

Some more info:



Android Version





U8850 V100R001C169B244SP22

Edited by spoonium
Link to comment
Share on other sites

I've found a Russian forum with quite much activity regarding the U8850 Vision. Problem is, I don't speak Russian, and registering on that forum requires you to input a Cyrillic CAPTCHA, which of course didn't work with Window's Character Map.

I've tried to translate the instructions on how to get root from this post: http://4pda.ru/forum/index.php?showtopic=257207&st=1700#entry14246750

I am however not sure if I understood everything correctly, or if Google Translate was working correctly.

I'm also not sure what exactly the "Russian Channel" firmware will do to my phone (e.g. phone is only in Russion, keyboard is in cyrillic, GPS not working, etc).

The firmware can be found on the official Huawei page (alongside a "Japan softbank" version): http://www.huaweidevice.com/worldwide/technicaIndex.do?method=gotoProductSupport&productId=3812&tb=0

Below is my take on the instruction (which I haven't tried yet). Does this sound plausible to you?

Success, see below.
Edited by spoonium
Link to comment
Share on other sites

Been there, done that, and successfully! :D

I've performed the root now by creating a custom firmware which includes su, busybox and Superuser.

I've uploaded the firmware here:


To flash the firmware, you will need the "U8850 Upgrade Tool V1.8.4" from here:


This will erase all of your user data, so save anything before you do this. And of course I'm not responsible if anything bad happens to your phone, all I can say is that it worked for me.

The firmware is based on a Slovenian one found here:


I've labelled this method the "Russian Root", because I found the initial instructions on a Russian forum. I've translated the instructions and added anything missing to it.

See below for a detailed instruction on how to create a custom rooted firmware for yourself.


* Russian Root

* Gaining root permissions on the Huawei Vision U8850 with Android version 2.3.7

* Originally posted at http://4pda.ru/forum/index.php?showtopic=257207&st=1700#entry14246750

* Translated into English, re-arranged items and added some stuff

* I've also replaced the Russian based firmware with a Slovenian, because it was newer

* Discussion Thread: http://www.handy-faq.de/forum/huawei_u8850_vision_forum/227127-huawei_u8850_vision_root_rooten.html

* Credits go to Sanaes & freedroid


You'll need both Windows and Linux to perform this update (e.g. a second computer, multiboot or a virtual machine).

In Windows:

1) Download the "U8850 Upgrade Tool V1.8.4" from here:


2) Download the "U8850 (Android 2.3.7)V100R001C279B244SP22(Slovenia TUS Mobil)" firmware from http://johnnyparanoia.blogspot.co.uk/search/label/Huawei%20U8850 or http://madmodder.co.uk/huawei/u8850/huawei-u8850-firmware-list.htm and extract the contained firmware (we need the SFC-244M-0-8025-A03.nb0 file)

3) Download nb0-utils.jar from http://yadisk.cc/d/MbFUvzN6bic

4) Download busybox from http://yadisk.cc/d/JIWwvYPNblL

5) Download su from http://yadisk.cc/d/XtZXIL9rble

6) Download Superuser.apk from http://yadisk.cc/d/7TQNlhsFbm1

The following steps need to be performed under Linux:

7) Create and navigate to the folder where you want copy the downloaded files to (e.g. "sudo mkdir /home/username/u8850/")

8) Create a folder where you want the firmware to extract to: (e.g. "sudo mkdir /home/username/u8850/extracted/")

9) Copy the downloaded files to the folder you just created in step 7), using a usb flash drive or whatever means you have (e.g. "sudo cp /path/where/they/are/saved/*.* /home/username/u8850/")

10) Go to that folder: "cd /home/username/u8850/"

11) Unpack the downloaded firmware into the "extracted" folder, using the following command: "sudo java -Xmx512m -jar nb0-utils.jar unpack SFC-244M-0-8025-A03.nb0 /home/username/u8850/extracted"

- Note #1: if this doesn't work, try to install Java first: "sudo apt-get install openjdk-6-jre"

- Note #2: extracting the firmware requires quite a lot of RAM, hence we added the "-Xmx512m" flag which allows Java to use up to 512 MB of RAM. Make sure your Linux machine has this much RAM available!

12) The extracted file "SF8-0-244M-0002-system.img.ext3" contains the Android file system, so we need to mount this file.

- To mount it, we first need to create a folder in /media/: "sudo mkdir /media/android"

- And then we mount the file to that location: "sudo mount /home/username/u8850/extracted/SF8-0-244M-0002-system.img.ext3 /media/android/"

13) Copy the previously downloaded "busybox" file to /media/android/xbin/: "sudo cp /home/username/u8850/busybox /media/android/xbin/"

14) Change the file permissions to 755: "sudo chmod 755 /media/android/xbin/busybox"

15) Copy the previously downloaded "su" file to /media/android/bin/: "sudo cp /home/username/u8850/su /media/android/bin/"

16) Change the owner and group of that file to root: "sudo chown root /media/android/bin/su" and "sudo chgrp root /media/android/bin/su"

17) And the rights to 6755: "sudo chmod 6755 /media/android/bin/su"

18) Copy the previously downloaded "Superuser.apk" file to /media/android/app/: "sudo cp /home/username/u8850/su /media/android/app/"

19) And change the permissions to 644: "sudo chmod 644 /media/android/app/Superuser.apk"

20) Now unmount the image file again: "sudo umount /media/android"

21) And pack the firmware again into a .nb0 file: "sudo java -Xmx512m -jar nb0-utils.jar pack /home/username/u8850/firmware_rooted.nb0 /home/username/u8850/extracted/"

Now we're finished in Linux, the actual flashing has to be done in Windows.

22) Somehow transfer the newly created firmware_rooted.nb0 file to Windows (e.g. with a USB stick).

23) Unpack and install the "U8850 Upgrade Tool V1.8.4". This will install a "SUT L3" program ("Software Update Tool") and the USB drivers for the U8850 Vision.

24) Connect your phone with a USB cable and use the Software Updater to flash the firmware_rooted.nb0 to the phone.

Don't get (too) nervous during the flashing and booting procedure, it does take quite a while.

After completion, all of your data will be reset and the phone should now be rooted. To check, use e.g. "Root Checker" from the market or any app that needs root rights.

Alternative (original) nb0-utils.jar download location:


Edited by spoonium
Link to comment
Share on other sites

  • 3 weeks later...

Yes, I'm afraid Dropbox doesn't really like public links, they've disabled that feature temporarily for my account. Although I severly doubt I've really reached the limit of 20 GB/day for this single file...

I've uploaded the file to Mediafire now, although I had to split the archive to make that work. I hope it'll live longer there.


Link to comment
Share on other sites

Yes, I'm afraid Dropbox doesn't really like public links, they've disabled that feature temporarily for my account. Although I severly doubt I've really reached the limit of 20 GB/day for this single file...

I've uploaded the file to Mediafire now, although I had to split the archive to make that work. I hope it'll live longer there.


Thank you very much! I will try to boot that firmware and post results!

Link to comment
Share on other sites

Please help. After i choose NB0 file and click next, i get the error 'sut has stopped working'...I tried everything. and even reinstalled windows, nothing helps...

Do you know what is the problem?

Link to comment
Share on other sites

Hm, try renaming the .nb0 file to something else (shorter). Somebody posted in another thread that he had problems with the default file name.

Thanks man! :D :D :D I renamed the file and everything is working perfectly, the phone is now rooted and it didn't even delete any data!

Link to comment
Share on other sites

  • 2 weeks later...

so how to root and install custom firmware ?just download and use upgrade tool with this Huawei.Vision.U8850.Rooted.Firmware.V100R001C279B244SP22.Android.2.37 .thanks

,thanks for the updated firmware , it works ,only by using huawei updater !now waiting for custom roms
Link to comment
Share on other sites

  • 2 months later...

good afternoon

I am christian from mexico, and I'm interested in installing this firmware including root, but I have a couple of questions, and I hope someone can help me

1.-If I install this firmware, can I have the 3G connection in my country mexico?

2. - Which languages ​​you have installed this firmware?

3. - All devices (gps, wifi, bluetooth, etc) work correctly?

I hope you can help me solve these questions, thank you very much in advance.

An apology for my English so poor

Link to comment
Share on other sites

3) Download nb0-utils.jar from yadisk.cc/d/MbFUvzN6bic

4) Download busybox from yadisk.cc/d/JIWwvYPNblL

5) Download su from yadisk.cc/d/XtZXIL9rble

6) Download Superuser.apk from yadisk.cc/d/7TQNlhsFbm1

Can someone please be kind and upload those 4 files somewhere for i can take them? I searched on google but i don't know how good those files are and i don't want to make something stupid with my phone. :D

Thanks in advance!

Link to comment
Share on other sites

  • 3 months later...
  • 4 months later...

Hi I have problem with instalation on the firmware nb0 file. When I push NEXT in Sut L3 it show me Error Code: 0xff06
Why? And is it possible to fix't?





Edited by Niki Nick
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.