Jump to content

Initial impressions

Guest ravenge

Recommended Posts

Guest ravenge

My Nexus 10 32gb (AUS variaint) arrived yesterday, I was pretty pumped to say the least!

Here are my initial impressions on the device:

Package included:

  • n10
  • 2A AC adapter with USB port
  • USB to micro USB cable (for charging/data)
  • Warranty information booklet
  • Quick start Guide

    Look of the device:
    The device looked more or less as expected. For some reason I was expecting the black border around the screen to be more pronounced but was pleased to find it is quite unobtrusive and provides just the right width for your hands to get a nice comfortable grip without covering parts of the panel.

    Build Quality:
    The nexus 10 feels great in my hands. The plastic backing has a rubbery (but not too sticky) feel very similar to that of the nexus 7 which extends all the way around to the bezel on the front of the n10. This rubbery texture makes the device very easy to safely grip without having to hold the n10 too hard which could result in fatigue.
    It feels extremely sturdy and well made and has little or no give in the plastic, no creaking or bending (if you are worried about the plastic construction, don't be. It feels great).

    As with any 10" tablet, you probably aren't going to hold it for extended periods in just 1 hand. You will probably want to rest it on a table or your lap. That said, the N10 is one of the lightest devices in its class, and it really does feel light and easy to hold. Portrait is comfortable in one hand, landscape you will find yourself wanting to put it down sooner. I'm hanging for a smart-cover type accessory that will fold into a stand.

    The screen looks amazing, it was amusing to fire up 1080p video at 100% zoom and have it take up only about 1/3 of the screen! SO MANY PIXELS! I did not experience any screen bleed like some of the early reviews mentioned.

    Video playback:
    Lets face it, if you get a 10" tablet, there is a good chance its for you to a] watch video on or, b] becuase you have kids and they like angry birds. I don't have kids so..
    I prefer MX player or Vplayer as a fallback. Both do a great job and play video seamlessly. I was very disappointed to learn that almost every android video player has been forced to drop support for DTS audio (a very common codec used for mkv / high res video). I had to work around this by using the "Use custom codec" feature of MX player. With the work around, playback is smooth and sound is good - it is nice to have front mounted stereo speakers on a tablet this size - They are probably too quiet to use in public areas so you'll want to have a nice set of headphones for such an occasion.

    Wifi Performance:
    Wifi performed as well as my Galaxy Nexus as far as I can tell without running benchmarks. It did seem a little more sluggish trying to connect to the network without a broadcasted SSID compared to my gnex.

    Note to Developers/root users:
    This was a very troublesome device to root. I did fastboot oem unlock immediately when first powering on the device. This worked fine, however when booting into android, the n10 would stick in the loading (nexus X glowing logo) screen. It seems like this is a pretty common problem. I was able to download the factory image from google and get the device to boot by replacing the userdata.img with the one from the factory image.

    Upon entering the os, I had more problems - the Wifi setup didn't have an option to skip setup or add a wifi network manually (My work network doesn't broadcast ssid, so I was stuck again).

    After using adb in clockwork mod recovery, I was able to set the flag that disables the setup wizard and get rolling again.

    Once I was in the OS, I found the factory image that my N10 shipped with was JVP15P and not JOP40C - Time to update again

    Rebooted to flash the whole JOP40C - got stuck in a boot loop again

    Re-flashed stock recovery image and did a factory reset from that to re gain a bootable os.

    Once I had the device booting again, I enabled debug mode immediately (so that i wouldn't forget later) I copied the root.zip update to the /sdcard/downloads via windows and rebooted to fastboot.

    In fastboot, I re-flashed the modified CWM touch recovery image, and rebooted to it.

    In recovery, i ran the root.zip and that patched the SU apk/binaries etc.

    Finally I'm unlocked with root access. (note JOP40C does have the option to manually add a wireless network - thank goodness)

    I also had a lot of trouble with drivers in windows. The only method that worked properly was the "have disk" manual assigning of the "Naked" drivers for android/adb.

    To save some time, I suggest try the following order if you're rooting:

  1. Download the naked drivers:

  2. Download JOP40C (or find yourself an equivalent ROM on xda that you prefer to use)

  3. boot up in fastboot mode (volume up, down and power)

    	fastboot oem unlock
  5. flash the .img's from the JOP40C download (there is a nice batch script that automates it) but I prefer to do it manually - or edit the script so that it doesn't reboot automatically after installation.
  6. boot into stock recovery (in fastboot mode, press the volume switch until the power button says reboot in recovery).
  7. Bring up the menu in stock recovery (iirc- [Power] + [volume up] once the red ! android logo is displayed in the background)
  8. reboot
  9. Hopefully you should now have an up-to-date booting device (unrooted).
  10. You can now root the device by putting a root.zip on the sdcard and flashing it with a custom recovery image. (I use CWM touch, the non-touch version did not work for me - you couldn't select menu options) http://forum.xda-dev...d.php?t=1997022
  11. Use fastboot to flash the recovery image
    fastboot flash recovery recovery.img[/code]
  12. reboot into recovery and apply the root.zip (I used this one, not sure where it was from originally. http://www.mediafire...es35lyioe8hxbxh )

By the time I've posted this, there are probably a bunch of pre-baked roms about for you to try instead of using the aosp build with a root zip. That will probably save you some time if you go straight from oem unlock, flash custom recovery, upload the update.zip over adb and install the custom rom. Be sure to factory reset after you install the rom. That will probably help.

Hopefully this helps someone, because I know it caused me a lot of headache yesterday! It will be interesting to find out next time I factory reset if I get boot loops again!


Edited by ravenge
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.