Jump to content

[STOCK] GEM7112 20121123 ROM

Guest gemini-frank

Recommended Posts

Guest gemini-frank

In this topic you'll find the utility and ROM to restore your Gemini Devices 7112 tablet to the latest software release.


  • Windows PC
  • miniUSB cable
    Note that updating the ROM will wipe the device!


    In order to prepare for installation download the following files:
    • 20121123 ROM - DOWNLOAD - MD5: e6c3914a838c4e4a9722fa64558d34c5
    • RockChip Batch Tool - DOWNLOAD


    To install the ROM on your device, carry out the following steps:

    [*]Unzip the two zip files you downloaded

    [*]Power off your tablet

    [*]Launch the RockChip Batch Tool

    [*]Click the '3 dots' (...) button to select an update image - choose the 'RK2906_B021_GEM7212_FT5X0X_20121123.img' image you just extracted

    [*]With your tablet still off, plug in the USB cable while holding the 'Vol -' button

    [*]In the 'Connected Devices' panel, a green '1' should appear, as shown below. At this point Windows may prompt you for drivers - these can be found in the Rockchip Batch Tool directory.


    [*]Click the 'Restore' button (3rd from the left) and the device will be flashed. Do not unplug the device until this process is complete (indicated by 'Restore Done Success' in the status window as shown below.


    [*]Your device is now upgraded!

    If you have any questions feel free to post below! :)

Link to comment
Share on other sites

Guest Nigel F

Hi need help, have dowloaded sw and followed instructions for Gemini 7112 but "1" box does not go green when pluged in instead is pink... what am I doing wrong... Nigel

Link to comment
Share on other sites

Guest PaulOBrien

If it goes pink your device is booted. You need to turn it off, then plug it in while holding down the volume down key (then it will install the drivers and go green).


Link to comment
Share on other sites

  • 4 months later...
Guest scareemarie

Hi - I'm nt a complete novice to updating firmware - but I simply cannot get the gem7112 drivers to install properly on my computer.

I'm running windows 7 on an AMD 64 bit system if that's any help? I even tried a manual install of the drivers through add a device, pointing at the rockchip folder but to no avail.

Can you confirm it is the volume down side of the button I need to be holding down? Maybe I am releasing it too soon or too late?


I found the SD card method on the get satisfaction site and it worked - so thanks - but I'm all set now

Edited by scareemarie
Link to comment
Share on other sites

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.