Jump to content

[STOCK] GEM7012 (RK) 20121123 ROM

Guest gemini-frank

Recommended Posts

Guest gemini-frank

In this topic you'll find the utility and ROM to restore your Gemini Devices 7012 tablet to the latest software release.

Before you begin, please run check you are using the 'RK' version of the 7012. You can do this by checking you have either the 'RK' model name on the back of the device or 'RK' in the version number displayed in Settings -> About. Do NOT flash this ROM unless this designation is present!


  • Windows PC
  • miniUSB cable
    Note that updating the ROM will wipe the device!


    In order to prepare for installation download the following files:
    • 20121123 ROM - DOWNLOAD - MD5: 8a6200f8c86719e1db3da7f818057876
    • RockChip Batch Tool - DOWNLOAD


    To install the ROM on your device, carry out the following steps:

    [*]Unzip the two zip files you downloaded

    [*]Power off your tablet

    [*]Launch the RockChip Batch Tool

    [*]Click the '3 dots' (...) button to select an update image - choose the 'RK2906_B016_GEM7012_20121123.zip' image you just extracted

    [*]With your tablet still off, plug in the USB cable while holding the 'menu' (3 lines) and power buttons

    [*]In the 'Connected Devices' panel, a green '1' should appear, as shown below. At this point Windows may prompt you for drivers - these can be found in the Rockchip Batch Tool directory.


    [*]Click the 'Restore' button (3rd from the left) and the device will be flashed. Do not unplug the device until this process is complete (indicated by 'Restore Done Success' in the status window as shown below.


    [*]Your device is now upgraded!

    If you have any questions feel free to post below! :)

Link to comment
Share on other sites

Tried all the above and the box wont go green. You say to hold vol - then plug in. PDF file downloaded from RKBatchtool says to press and hold vol+ key and power key. Tried all combos still nothing, is the pad suppose to power up then you press "turn on USB storage" cause I've tried that as well still nothing. Am I missing something simple here or just problems with this pad or software.

Link to comment
Share on other sites

Guest MrPuddington

I have a GEM7012 tablet, but the current software on it seems to indicate a RK2918 chipset. Is it the same model as this firmware, or is it a different one?

Link to comment
Share on other sites

Guest andalie


i have tried all of the above and cant get it to connect.

i have pressed menu and power butten and with usb in and nothing,

i did get a pink connection once.. but never had it go green,

ive also had unsuccesful driver message and then no choice of this rockchipusb anywhere,

So what am i doing wrong??

Ive just purcashed 2 of these tablets and im not happy with angry birds and amazon app store not working,

can you give me more help in getting this to work,



Link to comment
Share on other sites

  • 3 weeks later...
Guest greatlabtec

Hi, I have a Kocaso M760, it is the same shell and chipset as this model and the following may help you (fingers crossed) trying to get the item seen by rkbatchtool was a matter of sheer persistance trying lots of button press combos but this one works on mine, the hold voume down or up key whilst powering on had no effect hence by luck i found the following to work.

Start RKbatch tool, load your firmware and have it ready.

Power off device (long press -8 secs if already on) it did not matter for me if the usb cable was already attached at this point.

Press the 'return' button (bendy arrow sybol) and the menu key (3 lines in a small square symbol) keep them pressed in,

Now press the power key until you hear the comp beep (have pc speakers on -it helps)

When you hear the beep let go of power button but keep holding menu and return button for 1 sec and then let go, it should stay green and you can then flash your firmware.

If you change your mind and want to get out of the restore mode along press on power keyy again will turn off the green firware indicator in rkbatchtool and after 5 seconds power on as normal (another long press on power key)

Good luck, hope this helps someone

Link to comment
Share on other sites

Guest greatlabtec

PS. I have managed to flash the Joytab firmware above (7012) to my tablet and everything works as intended in fact even better as the battery indicator now shows the actual battery strength instead of a false reading (this is a major fault in the kocaso firmwares, something they refuse to acknowledge)

I might add Kocaso have no firmware for the M760 so if you need to reload then the link above is very helpful. Any letter after the M760 ie (w) inicates the case colour so W = white and P =Pink and so on, so don't be put off using the formware above if you have a M760* whater the last letter is :-)

Please post if the above flash process works for you or if stuck then I could post a quick link to a video showing how to do it.

Link to comment
Share on other sites

  • 2 weeks later...
  • 5 weeks later...
Guest yarrakid


Can this firmware you are talking about can this be used on the jobtab GEM7112 8GB version. if so can you give instructions to howto do this as I can not seem to get this to work based on the instructions mentioned. I think the layout for model is slightly different to the description you are showing. When i press the two keys and the power button it just clicks on the machine nothing on the pc, and stays off, when i release the power key it boots in the slash screen for mass storage. any advise please.

thanks in advance


Link to comment
Share on other sites

  • 9 months later...


i know that old topic, old tablets but can you give me a new rom for 7012(not rk).

currently i have 4.0.3 with baseband 1.1 is there anything new? 


is there any option to upgrade, flash clean android 4.4? any idea how to do this?

Link to comment
Share on other sites

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.