Jump to content

Cannot install any ROM on my ZTE blade II (Comviq, Sweden)

Guest Mekail

Recommended Posts


I wanted to try custom ROM on my ZTE Blade 2. I went for CWM method for flashing my ROM. Now after Successfully installing Clockworkmode I tried to flash with http://www.modaco.co...hnchips-7-235/. Which end up giving me error 7, and I started trying several other roms, none of them worked for me. All ending up with error status 7 or status 0 errors.

The only rom which endup with succefully updated message was http://www.modaco.co...up/page__st__80, (Mokee_SF2 ROM). But unfortunatly the phone was stucked on initial splash sceeen and dont boot.

Now I lost the built in recovery . I cant boot in FTM mode to use online upgrade tool to restore to factory setting. I also tried the firmware rom on http://wwwen.zte.com.../mobile/Sweden/ for tele2 and telenor to flash with CWM but same error. The comviq ROM can only be flashed online, which is not possible without accessing FTM mode.

Then I tried the TPT method to use image.bin file. But the phone just boot to CWM interface without doing anthying on Holding the menu+volume key and power on method.

If some how can successfully flash one ROM, or boot FTM mod, my problem will be solved. I dont know maybe someone here has experience with ZTE Blade 2 (comviq) and know about some working mod for it, and any other way.

Thanks in advance.


Edited by Mekail
Link to comment
Share on other sites

Update Solved my Problem.

Thanks to the guy on http://www.swedroid....ead.php?t=83575

Though the I have to do abit of correction. Download a Telenor or Tele2 ROM for BLADE2 from


Open the archive and extract the file updater-script (META-INF/com/google/android /). Edit it with Notepad and remove the first three lines. And and save it. Put it back in archive replacing the old one. Take the zip file and put it on SD. Use CWM and install the modified zip file from SD card. This time there will be error. Until the end an error will appear. Ignore it and boot the phone.

After some time the phone will boot with the new operating system.This process will remove CWM and FTM mode be back again. Though you can reinstall the CWM.

Unfortunately there is no working moded ROM available for ZTE blade so far. So far no problem with new operating system and quit alot of mess is removed compared to factory one.

Edited by Mekail
Link to comment
Share on other sites

  • 3 months later...
Guest Mekail

Here is a fix by konpa in the other thread. I tried it and got access to CMW and root back my phone.

After hours of searching and several desperate attempts, I'm proud to finally have found a solution and a rather simple one at that.


After having executed the following commands:

 adb reboot bootloader

 fastboot flash recovery /path/to/recovery.img

Instead of executing "fastboot reboot", simply disconnect the USB cable and remove the battery for a while. After having reinserted the battery, power it on in the typical recovery fashion (holding down the "volume down" button and pushing the power button until the device begin its boot process, do not release the "volume down" button before you have entered CWM recovery) and you should enter CWM recovery.

EDIT: Apparently, you'll only be able to access CWM recovery on this sole instance. In any further attempts you would simply land at FTM ("volume down") or Android recovery ("volume up" or "adb reboot recovery"). If you want to enter CWM recovery again, you're going to have to redo the flashing process and remove the battery, as explained earlier in this post. Such is at least the case for me.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.