Jump to content

How I rooted the Note II

Guest pedrojaime

Recommended Posts

Guest pedrojaime

As per the usual disclaimer, this worked for me. Hope it works for you too but don't hold me accountable if anything goes wrong.

Okay, these are the exact steps which worked for me:

You will need:

-Samsung Galaxy Note 2 GT-N7100 smartphone

-USB cable (I found a blackberry USB cable worked just fine if you can't find the manufacturer-supplied cable)

-I used Windows7 and it worked (I don't see that XP would be a problem though Vista may well cause issues with drivers and UAC user security settings)

*Note I had avira antivirus installed on PC, but no intrusion detection/firewall/windows firewall activated or installed. This posed no issues for me

-Samsung Kies (provides the necessary drivers), otherwise you will have to hunt down the correct Samsung USB drivers

-Enable USB debugging on phone (in Settings -> System -> Development)

-decent battery power left on the device just in case the process should get rudely interrupted (ie read 'bricking' potential here). I would say at least 40% battery to be on the safe side.

From what I have read:

Odin allows you to flash files on your Android device, including Kernels, stock and custom ROMs, along with different hacks. Flashing stock ROMs with Odin will usually not increase the flash counter, while custom ROMs and Kernels most definitely do increase it.

1. I downloaded the latest (recommended) Odin I could find (version 3.07) from here:


2. Downloaded Kies and installed on Windows7. Got 'kiesSetup.exe' for Windows from:

http://www.samsung.com/us/kies/ -> http://downloadcente...5/KiesSetup.exe (note this is quite large at 65.7Mb and setup takes a while to install too so you just have to wait this out and recommended to have the phone connected by USB during the install)

3. Downloaded https://hotfile.com/...121015.rar.html Extract the cwm6-root-n7100-121015.rar file and there you need to obtain the cwm6-root-n7100-121015.tar file. Unfortunately I did not succeed with this file so I downloaded Openrecovery from here: http://goo.im/devs/O...overy/t0ltespr/ and I picked the latest version ( - openrecovery-twrp- Save this on local hard disk (c:\temp), otherwise the rooting process will fail.

4. Disconnect your smartphone from the PC if it is still connected and then turn off your smartphone.

5. Run Odin (run odin.exe file) on PC (version 3.07)

6. Now, boot your Note II device into Download Mode. For this you must press and hold the following combination of buttons: Volume Down, Home, and finally press

Power buttons (note: you should be holding down 3 buttons) until a “Warning” message is displayed. Let go and then press the Up key to start Download Mode. Now, connect your smartphone to the computer with the USB cable. In the Odin window, you need to see the “Added!!”message. This message is located at the bottom left of the window Odin software and can take a few seconds for the device to be recognised. In the ODIN app click on the PDA button

and then select openrecovery-twrp- file. Verify if the file is shown on the space immediately beside the PDA button.

Important: Don’t change anything in the ODIN, as is expecting for adding this .tar file

Verify and make sure that the “Re-partition” box option is not ticked. Other than this, the only default options that should be ticked are 'Auto Reboot' and 'F. Reset time'

Now, provided that the phone has been connected to the PC for at least 20 seconds, press Start button in the ODIN application to begin to install the Recovery. If the phone was very recently connected, the Start button will go black again 2 seconds or so after it is pressed and you will have to try again.

IMPORTANT: Once this process is started, be patient! Do not move or disconnect or do anything as this can take 5 minutes or more until the flashing process is completed.

When the installation is successfully done, your device will get a reboot automatically. At the same time, the Odin will show a “PASS” message. When the SAMSUNG logo is displayed, then you can safely remove the smartphone from the computer.

Important: If the ODIN display the “FAIL” message or gets stuck, then you must disconnect your smartphone from the computer and close the ODIN application. Go

and remove the battery device, wait few seconds and then reinsert the battery. After that, repeat the guide from the step 5.

Note: These instructions guided me along the way: http://android.sc/ho...y-note-2-n7100/ though I wasn't successful until the 4th time I tried it with exactly what I have explained above.

Finally, once the phone rebooted, it prompted me for the installation of 'SuperSU' app to complete the rooting process. Then, I downloaded 'terminal' and 'SuperUser' apps and opened terminal, where I typed 'su'. This brought up supersu program which prompted me whether to grant terminal root access rights, where I pressed 'grant' and succeeded in rooting this phone.


Hope this helps someone out there and this sparks more ROM developers to take the plunge and experiment with this device!

Now, I have a question, has anyone managed to flash Clockwork recovery on this phone successfully or successfully backed up the factory image using Openrecovery because my backups fail with Openrecovery with the default options/partitions set.

->EDIT: I have since rebooted the phone, ran ODIN again and (now it's rooted), pointed it to the abovementioned downloaded https://hotfile.com/...121015.rar.html

and this time it succeeded! The output I got from Odin was:

<ID:0/004> Added!!

<ID:0/004> Odin v.3 engine (ID:4)..

<ID:0/004> File analysis..

<ID:0/004> SetupConnection..

<ID:0/004> Initialzation..

<ID:0/004> Get PIT for mapping..

<ID:0/004> Firmware update start..

<ID:0/004> cache.img

<ID:0/004> NAND Write Start!!

<ID:0/004> recovery.img

<ID:0/004> RQT_CLOSE !!

<ID:0/004> RES OK !!

<ID:0/004> Removed!!

<ID:0/004> Remain Port .... 0

<OSM> All threads completed. (succeed 1 / failed 0)

<ID:0/007> Added!!

<ID:0/007> Removed!!

For what seemed like a long time, I got 'RESET' displayed on Odin. I wasn't until Android fully came up and I tried calling the phone that it completed with 'PASS' and I disconnected the USB cable. I think I then went into 'ROM Manager' which I have installed and told it to reboot into recovery. At this point it asked me whether to reboot into:

Clockwork 2.x or

Clockwork 3.x

I selected 3.x

rebooted and after a while it now goes into Clockwork I was able to successfully backup then. i see that Clockwork is available and Clockwork touch. In people's experience, which is the most stable, recommended version of Clockwork??

=>EDIT: I have, through ROM Manager, now successfully updated and rebooted into ClockworkMod Recovery v6.0.3.0. It tells me I have x space free on the SD card. Funny that, I haven't bought an SD card yet but anyway..

I don't think I will be purchasing ClockworkMod Touch version unless anyone can give me a compelling reason to do so..?



Edited by pedrojaime
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.