Jump to content

[ICS][B960] ϟTesla ROM For The Huawei Ascend G300ϟ ✰31/05/2013✰


Recommended Posts

Guest kyan31

Game loading is still slow somehow, I have menu loading where I didn't have it on Infusion or stock ICS, but the game itself runs alot smoother while playing.

Reading statistics in Moon Reader Pro still show inaccurate data on words per minute, I was just testing it by scrolling really fast and it shows 23 wpm, which isn't possible since there is more than that on one screen...

While in settings, and requesting for superuser acces on System Tweaks for instance, if I choose option "this time only" it just keeps reseting itself. It works fine if 2nd or 3rd options is checked.

WiFi signal icons is showing gray, but I can surf and access internet, so that confuses me sometimes because I think my network is down. It was showing blue when I rebooted my phone but after some time it was back to gray.

Other than that, great ROM, runs really smooth and fast and I haven't experienced any non working apps or FCs for now.

Thanks for your great work smile.png

So are you saying that menus in game are slow, but the game itself is fast? About the moonreader thing, I have no idea. Finally, with the toggles, try going to the toggle settings and disabling the wifi toggle, and then re-enable it. After doing that, change the order of some of the toggles, and finally the toggles should all be correct and bug free forever.

Edited by kyan31
Link to post
Share on other sites
  • Replies 451
  • Created
  • Last Reply

Popular Posts

Presenting Tesla, created by me Kyan31. This ROM is based on stock B960 and has been created to expand the stock experience. It's smoother, faster, feature packed, and overall just a better experience

FAQ UPDATED 01/06/2013 NOTICE BUGS: If you find any bugs or errors, please don't tell me about it unless you have the following: You must have a clean install of Tesla Logcat List of installed

Cool! :D Thanks for this. It looks really good :)

Posted Images

Guest igorbj

kyan,the wake wolume unlock dont work,try to flash but nothing,and try with mount system and data in recovery,and nothing,can you look what is happening with that

sory on english!!

Link to post
Share on other sites
Guest kyan31

kyan,the wake wolume unlock dont work,try to flash but nothing,and try with mount system and data in recovery,and nothing,can you look what is happening with that

sory on english!!

I know that, thats why I removed it.

Addons

Volume wake - Lets you wake the device both with the power button, and the volume buttons - Needs checking

In the meantime you can flash the one on Cyda's Stock+ thread as it works on Tesla too.

Edited by kyan31
Link to post
Share on other sites
Guest Paulzie

I don't mean to be rude or anything it's just if your ROM has all the stuff then there isn't really any reason for mine.

Ross, as you have gone to the trouble of sourcing Huawei's EMUI components, can you supply an EMUI package that anybody can flash over a base of their chosing? Methinks more choice is a good thing. Telsa has a stack of great features including your wallpapers :)

You may be interested in a great recent post at XDA-devs about EmotionUI components including some download links: [APPS] [NO ROOT] Huawei EmotionUI Launcher, Livewallpaper, Weather App, and More!

Edited by Paulzie
Link to post
Share on other sites
Guest kyan31

ok

sofa

Lol

Ross, as you have gone to the trouble of sourcing Huawei's EMUI components, can you supply an EMUI package that anybody can flash over a base of their chosing? Methinks more choice is a good thing. Telsa has a stack of great features including your wallpapers :)

You may be interested in a great recent post at XDA-devs about EmotionUI components including some download links: [APPS] [NO ROOT] Huawei EmotionUI Launcher, Livewallpaper, Weather App, and More!

I don't think it would be a good idea to do that, Ross has made a very splendid ROM using EMUI components, and making a flashable zip for any ROM would spoil the uniqueness of Ross' ROM.

Link to post
Share on other sites
Guest flajko

Hey there, I actually went to school of Electrical Engineering "Nikola Tesla", since I'm from Serbia!

I'm really proud to use this ROM, thanks for making it! :D

I haven't experienced any bugs yet, it's very fast and sleek ROM but I'd like to ask you if you could add the option for stripping unicode character in Messaging app,

because my language has a couple of them("ć, č, š, ž...") and changing them into "c c s z..." really means a lot!

Thanks in advance! ^_^

Link to post
Share on other sites
Guest astraldemon

So are you saying that menus in game are slow, but the game itself is fast?

Yes, I know it's kinda strange...

For instance if I want to go to Options, I get loading screen and it loads for few seconds, same when going back, etc. This wasn't happening on Stock ICS or on Infusion ROM I installed 2 days ago. It was doing that in an instant.

But games here run alot smoother, it's really pleasent to play. On infusion and stock, I would have lags and twitches now and then.

I don't play alot, I was just testing it again, I keep games on my phone for my little nephew mostly.

I'll survive with those few issues, nothing important, just really like how light-weight and smooth this ROM is. Battery life looks awesome for this few hours I have been using it.

I haven't experienced any bugs yet, it's very fast and sleek ROM but I'd like to ask you if you could add the option for stripping unicode character in Messaging app,

because my language has a couple of them("ć, č, š, ž...") and changing them into "c c s z..." really means a lot!

Thanks in advance! ^_^

Why don't you just change your keyboard to USA/UK ? Since you won't use those letters anyway and it's easier to type with bigger letters...

I am from Croatia and don't have any problems with those letters.

Edited by astraldemon
Link to post
Share on other sites
Guest kyan31

What does 'sofa' mean, everyone says it :S

When translating pages in chinese to english (Anzhi for example), some of the stuff is translated as "Sofa" :P

Link to post
Share on other sites
Guest kyan31

Yes, I know it's kinda strange...

For instance if I want to go to Options, I get loading screen and it loads for few seconds, same when going back, etc. This wasn't happening on Stock ICS or on Infusion ROM I installed 2 days ago. It was doing that in an instant.

But games here run alot smoother, it's really pleasent to play. On infusion and stock, I would have lags and twitches now and then.

I don't play alot, I was just testing it again, I keep games on my phone for my little nephew mostly.

I'll survive with those few issues, nothing important, just really like how light-weight and smooth this ROM is. Battery life looks awesome for this few hours I have been using it.

Why don't you just change your keyboard to USA/UK ? Since you won't use those letters anyway and it's easier to type with bigger letters...

I am from Croatia and don't have any problems with those letters.

Navigate to system/etc/init.d and delete the loopy smoothness tweak. Reboot and see if the problem still exists. Make a backup of the loopy smoothness tweak so you can optionally add it back.

Link to post
Share on other sites
Guest kupp

@kupp

See edit of my previous post, maybe formating dalvick and cache will help you too.

About that issue with sound and screen when the phone is ringing, it's back. After wiping the cache and dalvik, the problem is fixed, but as soon as you reboot it once more it shows up again. Really needs some looking into.

Link to post
Share on other sites
Guest kyan31

About that issue with sound and screen when the phone is ringing, it's back. After wiping the cache and dalvik, the problem is fixed, but as soon as you reboot it once more it shows up again. Really needs some looking into.

I have a feeling that it is the loopy smoothness tweak, i'll probably end up removing it if it is the cause. Anyway, follow the steps below and see if the problem still persists:

Navigate to system/etc/init.d and delete the loopy smoothness tweak. Reboot and see if the problem still exists. Make a backup of the loopy smoothness tweak so you can optionally add it back.
Link to post
Share on other sites
Guest kupp

Yup it does seem to fix it, I'll let you know if this turns out to be a false alarm. What does the tweak do anyway? I feel pretty reluctant about deleting a file with "smoothness" in it's name. :P

Link to post
Share on other sites
Guest ivan.arandjelovic

Yup it does seem to fix it, I'll let you know if this turns out to be a false alarm. What does the tweak do anyway? I feel pretty reluctant about deleting a file with "smoothness" in it's name. :P

Yup, fixed it for me as well :)

p.s. I took a look at the script content. As far as I can tell, it seems to sets different nice levels (term for priority in Linux terms) to system process. System processes, launcher and some other processes get high priority, but this probably messes up the way these processes play media. So, it definitely makes sense that removing this tweak fixes the problem.

Edited by ivan.arandjelovic
Link to post
Share on other sites
Guest kyan31

Yup, fixed it for me as well smile.png

Oh, so now we're getting some progress done. I'm gonna edit the script a little and make a flashable zip for you guys, if the error is fixed permanently, i'll make sure the fix is in Tesla V2.

Link to post
Share on other sites
Guest kyan31

Yup it does seem to fix it, I'll let you know if this turns out to be a false alarm. What does the tweak do anyway? I feel pretty reluctant about deleting a file with "smoothness" in it's name. tongue.png

It basically locks the launcher in memory and does a few other things too, however deleting it shouldn't effect the rom too much as I have done a lot of changes myself. For example, I disabled the scrolling cache for hugely improved scrolling, and the launcher is already locked in memory in other places such as the build.prop.

Link to post
Share on other sites
Guest kyan31

@Kupp and ivan.a

Flash this in recovery, with cache/dalvik wipes. It is a modified LS script. I basically removed the phone and media lines, so sound and ringtones should not be affected at all.

http://www.solidfile...m/d/746fedc778/

Use any affected services as much as you can, while doing reboots every so often, and see if the problem still exists and then report back here. Thanks in advance :)

Edited by kyan31
Link to post
Share on other sites
Guest ivan.arandjelovic

Well, I copied the new script to init.d, adjusted permissions and rebooted the phone. It rings OK, assuming the new script was executed (haven't wiped dalvik and cache though, I doubt that shell scripts have anything to do with dalvik).

So, it seems OK. But, I wonder if the script effects (of the previous or the new one) can be noticed at all :) , also having processes with -20 or -18 priority is quite unusual for linux, unless they are kernel daemons or so.

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.