Jump to content

plzzzz help me urgently

Guest d07a2010

Recommended Posts

Guest d07a2010

My Mother's phone Acer liquid E Ferrari Edition is died today

plz help me guys rapidly,I don't want her to know

when i tried to flash Original ROM 4.005.05.AAP.GEN2_A22F_A.bin with A1_DL_Tool,

it suddenly stopped on fastboot over 10 minutes and give failed message (failed fastboot)

i tried to remove usb and put it again but no hope

also tried this method:-

1. Pull battery in and usb cable to phone and pc

Press in order and without releasing

1. < (back button)

2. Camera

3. (power) not always necessary

Bootloader should appear.

I think FastBoot appears but I don't know what i've to do exactly

phone also charging good

Sorry for my bad English

Thanks in advance,



Edited by d07a2010
Link to comment
Share on other sites

Guest Master_T

You tried to flash the wrong bin, if you have the Ferrari Edition you should use the ferrari rom: 4.002.15_EMEA-G1F_05.02.01 (For Liquid E Ferrari Edition 512MB)

Since you reach bootloader, you should be able to recover it. Does Liquid Download Tool recognize the phone while it's in fastboot? If so, try to flash with the proper bin.

If not you must use fastboot to flash the pieces of the ROM manually. Use this tool: https://disk.yandex.com/public/?hash=vzxWmVGP7M0FxAghxyNU1wkpp8IrltnNgnpIup0rJH8%3D to unpack the various pieces of the BIN file (the one with .img extensions), and flash them manually with fastboot. I must admit I don't know exactly the partition names to give to fastboot for flashing, someone else will have to help you with that.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.