Jump to content

GPS Lock Issue. Try This.


Guest Rico_89

Recommended Posts

Guest Rico_89

For everyone with GPS problems, if you download and launch GPS test, and then go to the compass view with the satellites on it, does the compass always point north, no matter which direction you are facing in?

I've just been out testing this and on my brothers V5, that is on the original rom, that was rooted and play store installed by Merrimobiles, he has a fully working compass, however on my V5 that I rooted, installed gapps and have updated to the latest official rom, my compass is not working.

I don''t know if updating has messed up the compass but anyone with any ideas as to what the difference is?

Link to post
Share on other sites
  • Replies 82
  • Created
  • Last Reply

Popular Posts

I just reset the V5 and duplicated what I did before. I did the steps above and pressed: MobileUncle>Engineer Mode>Engineer Mode (MTK)>Location>Location Based Service>GPS>GPS(OFF)

Posted Images

Guest george109

I've just been out testing this and on my brothers V5, that is on the original rom, that was rooted and play store installed by Merrimobiles, he has a fully working compass, however on my V5 that I rooted, installed gapps and have updated to the latest official rom, my compass is not working.

I don''t know if updating has messed up the compass but anyone with any ideas as to what the difference is?

Can you post a screenshot from about phone so people can see the versions affected. Thanks :)
Link to post
Share on other sites
Guest sandriderman

I have the same build number as the "None Working Compass" above and mine also does not work.

So, I tried restoring my rom back to its state before I ran the "Mobile Assistant" upgrade (which I did not think actualy worked) using CWM and this put me back to ALPS.JB2.MP.V1.2. Can confirm the compass does not work. The compass app says "MAGNETIC Senor error, No magnetic missing or it is out of order". (Smart Compass (ver1.5.1)).

Edited by sandriderman
Link to post
Share on other sites
  • 2 weeks later...
Guest Dan Mullen

It's no good, I just can't get even a single satellite fix :( I tried GPS Status, screen set to stay on, 30 minutes outside. It finds 11 satellites but can't get a fix. Am I missing anything?

Link to post
Share on other sites
Guest bryfly

It's no good, I just can't get even a single satellite fix :( I tried GPS Status, screen set to stay on, 30 minutes outside. It finds 11 satellites but can't get a fix. Am I missing anything?

there is many different ways proposed but you could try this one which worked for me...........in the video I did not delete the file I just renamed it to a .bak

Edited by bryfly
Link to post
Share on other sites
Guest Rico_89

Slightly modified from this tutorial : http://gizbeat.com/2...tk6577-mtk6575/

1. Go to Settings > Google > Location Settings and make sure ‘Let Google apps access your location’ is ON.

2. In this same area you will see a box at the bottom of the dialog that says ‘Location Access’ tap it. (alternatively, access this area by going to Settings > Location access. Make sure ‘Access to my location’, ‘GPS satellites’ and ‘Wi-fi & mobile network location’ are all checked / toggled on.

3. In Settings > Location access, tap the words ‘GPS satellites’. Enable ‘GPS EPO assistance’. Make sure you have internet on, go into ‘EPO settings’ and download EPO data.

4. Download my GPS.conf file. there are others you can try as well. gps.rar Unzip/ unrar and place the gps.conf file in the "system/ etc" directory on your phone. Make sure you backup all original files first.

5. Download ‘GPS Test’ from Play. In GPS Test settings, make sure screen always on is checked.

6. Go outside for up to 15 minutes and watch the pretty little bars go up and down until you get a lock, or put your phone outside (If your screen turns off then you are basically starting again). Subsequent locks should be quicker. Especially if you do it within a short time after the cold lock.

The first lock can take ages but once you get that first lock you should be able to get subsequent locks within a minute.

Edited by Rico_89
Link to post
Share on other sites
Guest Northstandhero

What ROM are you using? On the stock ROM my V5 was the same showing sattelites but no fix, i tried GPS status and then faster fix,which said i had no gps config file so I rooted, added CWM, and then flashed Tillaz's ROM and his GPS Fix and mine has been fine since.

Link to post
Share on other sites
Guest Dan Mullen

Slightly modified from this tutorial : http://gizbeat.com/2...tk6577-mtk6575/

1. Go to Settings > Google > Location Settings and make sure ‘Let Google apps access your location’ is ON.

2. In this same area you will see a box at the bottom of the dialog that says ‘Location Access’ tap it. (alternatively, access this area by going to Settings > Location access. Make sure ‘Access to my location’, ‘GPS satellites’ and ‘Wi-fi & mobile network location’ are all checked / toggled on.

3. In Settings > Location access, tap the words ‘GPS satellites’. Enable ‘GPS EPO assistance’. Make sure you have internet on, go into ‘EPO settings’ and download EPO data.

4. Download my GPS.conf file. there are others you can try as well. gps.rar Unzip/ unrar and place the gps.conf file in the "system/ etc" directory on your phone. Make sure you backup all original files first.

5. Download ‘GPS Test’ from Play. In GPS Test settings, make sure screen always on is checked.

6. Go outside for up to 15 minutes and watch the pretty little bars go up and down until you get a lock, or put your phone outside (If your screen turns off then you are basically starting again). Subsequent locks should be quicker. Especially if you do it within a short time after the cold lock.

The first lock can take ages but once you get that first lock you should be able to get subsequent locks within a minute.

Thanks, I'll follow those instructions to the letter after work :)

What ROM are you using? On the stock ROM my V5 was the same showing sattelites but no fix, i tried GPS status and then faster fix,which said i had no gps config file so I rooted, added CWM, and then flashed Tillaz's ROM and his GPS Fix and mine has been fine since.

I'm on the stock ROM CWM repack, (posted by tillaz).

Link to post
Share on other sites
Guest Rico_89

Just a small tip. Turn your GPS on 5 minutes before you intend on using it, so before you go outside to run the gps test app just turn on your GPS a few minutes before you start.

Link to post
Share on other sites
Guest romasis

Main problem is bad internal GPS antenna. I've made a simple test tried "GPS test" on my wife's huawei honor and mine vowney v5. Best signal on few satellites was around 42-43 on Honor and just 26-28 on Vowney. So, there is one way to make GPS work reliable is to find solution how to strengthen GPS antenna. Yesterday I had a tripe on car, used navigation on Vowney. Worked OK on clear road, but then were a lot of trees near road GPS signal was lost a lot of times.

Edited by romasis
Link to post
Share on other sites
Guest Dan Mullen

Well, I followed every step in the procedure above and it still wouldn't get a fix, even after half an hour. I'm going to give it one more try before I give up :(

Link to post
Share on other sites
Guest allanmac

My V5 didn't lock onto *anything* until I went into Mobile Uncle and started mashing various reset buttons (semi-kidding). I then went back to GPS Test and it spotted 10 and then quickly got a lock.

I don't know the exact incantation that I used but it was basically steps 2, 3 and 5.

I can't get a lock indoors but have never been able to with my Galaxy either. I think the windows in my building have metalized window tinting as the GPS signal goes to zero on phones and a standalone Garmin unit.

I didn't touch GPS.conf and the phone is not rooted.

So don't give up yet. :)

Edited by allanmac
Link to post
Share on other sites
Guest sandriderman

Having tried many things I was able to get the GPS locking on fairly quickly with GPS Monitor as previously mentioned. The problem I was then having was poor accuracy. When ever I would go past a junction it would get confused or if a road was running parallel with another road it would but me on the wrong one and do lots of re-routing.

A few days ago I took GPS Monitor off and tried GPS Status. This was no better, I then tried changing the "Sensor Filtering". Strong was very poor but I set it to weak today and had great results.

Its too soon to say if this will help in the long term and I will keep trying it but I was able to drive 10 miles through the middle of Doncaster without a single problem (using copilot).

Link to post
Share on other sites
Guest Dan Mullen

My V5 didn't lock onto *anything* until I went into Mobile Uncle and started mashing various reset buttons (semi-kidding). I then went back to GPS Test and it spotted 10 and then quickly got a lock.

I don't know the exact incantation that I used but it was basically steps 2, 3 and 5.

I can't get a lock indoors but have never been able to with my Galaxy either. I think the windows in my building have metalized window tinting as the GPS signal goes to zero on phones and a standalone Garmin unit.

I didn't touch GPS.conf and the phone is not rooted.

So don't give up yet. :)

I've tried everything. It sees between 10 and 13 satellites but never gets a fix. I'll try MobileUncle tools to see if there's anything that might help, but I'm completely stumped.

Link to post
Share on other sites
Guest allanmac

I did roughly the following:

1. MobileUncle>Engineer Mode>Engineer Mode (MTK)>Location>Location Based Service>AGPS>Reset to Default

2. EPO>Enable EPO + Auto Download

3. go back to YGPS and AGPS Restart

I assume the initial 10-13 satellite report is obtained via the network.

I never touched gps.conf and have not rooted.

Perhaps your phone is faulty but I do know that I was getting nothing at all for a long long time before I dug into the MTK settings.

It sort of sounds similar to your situation but it also sounds like you've tried everything. :|

Edited by allanmac
Link to post
Share on other sites
Guest allanmac

I just reset the V5 and duplicated what I did before.

I did the steps above and pressed: MobileUncle>Engineer Mode>Engineer Mode (MTK)>Location>Location Based Service>GPS>GPS(OFF)

Once the GPS(OFF) button was pressed there was a flurry of log messages and it started spotting satellites.

Link to post
Share on other sites
Guest nsmacd1

I just reset the V5 and duplicated what I did before.

I did the steps above and pressed: MobileUncle>Engineer Mode>Engineer Mode (MTK)>Location>Location Based Service>GPS>GPS(OFF)

Once the GPS(OFF) button was pressed there was a flurry of log messages and it started spotting satellites.

That's pretty much the only way I have found since having the phone to get any sort of GPS lock before launching any SatNav/location app (and I've tried quite a few different things!)

Link to post
Share on other sites
Guest Rico_89

Blew the power unit on my PC a couple of days ago arrrg still trying to get it sorted..

Anyway you should be able to get it working, both the V5s I've used can get GPS lock pretty quick now, I'm even using mine with run keeper and so far it has worked quite well.

Link to post
Share on other sites
Guest pawelde

there is many different ways proposed but you could try this one which worked for me...........in the video I did not delete the file I just renamed it to a .bak

Thanks dude. Works great!

Edited by pawelde
Link to post
Share on other sites
Guest bryfly

Been playing around with mobileuncle and just noticed that “Map” in mobileuncle shows my position accurately and does not move about, if this has picked up from GPS, why is GPS on Google maps so variable?

To have a look go to:- Mobileuncle > Engineer mode > scroll to location > open location based service > scroll top row to Map > open Map

Initially the map in mobileuncle showed my position somewhere in China until I did new “GPS config”

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.