Jump to content

Replaced Digitizer, now get nothing on screen? :(


Guest Lister Of Smeg
 Share

Recommended Posts

Guest Lister Of Smeg

Hi Guys,

I'm back, kinda....

After my phone died (Digitizer), I moved onto Galaxy Note N7000.... Whilst had this device (and still love it...) I thought I'd get a replacement Digitizer for the ZTE Blade. Cant let my first ever Android drift away...... :(

Some weeks/months of having this digitizer, I thought Id get around to installing it... All the time leading upto the Digitizer arriving, the phone booted and I could see whats on the screen, just couldnt touch any icons...

Anyway, after replacing the digitizer I now cant see anything on the screen, and not sure what its doing. Screen stays black (dont think it even powers on??) I get a short red flash of led, and then after a while the red light disappears. Then shortly after all the bottom lights seem to come on in a light white kinda colour. Still nothing on the screen, however if I press any of the Home, Menu, Back buttons, the phone vibrates....

Any idea's what I can do to revive it?? Or is it dead Dave, their all dead, everybodies dead Dave!!! for the phone... :(

Is there a magical reset switch/button, like a CMOS reset for PCs??

Cheers, Lister

Link to comment
Share on other sites

Guest Lister Of Smeg

With upto 107 views, and no comments.... I guess no one has replaced their digitizer before then??

Surely this has happened to others, whats with the magic reset button on the backs of the Blades too, as it doesnt really do much....

Cheers, Lister

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.