Jump to content

CWM 6.0.4.5 for MOTO G wtih F2FS support


Guest josalaito
 Share

Recommended Posts

Guest josalaito

ClockWork Mod Recovery v6.0.4.5

Device Source Tree: https://github.com/josalaito/android_device_motorola_xt1032

This should work on Unlocked BL devices.

Basically, i only add f2fs support to a1Pha repos and make my fork and my build, this should be bug-free.

First thing do you have to do if you installed alpha recovery before this is WIPE DATA/FACTORY RESET, or bugs related with data format or flashing don't dissapear.

THANKS: a1Pha for his repos.

Download: http://d-h.st/95A

Link to comment
Share on other sites

woo hoo, works great! For noobs:

 

copy the recovery.img to your adt-bundle-windows-x86_64-20131030\sdk\platform-tools folder

open an elevated command prompt wherever your adt-bundle-windows-x86_64-20131030\sdk\platform-tools folder is

type: fastboot flash recovery recovery.img

 

Job done!

 

PS this seems to have given me a Christmas boot animation - anyone else?

Also - I keep getting a warning about root access possibly having been lost along with an offer to fix it.

Also - the backup location is sdcard/clockworkmod/backup and CWM recovery can see the backups I have made in this location. But if I open the sdcard/clockworkmod/ folder with Root Explorer there is no backup folder - wtf?

Edited by dwl99
Link to comment
Share on other sites

Guest josalaito

woo hoo, works great! For noobs:

copy the recovery.img to your adt-bundle-windows-x86_64-20131030\sdk\platform-tools folder

open an elevated command prompt wherever your adt-bundle-windows-x86_64-20131030\sdk\platform-tools folder is

type: fastboot flash recovery recovery.img

Job done!

PS this seems to have given me a Christmas boot animation - anyone else?

Also - I keep getting a warning about root access possibly having been lost along with an offer to fix it.

Also - the backup location is sdcard/clockworkmod/backup and CWM recovery can see the backups I have made in this location. But if I open the sdcard/clockworkmod/ folder with Root Explorer there is no backup folder - wtf?

Christmas boot is because motorola have an app what changes boot, and hidden backups is a known bug, i set No Sdcard in Boardconfig but cwm doesn't read this stuff.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.