Jump to content

ZTE Blade Gen2 faulty sd card slot?


Guest deksman2
 Share

Recommended Posts

Guest deksman2

Hello everyone.

I'm in a bit of a pickle.

I got the THL W200 phone on Friday and its working great thus far.

I wanted to clean up my ZTE Blade and give it to my nephew.

Trouble is, the phone seems to refuse to ready any and all SD cards.

 

Last week I successfully managed to get the sd-ext partition to work on the Blade (and expanding the internal storage in the process), but then, days later, the phone suddenly lost ALL of the data on the sd-ext partition and effectively rebooted itself into a clean slate.

I looked at the internal memory and it was no longer at about 620MB (with the sd-ext), but 220MB as it was originally (before sd-ext).

I tried everything I could think of on the SD card, but alas, to no avail.

And just today, when I decided to clean up the phone from CWM and give it a fresh install, cleaning up everything in the process (except the SD card) and when it was time to install the ROM and GAPPs, the phone refused to read the SD card (2GB sd card that originally came with it nearly 3 years ago).

 

I tried another SD card (4GB from micronis) and its the same thing.

The Sd card reader on my laptop reads both cards just fine - it writes and removes files from them with ease, but the phone refuses to read the cards.

I should note, the Blade decided to stop reading higher capacity SD card (16GB) I had previously (months ago) almost suddenly, but the 2GB SD card I had put in as a replacement worked fine.

Some creative work on modifying the partitions of the 16GB card managed to get the card recognized on the Blade until I copied data to it (at which point it became unreadable again).

 

And now, I have no ROM installed, and no extra sd cards lying around to try out.

 

I downloaded ADB SDK developer tools in an attempt to install the ROM onto the phone without CWM, but alas, I got a strange error message after pushing the ROM to the phone - which made it impossible to complete the process and install the rom.

 

If someone could provide assistance, I'd appreciate it.

 

P.S. The 2GB card was formatted and tested formatted to FAT partition as well as FAT32. Neither seems to be affecting the Blade to recognize/mount the sd card anymore.

Edited by deksman2
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.