Jump to content

Solved: Restoring SMS Messages in KitKat (Specifically for SMS Backup+)


Guest zaxxon
 Share

Recommended Posts

Guest zaxxon

Hello fellow Blade lovers.  My apologies if this topic has already been posted in the Blade section... I did a few keyword searches to check first, but didn't find anything, so thought I might make a post just in case others are having the same problem.  Like many of you who are enjoying KitKat on our Blades (thanks to the great Zeelog for all his amazing work here) one of the minor problems I found was the change in permissions of how messaging works and how this affects SMS Backup/Restore apps - namely that when restoring text messages they don't re-appear.  To be clear, this is nothing to do with Zeelog, this is a change to the way KitKat deals with messaging.

 

I cannot take any credit for this - I did some searching on the internet and found a few different sites discussing this issue and possible solutions.  All I am doing here is just highlighting the way to get it working specific to Zeelog's KitKat for Blade users when using the app SMS Backup+ by Jan Berkel.  The theory would suggest that it would work for other similar apps as well, but I have only tested it with this app.  In brief (and from what I can make out), it relates to a change in KitKat where only the default designated SMS application has permissions to write to the SMS database.

 

In order to get it working, you need App Ops - which our KitKat has.  So here is what you do to restore your text messages:

 

1) Go into Settings>Privacy

2) Go into the first option Privacy Guard

3) Press the MENU button (or select the 3 square dots top right on the screen) and select Advanced

4) Scroll to the right twice so you get to the MESSAGING section

5) Scroll down until you find SMS Backup+ and then select it

6) Scroll down until you find the parameter Write SMS DB and you will see it is set to DENIED

7) Change it to ALLOWED

 

That's it.  Now when you restore your call and text logs you will get all your text messages back.  From what I can see, there is no reason why you cannot leave it set to ALLOWED.  Looking at the features of SMS Backup+, you can automate backups but not automate restores, so I cannot see any reason for putting it back to DENIED.  I cannot comment on any other backup/restore apps as this is my app of choice - but I guess that if you are not sure then DENY it once you have restored your logs.  Hope this helps.

Link to comment
Share on other sites

Guest Roeloff

Thanks for posting this, and I've done what you said, but I think my SMS Backup+ was working okay anyway with KitKat without doing this fix.

Link to comment
Share on other sites

  • 4 months later...
Guest uzicohen10

OK, i have the same problem with my new LG G3 device.

the AppOps is not supported anyome on 4.4.4 devices.

what else can i do?

 

BTW- when I start the SMS app, i see my entire SMS history for a blink, and then it disappears. Oh boy, Google, oh boy...

Link to comment
Share on other sites

Guest zaxxon

Hi uzicohen10.  I had exactly the same issue with my text messages - they appeared only for a second then disappeared until I figured out what was going on.  My humble ZTE Blade is running a custom 4.4.4 ROM and it supports App Ops (I just this second checked before posting this reply).  On my device, it's built into the ROM itself, but in your case, if it's no longer there, then you might be able to get it back again by installing Xposed from here.  Once installed and enabled, then install App Ops from here.  Hopefully that might sort out the issue for you.  Good luck.  Hope this helps.

 

EDIT - I forgot to mention - you will need root access on your device to make this all work.

Edited by zaxxon
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.