Jump to content

[ROM][4.1.1][B209] AOSP MOD [28/02/2015]


Recommended Posts

  • Replies 3.5k
  • Created
  • Last Reply

Popular Posts

About: My goal was to create a ROM that most of us wish the Y300 had of been sold with originally. I achieved that goal by converting the stock Huawei ROM back to AOSP, but I also improved some thing

Addons: 720p recording - http://www.any.gs/AGohR   Warning: The framerate will be low and you'll need to use a different camera app. The Google camera app won't work, but lgCamera does work.

I use Virgin Mobile, makes roaming on Movistar Chile. To solve this problem of the "R" in the status bar, copy a few lines of code from Universal Vendor SymAnd Y300 in "cust / hw / normal / xml / hw_d

Posted Images

When the icons aren't blue it means that you're basically not connected to Google Services. Go to settings, click Google and then press the options key and select to sync now.

 

For me it's basically always blue unless I'm really low on RAM and a Google service gets killed. That or if I've actually got no network access.

Thank you, now i understand

Link to post
Share on other sites

Performance Control has a better selection of options. I'm not sure if they change the OOM values to match too.

Your rom is the best, especially on gaming but the ram is very poor :(

Link to post
Share on other sites
Guest Gonzalox

Check that your APN settings are correct.

 

I don't use roaming so I can't test or debug it. You could try to forcefully disable roaming by giving root access to ES File Explorer and editing the build.prop file in /system/

 

Change this line "#ro.com.android.dataroaming=true" to "ro.com.android.dataroaming=false" and then reboot.

 

 

Edit: I bet it has something to do with the cust partition. This ROM uses the generic files and you might need a specific version. So the only way it could be fixed is if I knew what your exact stock ROM was.

 

 

Thanks friend, correct apn settings, change to false and still the same. I reactivate the national xposed romaing from the moment I solve it.

 

I use Virgin Mobile, makes roaming on Movistar Chile. To solve this problem of the "R" in the status bar, copy a few lines of code from Universal Vendor SymAnd Y300 in "cust / hw / normal / xml / hw_defaults.xml" in this ROM. The problem was solved. 
 
Here's the code: 
<!-- Start no-roaming patch beta -->
<string reg_plmn_custom="23211,23201;23207,23203;23212,23205;46000,46002,46007;24001,24007,24005;24405,24421;24002,24008,24004;46060,46008;23430,23433;21407,21404,21405,21418;21401,21406,21408,21416;21403,21409,21419,21421;73002,73007,73008"/>
<string hw_plmn_spn="1:21404,21407,21407,Yoigo;1:21404,26806,26806,TMN;1:21419,21409,21409,Simyo;1:21406,21406,21406,Pepephone;1:21406,21416,21416,Telecable;"/>
<string hw_cust_network_name="21407,Movistar;21403,Orange;21401,Vodafone;21404,Yoigo;21419,Simyo;21406,Pepephone;21416,Telecable;"/>
<!-- End no-roaming patch beta -->

* It should be a clean install for the changes to take effect.

 

Excuse my bad English, thanks.

Link to post
Share on other sites

Interesting. Weird how it only seems to effect a few networks and it's typical that Huawei has the problem due to all of their changes to the radio.

 

I'll include the lines in my next refresh. Thanks :)

Link to post
Share on other sites
Guest LotR656

Can you somehow put FM radio to lock in memory when I start it? Because FM and other app (like Clash of Clans) doesnt work in same time. Sometime it just stop to work, but sometime it starts to make some noise and I need to plug out headphones or to start FM again. Is that related to stock ROMs (because it is same to fonz93's ROM) or it needs fix.

I am now on KK (MahdiROM) and everything works fine. Also it works on SlimKat too.

Link to post
Share on other sites
Guest LotR656

I'm not sure if that would be a memory issue that causes it to get killed or an actual issue with the radio app. I'll do some tests shortly to see if I can replicate and fix it.

Thanks for quick reply. I hope you will fix that so I can use your ROM again.

In aospa I can use fmradio while playing clashofclans

Probably is a huawei fmradio app fault

I think it is huawei fm radio problem too. Because on other ROMs it works good if i remember well.
Link to post
Share on other sites

I just tested it as it is and I can play the game while also having the radio playing. I'll lock it in memory and might release a test update if you'd like to try it for a longer time.

Link to post
Share on other sites

It might. It'll say if it's flushed the memory or closed at least. If it's audio channel related though then that's pretty much impossible to fix, but I'm betting you simply run out of memory and the radio ends up getting killed.

Link to post
Share on other sites
Guest Takamoto

Hi all,someone have last version ostream for facebook offline? I've got the 1.3 downloaded by xda forum..thanks..

I didnt understand what you said. Are you asking for some app or?

Ostream is an app for to syncronized facebook offline..see the page xda forum..but I have an old version and now is not possible keep it on play store..I'like a last release..[emoji1]

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.