Jump to content

[DEV][ROM] SlimKat with display-caf


Guest chil360
 Share

Recommended Posts

Guest luca020400

The browser is very bugged :(

No white boxes but i have black boxes ( really big 1/3 of display )

I hope this can be fixed

Later I will build for cm11

And other small graphical glitches on tab switch ( browser )

EDIT : DPI to 240 fixed the black boxes

Edited by luca020400
Link to comment
Share on other sites

 

Caf-legacy is normal caf, they call it legacy because there is a new-caf (https://github.com/CyanogenMod/android_hardware_qcom_display-caf-new)

Edited by fonz93
Link to comment
Share on other sites

Guest DeSTRxL

The browser is very bugged :(

No white boxes but i have black boxes ( really big 1/3 of display )

I hope this can be fixed

Later I will build for cm11

And other small graphical glitches on tab switch ( browser )

EDIT : DPI to 240 fixed the black boxes

I don't have this problem with DPI at 200 (black box)..

Link to comment
Share on other sites

Guest luca020400

Building cm11 with display and media caf i got this error 

frameworks/av/media/libmediaplayerservice/StagefrightRecorder.cpp:66:25: fatal error: QCMediaDefs.h: No such file or directory
compilation terminated.

My fault ;)

 

Using TeamHackLG display-caf

In file included from hardware/qcom/display-caf/libhwcomposer/hwc_utils.h:33:0,
                 from hardware/qcom/display-caf/libqdutils/cb_utils.h:33,
                 from hardware/qcom/display-caf/libqdutils/cb_utils.cpp:28:
hardware/qcom/display-caf/liboverlay/overlayUtils.h:270:20: error: 'MDP_OVERLAY_PP_CFG_EN' was not declared in this scope
hardware/qcom/display-caf/liboverlay/overlayUtils.h: In function 'bool overlay::utils::isYuv(uint32_t)':
hardware/qcom/display-caf/liboverlay/overlayUtils.h:486:14: error: 'MDP_YCBYCR_H2V1' was not declared in this scope

Edited by luca020400
Link to comment
Share on other sites

Guest luca020400

With the ram to 380 ( more or less ) games that I could not run now travel safely

This is fantastic ;)

But I can't run some games with the display-caf ( in aospa work perfectly )

Link to comment
Share on other sites

Guest luca020400

Cyanogenmod 11 doesn't boot :(

The rom boots but the screen is black ( adb find mine device but is offline )

Edited by luca020400
Link to comment
Share on other sites

Guest chil360

Cyanogenmod 11 doesn't boot :(

The rom boots but the screen is black ( adb find mine device but is offline )

 

In vendor/cm/config/common.mk change persist.sys.root_access from 1 to 3. This enables 'Apps and ADB' root access. This will allow you to use adb logcat during boot so you can see what's going on.

Link to comment
Share on other sites

Guest chil360

Made some progess with video decoding...

 

If I add back my modified frameworks_av and set 

TARGET_QCOM_LEGACY_OMX := true

in BoardCommonConfig.mk then video playback works but the color formats are wrong. So I get a green bar at the top of the video and other wierd colors.

 

 

I copied the frameworks_av changes from legacymod/frameworks_av  to my slim based repo when I ported SlimKat as Dazzozo uses this repo in his CM11 rom. It's strange though - most of the changes are only activated when TARGET_QCOM_LEGACY_OMX is set but Dazzozo doesn't set this flag. So why the need for using this repo?? This must be why Luca and I have seen no difference when building roms without the modified frameworks_av.

Link to comment
Share on other sites

Guest luca020400
Guest luca020400

Mine aospa with display caf won't boot ( like cm11 ) stuck at he bootloader

 

Stuck at the bootloader but adb workf fine hahha

So the display-caf is bugged

I missed some libs ;)

I will try later

Edited by luca020400
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.