Jump to content

[DEV][ROM] SlimKat with display-caf


Guest chil360
 Share

Recommended Posts

Guest chil360

Decoder S/W works fine

Now tring to update OMX libs

Yes, I've noticed that. Can you make a list of the OMX libs that don't work - then we can stop them being installed. If we do that, then we should have a rom that fully works but with only software decoders.

 

Next, I'm going to port the prebuilt chromium patches (by Omni) to Slim. Chromium webview takes so long to build so this will speed up the build massively!

Link to comment
Share on other sites

Guest Y300-0100

Yes, I've noticed that. Can you make a list of the OMX libs that don't work - then we can stop them being installed. If we do that, then we should have a rom that fully works but with only software decoders.

Next, I'm going to port the prebuilt chromium patches (by Omni) to Slim. Chromium webview takes so long to build so this will speed up the build massively!

Do you have big ram consumption at the end of building? Because i do and it slow down build. I got 2gb ram + 2gb swap. Any sugestion? Just don't say buy more ram :) Edited by Y300-0100
Link to comment
Share on other sites

Guest luca020400

Aospa uses prebuilt chromiuim ;)

 

All the OMX are bugged :(

No one is working

MX Player + ARMv7 NEON codecs + S/W decoder can run every video

Edited by luca020400
Link to comment
Share on other sites

Do you have big ram consumption at the end of building? Because i do and it slow down build. I got 2gb ram + 2gb swap. Any sugestion? Just don't say buy more ram :)

Did you try to increase swappiness?
Link to comment
Share on other sites

Guest chil360

Near the end of the build, it starts linking libwebviewchromium.so which takes up huge amounts of ram and slows everything else down. I would increase your swap to 6gb this should help a little.

Link to comment
Share on other sites

Guest chil360

Camera updates pushed to github - changes in proprietary_vendor_huawei  & android_device_huawei_msm7x27a-common 

 

New build is uploading now will be available here when it's done - SlimDEV-u8833-4.4.4.build.8.9.20141028-CHIL360.zip.

Link to comment
Share on other sites

Guest luca020400

YouTube isn't working for me

Video Playback is bugged so every video cannot be played

@chil360 : Can we build using display-caf and media-legacy ??

Edited by luca020400
Link to comment
Share on other sites

Guest chil360

My experiments with the modified (legacymod) frameworks_av - see here - suggests that we need to work on frameworks_av not media-caf/legacy.

With this framework_av and TARGET_QCOM_LEGACY_OMX set then videos will play but with the wrong color format.

 

Black screen & chromium black boxes - looking in logcat I see ion/gralloc out of memory messages. So, I need to tweak the kernel to reserve more memory or maybe there is a memory leak somewhere.

Edited by chil360
Link to comment
Share on other sites

Guest luca020400

The camera doesn't work in aospa ( cannot find camera and stock camera isn't incluede ) :(

I found the problem ;)

Edited by luca020400
Link to comment
Share on other sites

Guest luca020400

 

Just looked at your repo...

 

You are missing this in msm7x27a.mk

PRODUCT_PACKAGES += \
    camera.msm7x27a

 

I already added it ;)

I tought it was already here

Chil this build is stable for normal use day?

No

DEV in the title is enought 

Edited by luca020400
Link to comment
Share on other sites

Guest juanpablocastillo

Ok, other question:

If LG has updated the L7 II to KitKat, they were used the display-caf and media-caf repos for it, right?

So, the OMX libs from the KitKat ROM of LG should work in the phone due to the similar specs, If LG has worked in that form.

I think Luca already tried that and it's not working.

Edited by juanpablocastillo
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.